LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 01-01-2010, 08:45 PM   #1
mf93
Member
 
Registered: Jun 2009
Distribution: Debian Squeeze, centOS
Posts: 229

Rep: Reputation: 36
spotty wireless with atheros wireless card and ath5k driver debian squeeze(testing)


I am running debian squeeze/sid on an hp dv7 laptop with an atheros wireless card and the ath5k driver. my wireless will work fantastically for days on end with no problem, but suddenly my wireless will stop connecting and it will say there are no available wireless networks however it will say wireless is enabled...pressing the wireless on/off switch does nothing, and usually after a couple of days the wireless will "magically" switch back on to its full power...I have tried restarting my internet, rebooting, restarting specific devices, bring wlan0 up and down...anyway here is the output of a couple of wireless commands
NOTE: the hw addresses have been zeroed out for security purposes
Code:
#iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=27 dBm
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

pan0      no wireless extensions.
ifconfig
Code:
ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:23:5a:30:2c:bf
          inet addr:192.168.1.50  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:65282 errors:0 dropped:0 overruns:0 frame:0
          TX packets:40210 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:90346708 (86.1 MiB)  TX bytes:3433809 (3.2 MiB)
          Interrupt:29 Base address:0xe000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:725 errors:0 dropped:0 overruns:0 frame:0
          TX packets:725 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:66348 (64.7 KiB)  TX bytes:66348 (64.7 KiB)

pan0      Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
ip
Code:
ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.50/24 brd 192.168.1.255 scope global eth0
3: wmaster0: <UP,LOWER_UP> mtu 0 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ieee802.11 00:00:00:00:00:00 brd 00:00:00:00:00:00
4: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff
5: pan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff
any help would be GREATLY appreciated since this has been bugging me for 2 months and i have tried everything to fix it
thank you!
 
Old 01-02-2010, 02:31 AM   #2
ofaring
Member
 
Registered: Feb 2006
Location: Ontario, Canada
Distribution: Debian, sometimes BSD.
Posts: 44
Blog Entries: 13

Rep: Reputation: 21
Without meaning to insult you, and presuming that you don't have a hardware issue, I have some basic questions.
How are you managing your internet? With the info you've given, I'm going to guess that you have an unencrypted/unprotected wireless router and GNOME or KDE network tools installed. To put that another way, when you first got online did your computer connect automatically, or did you have to configure the network?

If you do indeed have an open wireless router, from a terminal or console (as root, or using sudo), try typing:
Code:
# dhclient wlan0
If that works, then you likely need to setup a network profile either through a GUI or one of many methods available.
If you have WEP or WPA enabled, than the above command obviously won't work. In that case I assume that you've already setup a profile. Perhaps try using another method of connecting, either manual (preferable) or with, say, Wicd. Debian "testing" may be quite useable most of the time, but there are no guarantees, especially while they are in the process of switching to a new release model.

I'm beat; must get sleep. Good luck.
 
Old 01-02-2010, 07:38 AM   #3
mf93
Member
 
Registered: Jun 2009
Distribution: Debian Squeeze, centOS
Posts: 229

Original Poster
Rep: Reputation: 36
yes im using kde and i will usually use knetworkmanager to easily deal with my internet...i used to just let the router automatically assign my ip, nameserver, etc. using DHCP but i wanted to use this computer for file sharing and other things that require forwarded ports, and my ISP's default nameserver was just plain awful, it had a problem resolving hostnames for a multiplicity of applications. So i am manually configuring my conection so i can specify my static ip and the openDNS nameservers...when i say i am unable to connect i do not mean my wireless reception becomes poor, i mean i cannot connect to any wireless networks by any means(they do not show up when i scan for wireless networks). It is almost as if someone suddenly turns off the wireless card however I'm not sure what is doing that and nothing i press makes it any better. Thank you for responding

p.s. also, when i was using debian lenny i used the MADWIFI drivers instead of ath5k, and i never experienced this problem. However, MADWIFI is incompatible with linux kernel 2.6.28(im pretty sure this is the one) and above

Last edited by mf93; 01-02-2010 at 07:40 AM.
 
Old 01-02-2010, 08:15 AM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,782
Blog Entries: 1

Rep: Reputation: 413Reputation: 413Reputation: 413Reputation: 413Reputation: 413
Have you tried looking in the log files from around the time the connection drops? Problems like this can be brutally hard to figure out without some additional clues.
 
Old 01-02-2010, 10:44 AM   #5
mf93
Member
 
Registered: Jun 2009
Distribution: Debian Squeeze, centOS
Posts: 229

Original Poster
Rep: Reputation: 36
where would i find such logs on my HDD?
 
Old 01-02-2010, 04:49 PM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,782
Blog Entries: 1

Rep: Reputation: 413Reputation: 413Reputation: 413Reputation: 413Reputation: 413
Most system logs are stored in /var/log. Try looking for messages or syslog, those are the most likely to contain system level information.
 
Old 01-02-2010, 11:21 PM   #7
mf93
Member
 
Registered: Jun 2009
Distribution: Debian Squeeze, centOS
Posts: 229

Original Poster
Rep: Reputation: 36
alright thank you, i think i found something around the last date the internet stopped in kern.log
Code:
Dec 27 09:23:07 matt-pc kernel: [59230.367825] wlan0: deauthenticated (Reason: 7)
Dec 27 09:23:08 matt-pc kernel: [59231.364121] wlan0: direct probe to AP 00:00:00:00:00:00 try 1
Dec 27 09:23:08 matt-pc kernel: [59231.365871] wlan0 direct probe responded
Dec 27 09:23:08 matt-pc kernel: [59231.365883] wlan0: authenticate with AP 00:00:00:00:00:00
Dec 27 09:23:08 matt-pc kernel: [59231.367634] wlan0: authenticated
Dec 27 09:23:08 matt-pc kernel: [59231.367643] wlan0: associate with AP 00:00:00:00:00:00
Dec 27 09:23:08 matt-pc kernel: [59231.369853] wlan0: RX ReassocResp from 00:00:00:00:00:00 (capab=0x401 status=0 aid=4)
Dec 27 09:23:08 matt-pc kernel: [59231.369865] wlan0: associated
and then a couple of lines later
Code:
Dec 27 10:24:33 matt-pc kernel: [62917.204005] ath5k phy0: unsupported jumbo
this may or may not hint at it as i am not familiar with the intimate workings of the linux kernel...
anyway thank you for your help!

Last edited by mf93; 01-02-2010 at 11:33 PM.
 
Old 01-03-2010, 08:35 AM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,782
Blog Entries: 1

Rep: Reputation: 413Reputation: 413Reputation: 413Reputation: 413Reputation: 413
Wow. Wanna see something scary? Just google on "ath5k deauthenticated Reason 7". This is apparently a long-standing bug with the ath5k driver and encrypted networks. People on the Arch forums suggest that the 2.6.29 kernel is OK, at least on Arch. Other suggestions are that this only affects WPA-PSK encryption. If you're using that you might try other forms of encryption, or (shudder) none at all. You might even upgrade to the absolute latest kernel and see if the bug is fixed yet although I've seen some suggestions that it isn't.

The short answer here is that you probably need to experiment with different kernels. It isn't clear what is causing the problem with the ath5k driver, but it is widespread. As an alternative you could drop back to Lenny and the madwifi drivers.
 
Old 01-03-2010, 11:19 AM   #9
mf93
Member
 
Registered: Jun 2009
Distribution: Debian Squeeze, centOS
Posts: 229

Original Poster
Rep: Reputation: 36
ok well im glad i now know at least what the problem is even if a tenable solution is not currently available...anyway thank you very much for your help i greatly appreciate it!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Where to find the kernel driver (ath5k?) for atheros AR5416 card Weibin Zheng Red Hat 10 12-01-2009 06:53 AM
[SOLVED] Atheros Madwifi driver not working on debian squeeze mf93 Linux - Wireless Networking 3 09-28-2009 11:52 AM
Debian (squeeze) MadWifi D-Link wireless card DWL-G650 not recognizied tizak Linux - Networking 1 04-27-2009 09:20 AM
Atheros Wireless(built-in card) and Debian sudya Linux - Wireless Networking 3 03-07-2006 07:24 PM
Planet 8310 wireless card driver? (atheros) nvidiausr Linux - Wireless Networking 4 11-01-2004 10:44 AM


All times are GMT -5. The time now is 08:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration