LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Speedtouch 121G on CentOS (http://www.linuxquestions.org/questions/linux-wireless-networking-41/speedtouch-121g-on-centos-492451/)

Andrftw 10-14-2006 08:15 PM

Speedtouch 121G on CentOS
 
Hi guys (and girls),

i'm getting crazy here, today i downloaded the centos live cd, i burned it, used it etc. but now i want to add my speedtouch 121g to centos, so that i can browse on the internet. The USB WLAN reciever is a SpeedTouch (Thompson Alcatel) 121G.

For some reason CentOS doesn't have the ndiswrapper, so i need to install it, i downloaded it, extracted it, but when i try to install it, it just doesn't work.

I'm a Linux newb (i started today with linux), so can somebody plz help me, i'm really getting crazy :(

-x-

Andreas :)

Andrftw 10-15-2006 08:22 AM

Well, now i used the Kubuntu Live Cd, i installed a ndiswrapper-utils.***.deb, so now ndiswrapper works a bit. I configure it like this:

Code:

cd /home/ubuntu/setup/Driver
sudo ndiswrapper -i BT4501G.inf

Then it starts installing...

Code:

sudo ndiswrapper -l
This gives me:

Code:

b4501g driver present, hardware present
So it looks okay

Code:

sudo modprobe ndiswrapper
That also works

Code:

sudo iwconfig wlan0 ESSID myssid
Well that one doesn't give an error, but when i check with

Code:

sudo iwconfig wlan0
It is ESSID:any/none

So what goes wrong?

pxumsgdxpcvjm 10-30-2006 05:48 AM

Quote:

Originally Posted by Andrftw
Code:

sudo iwconfig wlan0
It is ESSID:any/none

So what goes wrong?

I had to do:
Code:

sudo iwconfig wlan0 Mode Managed
before. When I tried to do it in other order it didn't worked. You can see the full article on how I did it in:
http://www.darandandunguen.org/2005/...linux-parte-i/
For the english version, click on the flag.

Andrftw 10-30-2006 10:01 AM

Quote:

Originally Posted by pxumsgdxpcvjm
I had to do:
Code:

sudo iwconfig wlan0 Mode Managed
before. When I tried to do it in other order it didn't worked. You can see the full article on how I did it in:
For the english version, click on the flag.

Thanks i'm reading it, but then you say this:

iwconfig wlan0 mode "Managed"
iwconfig wlan0 essid "SuperCoco"
iwconfig wlan0 key "s:EstoEsArriba"
ifconfig wlan0 192.168.0.128 netmask 255.255.255.0

Well the first 2 en the 4th (mode,essid & local ip and netmask) are fine, but i got a 128 WEP key, so how do i fill in this one (the 3rd)?

These are my router options:

Andrftw 10-30-2006 10:02 AM

Sorry these are my router options

http://www.glowfoto.com/viewimage.ph...=8771&srv=img3

Andrftw 10-31-2006 12:52 PM

How do i fill in my WEP key, because there are several ways, plz look at my screen for my routeroptions, that could help.

It's 128 bits WEP...

iwconfig wlan0 key "mykey"
iwconfig wlan0 key open "mykey"
iwconfig wlan0 key "s:mykey"
etc.

Which one do i have to use?

Andrftw 11-01-2006 08:51 AM

Quote:

Originally Posted by Andrftw
How do i fill in my WEP key, because there are several ways, plz look at my screen for my routeroptions, that could help.

It's 128 bits WEP...

iwconfig wlan0 key "mykey"
iwconfig wlan0 key open "mykey"
iwconfig wlan0 key "s:mykey"
etc.

Which one do i have to use?

Yes i got it working!!!@ :DDDDDDDD :) :) :) :) :) I had to use:

iwconfig wlan0 key open "mykey"


All times are GMT -5. The time now is 09:30 PM.