LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Closed Thread
 
Search this Thread
Old 12-10-2008, 11:41 AM   #1
Zebis
LQ Newbie
 
Registered: Dec 2008
Posts: 15

Rep: Reputation: 0
slackware 12.1 wpa_sipplicant wont connect.


I have spent alot of time lkooking arround for how to set this up but I cannot seem to find a guide for what I am looking for. I tried to go off of what I found and tried to modify it to what I am trying to do, but without luck.

Here are what my files look like:

wpa_supplicant.conf
Code:
# See /usr/doc/wpa_supplicant-0.5.10/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=1
  ssid="Zebis_Loaner_Wireless"
  proto=WPA2
  key_mgmt=WPA-EAP
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  eap=TTLS
  identity="test"
  password="test"
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
network={
  key_mgmt=NONE
  priority=0
}
rc.local
Code:
#!/bin/sh
#
# /etc/rc.d/rc.local:  Local system initialization script.
#
# Put any local startup commands in here.  Also, if you have
# anything that needs to be run at shutdown time you can
# make an /etc/rc.d/rc.local_shutdown script and put those
# commands in there.

set -x
/etc/rc.d/rc.wifi_wpa
rc.wifi_wpa
Code:
#!/bin/sh
set -x

wpa_supplicant -ieth0 -Dwext -c/etc/wpa_supplicant.conf -Bw
sleep 10
wpa_cli -ieth0 add network
wpa_cli -ieth0 enable_network 0
route add default gw 192.168.4.105 dev eth0 &
sleep 3
rc.inet1.conf
Code:
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""
WLAN_WPA[1]="wpa_supplicant"
WLAN_WPADRIVER[1]="wext"
WLAN_WPACONF[1]="/etc/wpa_supplicant"

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"
I am unable to connect to my WAP. If I run wpa_gui I can see that the status stays at scanning indefinately. Also most recently I noticed something that was odd... I restarted MY pc after it locked up and I again launched wpa_gui and again it was showeing scanning and not changing. However it showed me as having an IP address of 192.168.15.153 which is a valid address given the networks we have available here. It is an unsecured network and I was not actually connected to it as I was unable to ping anything or do any network related tasks. Strange.
 
Old 12-10-2008, 01:58 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate.
 
  


Closed Thread

Tags
slackware, wpasupplicant


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware 12.1 wpa_sipplicant wont connect. Zebis Linux - Wireless Networking 6 12-15-2008 06:24 PM
slackware 10.2 wont connect to DHCP ichiroboston Linux - Newbie 2 06-29-2006 10:47 AM
Wont connect !? muppski Linux - Games 0 07-27-2005 11:47 AM
mandrake client wont connect to slackware server Fantus Linux - Networking 0 12-18-2004 08:25 PM
Wont connect schindler Linux - Networking 3 10-21-2004 10:55 AM


All times are GMT -5. The time now is 06:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration