LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 09-06-2004, 12:46 AM   #1
jacksmernov
LQ Newbie
 
Registered: Sep 2004
Posts: 2

Rep: Reputation: 0
slackware 10 startup/hotplug ndiswrapper/acx100 driver


I've tried two solutions for my wireless dlink dwl 650+ on slackware 10

ndiswrapper and the acx1xx driver at acx100.sourceforge.net

I have gotten them both to work at install. But I can't get ndiswrapper to work at startup. I can get acx1xx to work at startup. But it still dosn't work when i replug in the card.

for acx1xx i use the start_net script that comes with the driver. I reference it in /etc/rc.d/rc.local

for ndiswrapper I had a script that went something like this

Code:
#/bin/sh

modprobe ndiswrapper
iwconfig wlan0 essid xxxxx
ifconfig wlan0 up
dhcpcd wlan0
I reference this script in /etc/rc.d/rc.local

When the script runs iwconfig and ifconfig complain that they can't find wlan0. The odd thing is that if i run this script a second time it works. It's as if it runs modprobe ndiswrapper in the background while it exicutes iwconfig and ifconfig. So that they run before modprobe has a chance to finish.

So what I'd like to know is how to get ndiswrapper working at startup and how to get either one of them hotplugable

PS... No i'm not trying to run both of these at once
 
Old 09-06-2004, 02:14 AM   #2
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
I get a device called /dev/ndiswrapper once ndiswrapper is loaded. If you get the same thing (I'm using udev and not devfs but I don't think it makes a difference), you could change the script a bit to wait for /dev/ndiswrapper to appear. Something like:

modprobe ndiswrapper
while [ ! -c -/dev/ndiswrapper ]; do /bin/true; done
iwconfig ...
 
Old 09-06-2004, 06:33 PM   #3
kersten78
Member
 
Registered: Nov 2003
Location: Minneapolis, MN
Distribution: Slackware, Debian, Gentoo, openSuSE
Posts: 357

Rep: Reputation: 30
jacksmernov, I was having the exact same problem. For some reason modprobe ndiswrapper takes a few seconds to activate everything. I created this script /etc/rc.d/rc.wlan0
Code:
#!/bin/sh
#rc.wlan0
modprobe ndiswrapper
sleep 6
ndiswrapper -l
iwconfig wlan0 key open mykeyxxxxx
iwconfig wlan0 essid myessid
ifconfig wlan0 up
dhcpcd -t 10 -d wlan0
For some reason adding the sleep 6 command gives it enough time to activate ndiswrapper. Note also that the line ndiswrapper -l isn't necessary, I just like to see that the driver is loaded...I guess it was just a troubleshooting thing at first. Since you already have the script executable and added to your rc.local file, adding the sleep 6 line should solve your problem. Good luck and let us know if it works.
-Kris
 
Old 09-07-2004, 12:14 AM   #4
jacksmernov
LQ Newbie
 
Registered: Sep 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Putting in a while loops worked for ndiswrapper. But it still dosn't work after unpluging and repluging in. How do i get it to be hot swapable?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10: How do you disable hotplug at startup? jtp51 Slackware 6 10-29-2004 05:14 PM
start_net problem with acx100 driver daniela Linux - Wireless Networking 2 09-21-2004 08:55 AM
ACX100 driver on Slackware 10 oudent Linux - Wireless Networking 0 07-16-2004 12:35 AM
slackware ndiswrapper startup! trey85stang Linux - Wireless Networking 5 07-06-2004 12:46 PM
compiling acx100 driver in RH9.0 Andmann Linux - Networking 0 09-25-2003 07:54 PM


All times are GMT -5. The time now is 05:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration