LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 09-12-2003, 05:57 PM   #1
Belize
Member
 
Registered: Jul 2003
Posts: 113

Rep: Reputation: 15
Setting up my wireless LAN internet on my slack laptop :D


Greetings
I installed slackware 9 on my new laptop.
When installing, I set my network to be DHCP for now.

My wireless lan pcmcia card is RoamAbout 802.11 DS ( Cabletron )

The slackware detects the wireless-lan pcmcia card and one of the two lights lights up. The other one that indicates the traffic doesnt light up. ( which will actually show if its connected )

I copied my network interfaces from my windows :

LAN ( This will be eth0 )
IP 127.0.0.1
Broadcast 255.255.255.0
Netmask 255.0.0.0

Internet ( Will be eth1 )
IP 10.4.2.235
Broadcast 255.255.255.0
Netmask 255.0.0.0

I set those values in /etc/rc.d/inet1 ( or something similar ).

There is some key entered that I saw when checking the details of my wireless interface in windows. Is that some password I should ask the admin of the school network for ?

What should I do next to make my internet works ?

Thanks in advance for the replies, be happy

Last edited by Belize; 09-12-2003 at 06:01 PM.
 
Old 09-12-2003, 08:06 PM   #2
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
First of all, the 127.0.0.1 ip address is always already in use by the system, you must change that address for device eth0. Most people use 192.168.x.x for their local networks, again, 127.0.0.1 is taken.

As for device eth1, see if your card is a 16-bit pcmcia card (not a cardbus card) by typing "/sbin/cardctl status" at a console, it should tell you if it's a pcmcia or cardbus card. If it's a pcmcia card, take a look at /etc/pcmcia/wireless.opts, it is well-commented and should be pretty much self-explanatory, put your wireless-specific settings there, including what sounds like your encryption key ("some key entered that I saw..."), read the commentary throughout the file to see how to do this.
 
Old 09-13-2003, 04:09 AM   #3
Belize
Member
 
Registered: Jul 2003
Posts: 113

Original Poster
Rep: Reputation: 15
I changed my IP on eth0 to 192.168.20.4

this is what printed when I typed /sbin/cardctl status

Socket 0:
5V 16-Bit PC Card
function 0: [ready]

after that I looked in /etc/pcmcia/wireless.opts and there I think saw the appropriate driver for my card ( Lucern RoamAbout ). But I dont know the key for now, I will ask the teacher on monday. Also, I dont understand what the other options are about : should I leave them the way they are ?
Peace
 
Old 09-13-2003, 12:42 PM   #4
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
Good, so you have a 16-bit pcmcia card and thus can use /etc/pcmcia/wireless.opts and /etc/pcmcia/network.opts to setup your wireless card.

You'll need to edit /etc/pcmcia/network.opts and /etc/pcmcia/wireless.opts correctly for your particular site. Note that the "Lucent RoamAbout" section in wireless.opts that you're referring to is just an example and is not functional.

If you could post the info specific to your situation, then we can get those numbers into the right places in those files, DO NOT post the key you spoke of earlier, we will refer to that with x's in place of the digits, also do not post the essid or "SSID" name either, we will refer to that as "essidname", and you can simply substitute the correct characters. Here's the info you need to have in front of you before we begin:

1. network setup used by your school, no doubt they are assigning ip addresses via dhcp, you need to verify that. If they are not using dhcp, then you need to know what ip address is assigned to you by them and what the addresses of the gateway and dns servers are (they may be the same address).

2. wireless setup used by your school, including ssid name(again, do not post the name), WEP encryption key (again, do not post this key), the MAC address of your wired (eth0) device and the wireless card, this is a number like this: "00:ED:A0:B4:E1:09" you'll need this number in order to differentiate this card in those *.opts files from your wired device, you should be able to get these MAC address numbers by doing a /sbin/ifconfig -a, which will list them in the "HWaddr" field.

When you've got this info, post back and we'll go through the edits you need to make.
 
Old 09-24-2003, 01:18 PM   #5
Belize
Member
 
Registered: Jul 2003
Posts: 113

Original Poster
Rep: Reputation: 15
Hi again.
I talked with the school admin, but he refused to tell me the network key ( there were some issues of students abusing it ) and he said I should bring my laptop to him for him to set it up.

So please post the steps that the admin should go over so he configures my wireless lan on my laptop. Most probably I will go to him with my laptop, and we open that thread to figure out the right way of configuring the net. Thanks in advance
 
Old 09-24-2003, 06:46 PM   #6
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
First of all, the admin is going to have to trust you with the key, it's going to easily viewed by you once the configuration is done.

Second, keys larger than 64bit may or may not work, that's something to ask about before bothering to go any further, what the key length is.

The changes need to be made to /etc/rc.d/rc.inet1 and /etc/pcmcia/wireless.opts, I don't have enough of your info to tell you what to put in those files, have the the admin look at both of them, they are well commented and the admin should be able to put the right numbers in the right places. Post back any specific questions the admin might have.
 
Old 09-29-2003, 02:20 PM   #7
Belize
Member
 
Registered: Jul 2003
Posts: 113

Original Poster
Rep: Reputation: 15
yo I got the network key

A boy next door configured his wireless lan on red hat 9 easily, with the X internet connection manager ( something like that ). Ill try to do it trough X too. Good luck to me
 
Old 09-29-2003, 05:30 PM   #8
Belize
Member
 
Registered: Jul 2003
Posts: 113

Original Poster
Rep: Reputation: 15
yo, why isnt there a way to do it easily in slackware the way its configured in red hat ! .
There is no such tool to configure the network card in X, and when in consoled I configured /etc/rc.d/inet1 , /etc/pcmcia/wireless.opts and network.ops bwoy I got lost. I edited all things and when rebooting, again, it doesnt f***ing work.

I wanted to copy wireless.opts and network.opts to the c:\ directory ive mounted but it sais read only drive. How can I make it writable ? Also, how can I see the startup log so I can see what the exact error was ? I really want to fix it and continue using slack, rather than redhat.
 
Old 09-29-2003, 05:43 PM   #9
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
Slackware puts their efforts in other places than Red Hat does, we all end up benefiting from both approaches. Slack does have a config tool for the network which you can try, it's <I'm booting a slack box and checking...brb>.

Is the "c:\" directory you mounted an ntfs(windows XP, 2000, etc) volume? or is it vfat? (windows 95, 98, ME) if ntfs, writing to it is not considered safe by the system, this is why it's mounted read-only, unless of course you specified read-only when mounting it, or it's specified read-only in your /etc/fstab. Try using a floppy formatted vfat for that kind of thing. Both os's should be able to read it, or a keychain usb "drive" works also for me.

Startup log is viewable by doing "dmesg | less" from console, then up/down arrows and/or page up/down to scroll through it.

Last edited by akaBeaVis; 09-29-2003 at 05:44 PM.
 
Old 09-30-2003, 12:50 AM   #10
Belize
Member
 
Registered: Jul 2003
Posts: 113

Original Poster
Rep: Reputation: 15
whats that utility I can use ?
yes, c:\ is a ntfs partition
can I mount that partition so I can write on it ? ( do you think that is safe )
ok I will try using the floppy later cause now I gotta go to school.
 
Old 09-30-2003, 07:18 PM   #11
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
Sorry, fell asleep...anyway the utility for slack is "netconfig", it's not going to do much for your wireless settings though.
 
Old 10-01-2003, 09:34 AM   #12
Belize
Member
 
Registered: Jul 2003
Posts: 113

Original Poster
Rep: Reputation: 15

and what about my other quesions
 
Old 10-01-2003, 05:35 PM   #13
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
You mean about writing to the ntfs partition? I really don't know, I don't have any ntfs partitions on any machine here. Perhaps the slackware forum here at LQ would help.
 
Old 10-01-2003, 05:51 PM   #14
hakcenter
Member
 
Registered: Apr 2003
Location: Not to far from the computer screen
Distribution: RedHat 9.0
Posts: 324

Rep: Reputation: 30
if you want read/write to a ntfs partition, you need a kernel that has the support for it...

Either recompile your current kernel from source, or find a alternate kernel that is pre-compiled for ntfs partitions.
 
Old 10-01-2003, 06:06 PM   #15
Belize
Member
 
Registered: Jul 2003
Posts: 113

Original Poster
Rep: Reputation: 15
hello again

I really worked on my slackware and after editing all things right ( I think ) this is what appears on the startup log ( that cant be viewed with dmesg | less, dmesg shows that everything works - right MAC address, etc. )

-netmask doesnt match route access
and this appears when it loads the wireless drivers ( wireless.opts I suppose )
-[cardctl 69](not exactly the same ) +ioctl operation not supported

on all my options I have written for eth1

IP 10.4.2.14
Broadcast 255.255.255.0
Netmask 255.0.0.0

this info I copied from my win settings
network.opts I think asks for Network IP - by default it was 10.0.1.0 . I left it blank, as I dunno what to write there.

Also on all files I left DHCP = yes ( so that it uses DHCP )

And Im kinda not sure about the broadcast/netmask IPs.

Hope that helps you kind people help me
Peace
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to connect to internet using the internal 802.11b/g wireless LAN in laptop bin75 Linux - Wireless Networking 1 04-21-2005 09:48 AM
connecting to the internet via wireless through Intel PRo/Wireless LAN 2100 3B Mini P k_wjss Linux - Newbie 1 09-28-2004 05:00 PM
Wireless problems on a laptop... I have LAN no internet spicyohaggis Linux - Wireless Networking 14 07-30-2004 06:42 AM
setting up internet in small LAN lukalinuix Slackware 8 02-10-2004 06:28 AM
Setting up wireless LAN tommylkc Linux - General 4 07-03-2002 12:51 AM


All times are GMT -5. The time now is 06:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration