LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 04-22-2007, 12:01 PM   #16
dahouse
LQ Newbie
 
Registered: Apr 2007
Posts: 23

Original Poster
Rep: Reputation: 16

Didn't work, but now I'm running kubuntu and it does.
 
1 members found this post helpful.
Old 04-22-2007, 02:45 PM   #17
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I'm glad you got it working, but it is too bad you had to give up on Gentoo. To be honest, I don't think it was a kernel configuration problem, but then again, I don't have any prime suspects either. You could always try tweaking the Kubuntu kernel and see if that gets you the audio and boot performance you need.
 
Old 04-29-2007, 09:29 AM   #18
rocher
LQ Newbie
 
Registered: Apr 2007
Location: Prague
Distribution: Gentoo
Posts: 3

Rep: Reputation: 0
I had the same problem with my gentoo laptop when I upgraded to 2.6.20-gentoo-r7 kernel. My wifi is: Intel Corporation PRO/Wireless 3945ABG Network Connection and I use ipw3945 driver.

Now it works fine, the problem was, that I had to compile all the IEEE80211 stuff into the kernel (not as modules), ie this: <*>, not <M> option.
 
Old 04-29-2007, 10:38 AM   #19
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
Originally Posted by rocher
I had the same problem with my gentoo laptop when I upgraded to 2.6.20-gentoo-r7 kernel. My wifi is: Intel Corporation PRO/Wireless 3945ABG Network Connection and I use ipw3945 driver.

Now it works fine, the problem was, that I had to compile all the IEEE80211 stuff into the kernel (not as modules), ie this: <*>, not <M> option.
Thanks for posting that bit of info. Prior to compiling into the kernel did you notice if the modules were all loading? The reason I'm asking is that I've always been compiling the ieee80211 stuff as modules since I switch between bcm43xx and ndiswrapper and I've never had any trouble. However, this could easily fall into the "Your milage may vary" dept.


Nice first post by the way. Welcome to LQ!
 
Old 04-30-2007, 08:12 AM   #20
rocher
LQ Newbie
 
Registered: Apr 2007
Location: Prague
Distribution: Gentoo
Posts: 3

Rep: Reputation: 0
Actually, I don't know. I forgot to check lsmod before I compiled the new kernel. I suppose, that these _ieee modules weren't loaded, as they weren't in the modules.autoload.d configuration.
 
Old 04-30-2007, 12:41 PM   #21
dahouse
LQ Newbie
 
Registered: Apr 2007
Posts: 23

Original Poster
Rep: Reputation: 16
The appropriate modules were loaded as modules, but I made them part of the kernel ie. * vis a vis M. The only thing I didn't do was copy over the system map file. There was no such explanation in the Gentoo handbook, so I had never done it, but I never found a good guide to do it on the internet, so I didn't bother.

I'm fairly certain I'm going to switch to Ubuntu Studio when it comes out though. I'm very happy with the simplicity of kubuntu, but it lacks the performance for audio I need.

INTERESTING FACT: without the RT kernel, Gentoo's latency got to 42, with Kubuntu, it was 43ms. Not that bigga difference.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error: Error for wireless request "Set Mode" (8B06) : invalid argument "roaming" penguin chick Linux - Wireless Networking 5 08-22-2008 02:16 PM
I cant set WEP key! "Operation not supported" ??? EcceVery Linux - Wireless Networking 3 11-19-2006 01:06 PM
Error for wireless request "Set Encode" (8B2A), help me jiasen_ma Linux - Wireless Networking 4 05-25-2006 03:33 PM
Error for wireless request "Set Encode" (8B2A) for ath0 Suse 9.0 debasisdan Linux - Wireless Networking 2 04-19-2006 02:28 AM
Startup Errors with wireless networking Error for wireless request "Set Encode" Cryptoniks Linux - Wireless Networking 1 03-21-2006 08:06 AM


All times are GMT -5. The time now is 01:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration