LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 11-25-2004, 02:52 PM   #1
ner0
LQ Newbie
 
Registered: Jun 2004
Posts: 18

Rep: Reputation: 0
Routing between a wired ethernet (internet connection) and a wireless card (home net)


Hi!,

Firstly I would like to thank you all for your help with my previous problem concerning selecting my ethernet (eth0) as the internet connection. This all now works fine, and eth0 is totally configured.

My problem at this stage is enabling the wireless interface also, I found that doing a "netconfig" would remove my eth0 settings, and only configure the wireless network. I also found that in order for the eth0 to work, eth1 had to be disabled, this; I presume is a consequence of misconfigured routing.

from a "route -n" query, I get the correct destinations of the eth0 device, along with gateways etc, and this gateway is also defined as default in /etc/rc.d/rc.inet1.conf, but nothing from eth1 (i know this should happen because It isn't told to use dhcp in the rc.d/rc.inte1.conf)...

I know my eth1 device is detected from both lspci and ifconfig, and the penultimate question I have is:

How can i configure my routing (i am assuming this is the issue) to route network packets through eth1, and internet packets through eth0...

preferably, but not essentially, I would aspire to do this without the need of going offline.
 
Old 11-25-2004, 03:34 PM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

What you would do is make eth0 the default route, and do 'route add -net 192.168.0.0 netmask 255.255.255.0 eth1' (assuming your network is using the 192.168.0.x address space). That would route all internal network traffic to eth1, and everything else should go to eth0. Hopefully.

You shouldn't have to go offline to do this.

Dave
 
Old 11-25-2004, 05:51 PM   #3
ner0
LQ Newbie
 
Registered: Jun 2004
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks for the reply Dave, I had thoughts of it being along those lines, however I get an error from SIOCADDRT saying "No Such Device", I personally have no idea what this means, any ideas as to what I should refine?
 
Old 11-25-2004, 08:13 PM   #4
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi again.

Try doing 'ifconfig eth1 up' first. I'm guessing that's what the problem is, however I get the same error if I try to configure a device which doesn't exist, so it might be a driver issue.

Dave
 
Old 11-26-2004, 07:33 AM   #5
ner0
LQ Newbie
 
Registered: Jun 2004
Posts: 18

Original Poster
Rep: Reputation: 0
yeah, I'd also think it would be a driver issue now, however I know the eth1 has been working. no kernel modules have been changed, only the inet1.conf.

still getting the same error by the way, so right now I'm pretty confused
 
Old 11-28-2004, 01:54 PM   #6
ner0
LQ Newbie
 
Registered: Jun 2004
Posts: 18

Original Poster
Rep: Reputation: 0
Ok, I realise this thread died, but after acknowledging the idea that my card may infact not be recognised by my system I tried other things...

I've come across "iwconfig" and it certainly does appear that "eth1" is up and connected to the network, here's my results of iwconfig:

Quote:
eth1 IEEE 802.11-DS ESSID:"belkin54g" Nickname:"dtop"
Mode:Managed Frequency:2.462GHz Access Point: 00:30:F1:AF:B8:08
Bit Rate:2Mb/s Tx-Power=15 dBm Sensitivity:1/3
Retry min limit:8 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality:92/92 Signal level:5/153 Noise level:112/153
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
would lead me to believe theres just one simple thing I could do to fix this, but for the life of me I can't find out what.

;note, In /etc/rc.d/rc.inet1.conf, the USE DHCP for eth1 is set to OFF, this is one suspicion I have as to why it does not work, however enabling it scraps my settings for eth0.

your help is appreciated

Paul

Last edited by ner0; 11-28-2004 at 01:57 PM.
 
Old 11-28-2004, 02:07 PM   #7
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
What do you get when you run ifconfig on its own (after doing 'ifconfig eth1 up')?

Dave
 
Old 11-28-2004, 05:35 PM   #8
ner0
LQ Newbie
 
Registered: Jun 2004
Posts: 18

Original Poster
Rep: Reputation: 0
heres the ifconfig results; sorry I'm 3 hours late lol...

Quote:
eth0 Link encap:Ethernet HWaddr 00:0C:76:A8:1B:C0
inet addr:my.ip.address.here Bcast:255.255.255.255 Mask:255.255.248.0
EtherTalk Phase 2 addr:65280/9
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3048646 errors:0 dropped:0 overruns:0 frame:0
TX packets:90263 errors:0 dropped:0 overruns:0 carrier:0
collisions:0
RX bytes:215378546 (205.4 Mb) TX bytes:9026295 (8.6 Mb)

eth1 Link encap:Ethernet HWaddr 00:09:5B:91:A4:A4
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:673 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0
RX bytes:235574 (230.0 Kb) TX bytes:0 (0.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
EtherTalk Phase 2 addr:0/0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:46914 errors:0 dropped:0 overruns:0 frame:0
TX packets:46914 errors:0 dropped:0 overruns:0 carrier:0
collisions:0
RX bytes:5689656 (5.4 Mb) TX bytes:5689656 (5.4 Mb)
hope this helps.
 
Old 11-29-2004, 02:12 AM   #9
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
It looks like you need to configure eth1 (i.e. give it an IP address etc). If you're using DHCP for eth1, then try running 'dhclient eth1'. If not then you can use ifconfig to set up the interface.

I'm not sure why you were getting 'No such device', though.

Dave
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WIreless won't surf internet unless wired card has IP even if not plugged in tuxkwb Linux - Wireless Networking 4 12-28-2006 02:07 AM
Wireless-2-wired routing question dolvmin Linux - Wireless Networking 1 11-06-2005 12:31 PM
No internet connection, ethernet card id ok bacan Suse/Novell 3 06-03-2005 04:27 PM
Wireless Laptop to Wired ethernet via Linux PC (wired/wireless) sambartle Linux - Wireless Networking 0 01-30-2005 05:37 AM
Laptop-net on wired/wireless interface blueplazma Linux - Wireless Networking 2 12-24-2004 03:29 PM


All times are GMT -5. The time now is 03:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration