LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-05-2006, 06:10 AM   #1
sabbathpriest
LQ Newbie
 
Registered: Sep 2005
Location: Ft Lauderdale
Distribution: Lispire 5.0
Posts: 6

Rep: Reputation: 0
Router issue (Belkin non wireless)


I have a DSL modem connected to a Belkin 4 port cable/DSL Router (Model F5D5231-4) and two computers connected to the router, one running on Windows XP Home and my Linspire 5.0 box. The Windows computer installed the router software and connected immediately, but my Linspire box will not connect through the router, even though this computer connects to the web flawlessly when I just plug it to the DSL modem directly I've tried the following:

1) Restart Linspire 5.0 (This system seems to detect ans install everything on restart, so it seemed like a good option)

2) Restart the router

3) Type 192.168.1.254 on the address bar (That's the Modem IP Address)
I contacted Belkin's tech support and this is the answer I got:
Quote:
We understand that you are unable to connect to the Internet, from your Linux computer. On the computer, check if you have an IP address in the range of 192.168.2.x. If not assign a static IP address in the range of the router, that is 192.168.2.x (x=2to200).

4) Went to Settings > Control center > Network > Network settings and Profiles (Logged in as Root). I checked and it shows "Configuration Mode DHCP".

5) Went into my Router (through the Windows XP computer) and checked the "Connection Configuration: PPPoE.
It also shows the following:
Modem IP address: 192.168.1.254
Subnet mask: 255.255.255.0
DHCP Start Address: 192.168.1.1
DHCP End Address: 192.168.1.253
VPI: 8
VCI: 35
Protocol: PPPoE
Static IP Address: 0.0.0.0
WAN IP Address: 65.2.124.9

6) I opened a terminal and typed "ifconfig". This is what it tells me: (not that I know what any of it means...)
eth0
Link encap:Ethernet HWaddr 00:0D:88:3B:2D:07
inet addr:192.168.1.254 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:150 error:0 dropped:0 overruns:0 frame:0 TX packets:150 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 b) TX bytes:41868 (40.8 KiB)
Interrupt:12 Base Address:0x6000

6) I changed the interface from the default "eth0 [D-Link System Inc RTL8139 Ethernet (rev-10)]" to "eth1 [VIA Technologies, Inc. VT6102 [Rhine-II](rev-78)]". It didn't work neither, so I changed back to the default.

None of the above made any difference. The Linspire 5.0 computer does not seem to recognize a web connection through the Belkin router.
Any suggestions will be greatly appreciated!!!
 
Old 05-05-2006, 06:38 AM   #2
okmyx
Member
 
Registered: May 2004
Location: Cornwall, UK
Distribution: Ubuntu 8.04
Posts: 464

Rep: Reputation: 31
Point 1, your computer and modem seem to be sharing the same IP address 192.168.1.254 which is going to cause problems.

Try manually appyling an IP address to your eth0 or eth1 adapter of 192.168.1.1 (basically any address between 192.168.1.1 and 192.168.1.253), a subnet mask of 255.255.255.0 and a gateway address of 192.168.1.254.
 
Old 05-05-2006, 09:45 AM   #3
sabbathpriest
LQ Newbie
 
Registered: Sep 2005
Location: Ft Lauderdale
Distribution: Lispire 5.0
Posts: 6

Original Poster
Rep: Reputation: 0
Following okmyx's advise I tried the following:
1) Signed in as root, went to network settings, changed to "Static", assigned IP address of 192.168.1.100, assigned subnet of 255.255.255.0, and assigned gateway 192.168.1.254 (It was defaulting the gateway to 192.168.1)
It did not work, so:
2) Changed the interface to eth1 and the same settings above.
It didn't work neither, so:
3) Changed everything back to DCHP and refreshed the interface
Of course this didn't work neither. Also:
4) After every change I opened a terminal and I typed again "ifconfig" and printed the screen. On "Static" it reads
"Link encap:Ethernet HWaddr 00:0D:88:3B:2D:07
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask 255.255.255.0
inet6 addr: fe80::20d:88ff:fe3b:2d07/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1"

But on "DCHP" it does not have the second line of text. It reads
"Link encap:Ethernet HWaddr 00:0D:88:3B:2D:07
inet6 addr: fe80::20d:88ff:fe3b:2d07/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1"

I suspect this is a necessary difference between "Static" and "DCHP", but I thought I better mentioned, just in case....

If you are wondering:
I got the info from the modem through the XP computer, I double checked all the connections, I tried all the four ports on the back of the Router and I swapped the cables from one computer to the other to check if one of them was faulty...
I haven't tried prayer, though.
 
Old 05-05-2006, 10:10 AM   #4
crazytigger
Member
 
Registered: Sep 2004
Location: Brighton UK
Distribution: *buntu 7.10
Posts: 59

Rep: Reputation: 15
1) when you have the address 192.168.1.100 assigned to you linux box, make sure that the windoze box doesnt have the same IP (bit obvious this one)

2)Can you ping the router from the linux box? <ping 192.168.1.254>

If you can ping but cant get on the internet with linux you need to add the IP of the router as your DNS server on the linux box.

If you cant ping the router then, either: You have assigned the wrong IP address, You have a dodgy cable, You have a dodgy network card.. Can you ping the loopback address on the linux box? <ping 127.0.0.1> if not then the network card is stuffed.

I hope i understand your question properly.

Last edited by crazytigger; 05-05-2006 at 10:18 AM.
 
Old 05-05-2006, 10:03 PM   #5
sabbathpriest
LQ Newbie
 
Registered: Sep 2005
Location: Ft Lauderdale
Distribution: Lispire 5.0
Posts: 6

Original Poster
Rep: Reputation: 0
I may be getting everything wrong, I really am a green newbie at this... I hope I am not posting the wrong info!!!! Anyway, just in case, here's what I read in the Modem, in the Widoze box and in the Linspire Box:

The modem infor displays the following:
Connection Information
IP Address : 72.153.74.34
IP Gateway :65.14.252.2
Primary DNS: 205.152.144.23 dns.mia.bellsouth.net
Secondary DNS: 205.152.132.23 dns.msy.bellsouth.net
Local Network
Modem IP Address: 192.168.1.254

Windoze “ipconfig”displays the following:
IP Address 192.168.2.9
Subnet mask: 255.255.255.0
Default Gateway: 192.168.2.1

Linspire “ifconfig” displays the following:
Link encap:Ethernet HWaddr 00:0D:88:3B:2D:07
inet6 addr: fe80::20d:88ff:fe3b:2d07/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1

I can ping the network card (I didn't know how to do that until now!!) on the Linspire box, but cannot ping the Router.

I'll be away until Sunday, thank you so very much for your help!!!!!
 
Old 05-06-2006, 08:43 PM   #6
crazytigger
Member
 
Registered: Sep 2004
Location: Brighton UK
Distribution: *buntu 7.10
Posts: 59

Rep: Reputation: 15
Hi there. Sorry i was a bit confused until i re-read your first post.

The modem ip is 192.168.1.254. and that is connected to one side of your belkin router.. (no doubt this is 192.168.1.1) However the other-side of your router is 192.168.2.1 (as the router is routing between the two networks .. (the 192.168.1.0 and the 192.168.2.0 networks.)

Therefore i believe you need to set the IP of the linux box to something like 192.168.2.2 with default gateway of 192.168.2.1 and DNS server of 192.168.2.1.

You can set the IP address manually on your linux box as root like this:

ifconfig eth0 192.168.2.2 netmask 255.255.255.0

If youre having problems setting the DNS server you can enter in manually in file /etc/resolv.conf.

As root do

gedit /etc/resolv.conf

and enter

nameserver 192.168.2.1

save and exit this file.

default gateway can be added as root like this:

route add default gw 192.168.2.1

You probably have some nice graphical thing to do this .. ive got one when i type network-admin in run however there will be a file somewhere where this info is stored.. mine happens to be in /etc/network/interfaces but i think suse's is in /etc/sysconfig/network-scripts/ifcfg0 or similar. I say this because im lead to belive that if you add the default gateway manually as we did above, it will forget itself on a reboot.. ( i could be wrong and dont want to reboot my machine to find out.. (up 43 days now )

anyway if you do the above you should be good to go. My apologies for getting it so wrong earlier

best of luck

Last edited by crazytigger; 05-08-2006 at 12:27 AM.
 
Old 05-08-2006, 04:42 PM   #7
sabbathpriest
LQ Newbie
 
Registered: Sep 2005
Location: Ft Lauderdale
Distribution: Lispire 5.0
Posts: 6

Original Poster
Rep: Reputation: 0
Well, I'm close to giving up by now: I've tried all of the above and nothing happens. I'll be away from my computers for a week, I'll start again next Monday, hopefully I'll feel less confused by then...
Thanks for all the suggestions, and I'll keep you posted when I come back...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Belkin Wireless router/card ubrs Linux - Wireless Networking 7 01-05-2006 04:50 AM
Two comp network with belkin wireless card and router windell Linux - Wireless Networking 1 07-24-2005 05:49 AM
SSH - FC3 - BELKIN wireless router fcbarnard Linux - Wireless Networking 2 02-19-2005 07:58 AM
Belkin Wireless Card Connecting To Belkin Router Skippy06 Suse/Novell 1 02-02-2005 02:51 AM
need help with Belkin 54g Wireless router and network card joeman3429 Linux - Wireless Networking 2 01-02-2005 07:42 PM


All times are GMT -5. The time now is 03:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration