-   Linux - Wireless Networking (
-   -   Request to suggest compatible gcc version (

gopi001 02-18-2013 05:02 AM

Request to suggest compatible gcc version

I want to install ns-2.28 on ubuntu-12.04 LTS, kernel version:3.2.0-29-generic-pae.I request you to suggest gcc version that is compatible with this and how to install it?
Kindly advise for the same.
Waiting for your reply.

pan64 02-18-2013 05:26 AM

so I have Ubuntu 12.04.2 LTS and 3.2.0-37-generic kernel. the default gcc is 4.6.3 I think it should work for you too.

knudfl 02-18-2013 09:30 AM

Welcome to LQ.

None of the default compilers can be used for ns-2.28, dated year 2005.
(The default compilers are g++-4.4, g++-4.5, g++-4.6 ( 4.6 is the system compiler.))
Also : No old Ubuntu compilers will work.

Please use 'gcc41-compat-4.1.2-ubuntu1210_i386.deb'
And 'g++41-compat-4.1.2_i386.deb'

The install instructions for ns-allinone-2.28 are here, post # 15 , 1) .. 6)
( The text about post # 3 can be ignored.
Not valid when both patches, ns228-gcc40.patch, ns-2.28-gcc410.patch are used.)


All times are GMT -5. The time now is 06:21 AM.