LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 10-11-2011, 05:30 PM   #1
Delta_X
LQ Newbie
 
Registered: Oct 2008
Posts: 20

Rep: Reputation: 1
Question Realtek RTL8192SE Install (Make) Errors - Debian


Update: I have successfully fixed this problem. Skip to the bottom of this post for the final change I made.

I'm running BackTrack 5 (Kernel Ver: 2.6.39.4) on a Lenovo Edge 14 with a Realtek RTL8192SE Wireless card built-in.

This card does not work out of the box, so here is what I have done so far.

Yes all commands are run as root user.

Checked that I have the most recent version of linux-headers and linux-kernel. I do, all located in /usr/src.

I downloaded the Linux drivers from Realtek's web page for this card. I extracted the archive, and followed the directions in the "readme" file. The first step for installing was to run "make". I received an error when running this command, I'll explain more below..

I researched this and could not find a similar issue concerning wireless cards (mostly GPU issues).

I contacted Realtek technical support via email with the following:

Me > Realtek Support:
Hello,

I have a Debian based Linux distribution on my Lenovo Edge 14 laptop with a Realtek 8192SE wireless chip.
I downloaded the "rtl_92ce_92se_92de_linux_mac80211_0003.0620.2011" file from the Realtek website.
I have extracted the archive and read the "readme" file included.
From what I understand the first step is to run "make" as root. When I run make in the root "rtl_92ce_92se_92de_linux_mac80211_0003.0620.2011" directory my terminal outputs the following below:

root@bt:~/rtl_92ce_92se_92de_linux_mac80211_0003.0620.2011# make
make -C /lib/modules/2.6.39.4/build M=/root/rtl_92ce_92se_92de_linux_mac80211_0003.0620.2011 modules
make[1]: Entering directory `/lib/modules/2.6.39.4/build'
make[1]: *** No rule to make target `modules'. Stop.
make[1]: Leaving directory `/lib/modules/2.6.39.4/build'
make: *** [all] Error 2
root@bt:~/rtl_92ce_92se_92de_linux_mac80211_0003.0620.2011#

I have also tried running make from the included "rtl8192se" directory in the archive and I receive:

root@bt:~/rtl_92ce_92se_92de_linux_mac80211_0003.0620.2011/rtl8192se# make
make -C /lib/modules/2.6.39.4/build M=/root/rtl_92ce_92se_92de_linux_mac80211_0003.0620.2011/rtl8192se modules
make[1]: Entering directory `/lib/modules/2.6.39.4/build'
make[1]: *** No rule to make target `modules'. Stop.
make[1]: Leaving directory `/lib/modules/2.6.39.4/build'
make: *** [default] Error 2
root@bt:~/rtl_92ce_92se_92de_linux_mac80211_0003.0620.2011/rtl8192se#

I have done a few Google searches and have not found a work around for this problem. Is there some change that I need to do in the Makefile? Am I running "make" in the correct directory, or am I possibly missing some dependencies that I need to install this driver. Any guidance would be appreciated.

Thanks!
End Email

I received a (surprisingly prompt) response from Realtek with the following:

Realtek > Me
Dear Sir / Madam,



Thanks for your email.

Please find the latest RTL8191SE Linux driver source as attached.

This driver source only support PC-based x86 platform, not support embedded system.

Please refer to readme file within the package for installation and follow below steps.

You should clean/delete previous/default/inbox driver first after you install this driver source.

The previous driver will be stored within /lib/modules/2.6.XXX/kernel/driver/staging.

Please remove "r8192se_pci.ko" files by following command.

1. sudo su (you should input you root password after it)

2. find /lib/modules/ -name "r8192se_*.ko" -exec ls -l {} \;

3. find /lib/modules/ -name "r8192se_*.ko" -exec rm {} \;



After, You could execute "find /lib/modules/ -name "r8192se_*.ko" -exec ls -l {} \;" to confirm it’s clear properly.

And then, install this driver source as below steps. Don’t forget to extract this package before you install it.

1. sudo su

2. make

3. make install

4. reboot

Then, you could use " NetworkManager " to site survey AP and link it.


But, we think you encountered the issue of build environment. You don’t install the kernel completely.

Please install the kernel header or kernel source properly. Thanks.


Best Regards,

Roger_XXXXX

Realtek Semiconductor Corp.
End Email

I have tried the above solutions with a little more luck than I had when I began. I received a similar error however I was able to get some more information out in my terminal. I have responded to the Realtek Rep with the following:

Me > Realtek
Thank you for the quick response.

I executed the "find" commands to remove the old files.

I ran "make" after extracting the archive that you attached. I still received the same error as before. I double checked that I had both the linux-source and linux-headers installed and updated on my system.

I opened Makefile and changed the KSRC := to /usr/src/linux-headers-2.6.39.4 which is the directory of my kernel source header files.

Now after that change I got some more output to my terminal, which I have copied below:

root@bt:~/rtl_92ce_92se_92de_linux_mac80211_0004.0816.2011# make
make -C /usr/src/linux-headers-2.6.39.4 M=/root/rtl_92ce_92se_92de_linux_mac80211_0004.0816.2011 modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.39.4'
Building modules, stage 2.
MODPOST 1 modules
make[1]: Leaving directory `/usr/src/linux-headers-2.6.39.4'
make[1]: Entering directory `/root/rtl_92ce_92se_92de_linux_mac80211_0004.0816.2011/rtl8192ce'
make -C /lib/modules/2.6.39.4/build M=/root/rtl_92ce_92se_92de_linux_mac80211_0004.0816.2011/rtl8192ce modules
make[2]: Entering directory `/lib/modules/2.6.39.4/build'
make[2]: *** No rule to make target `modules'. Stop.
make[2]: Leaving directory `/lib/modules/2.6.39.4/build'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/root/rtl_92ce_92se_92de_linux_mac80211_0004.0816.2011/rtl8192ce'
make: *** [all] Error 2
root@bt:~/rtl_92ce_92se_92de_linux_mac80211_0004.0816.2011#

As you can see I am still receiving an error about no target 'modules'. I'm wondering if I need to make another change in the Makefile to a directory location for this 'modules' file. It may not be located in /lib/modules/2.6.39.4/build.

Any other suggestions you can give me for this?

Thanks again!
End Email

I'm still awaiting a reply from Realtek.

I have attached the contents of the "readme" file I received from the Realtek rep as well as the contents of my edited "Makefile".

Can anyone understand what's going on here? I'm thinking I need to move some header files or change some directories in the "Makefile".

Any input is appreciated everyone!
I'll also make sure I keep this updated with anything I come up with to help others with this problem as there isn't much information out there at all on this card.

UPDATE
I received the following email from Realtek:

Realtek > Me
Dear Sir,

Could you help to provide the message of “ ls /lib/modules/2.6.39.4/build –l ” for reference? Thanks.

Best Regards,

Roger_XXXXX

Realtek Semiconductor Corp.
End Email

I ran the command [ls -l /lib/modules/2.6.39.4/build] and replied with the following:

Me > Realtek
root@bt:~# ls -l /lib/modules/2.6.39.4/build
total 4168
-rw-r--r-- 1 root root 677438 2011-10-11 13:22 modules.alias
-rw-r--r-- 1 root root 656581 2011-10-11 13:22 modules.alias.bin
-rw-r--r-- 1 root root 5152 2011-10-11 13:22 modules.builtin
-rw-r--r-- 1 root root 6370 2011-10-11 13:22 modules.builtin.bin
-rw-r--r-- 1 root root 69 2011-10-11 13:22 modules.ccwmap
-rw-r--r-- 1 root root 296486 2011-10-11 13:22 modules.dep
-rw-r--r-- 1 root root 434115 2011-10-11 13:22 modules.dep.bin
-rw-r--r-- 1 root root 665 2011-10-11 13:22 modules.ieee1394map
-rw-r--r-- 1 root root 295 2011-10-11 13:22 modules.inputmap
-rw-r--r-- 1 root root 8364 2011-10-11 13:22 modules.isapnpmap
-rw-r--r-- 1 root root 403 2011-10-11 13:22 modules.ofmap
-rw-r--r-- 1 root root 118246 2011-10-11 13:22 modules.order
-rw-r--r-- 1 root root 439265 2011-10-11 13:22 modules.pcimap
-rw-r--r-- 1 root root 1471 2011-10-11 13:22 modules.seriomap
-rw-r--r-- 1 root root 248718 2011-10-11 13:22 modules.symbols
-rw-r--r-- 1 root root 315827 2011-10-11 13:22 modules.symbols.bin
-rw-r--r-- 1 root root 1011798 2011-10-11 13:22 modules.usbmap
root@bt:~#
End Email

Not sure if this will help anyone here or not, just figured I should update!

Issue still unresolved.

Final Solution:

The Realtek rep replied to my email stating that he believes I do not have the kernel source and headers installed correctly.

I double checked that I have the kernel source (2.6.39.4) and header files installed correctly. I did and they can be located in their respective directories under /usr/src. I copied the contents of the header and kernel source directories to /lib/modules/2.6.39.4/build and I was able to compile the software successfully after this change. The device now shows up as wlan0 and I can scan for wireless networks, connect, etc.
Attached Files
File Type: txt Makefile.txt (2.1 KB, 184 views)
File Type: txt readme.txt (9.0 KB, 92 views)

Last edited by Delta_X; 10-15-2011 at 03:26 PM. Reason: Update; Solved
 
Old 10-31-2011, 08:18 AM   #2
noisome
LQ Newbie
 
Registered: Nov 2006
Posts: 5

Rep: Reputation: 0
Hey there!

This is definitely helping me. I am using Slackware and my kernel files are in /usr/include/linux. Exactly what did you copy from your kernel header and source files over to the /lib/modules/${KVER}/build directory and did you keep their folder structure or just dumped everything in it?

Thanks
 
Old 11-02-2011, 01:46 AM   #3
Delta_X
LQ Newbie
 
Registered: Oct 2008
Posts: 20

Original Poster
Rep: Reputation: 1
Great to hear its helping!

I copied everything over keeping the folder structure.

I recommend trying "sudo cp /usr/include/linux/* /lib/modules/${KVER}/build/" in your case.
 
Old 02-25-2012, 11:32 PM   #4
extraweb1
LQ Newbie
 
Registered: Feb 2012
Posts: 1
Blog Entries: 1

Rep: Reputation: Disabled
I have BT5 and have the same problem with my rt5370 driver install from them and was wondering if you could post a step by step to get those files in that directory as i don't see kernel but see headers or maybe you could just upload a copy of what you put in the modules folder to 4shared or something for me please.

UPDATE!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Code:
locate Module.symvers
cp "dir without quotes where found" /usr/src/linux
I tried changing the following in the makefile with after using locate to locate some of the requirements of the makefile

Code:
LINUX_SRC =/lib/modules/$(shell uname -r)/build
to
LINUX_SRC =/usr/src/linux
and below it:

Code:
LINUX_SRC =/lib/modules/$(shell uname -r)/kernel/drivers/net/wireless
to
LINUX_SRC =/usr/src/linux/drivers/net/wireless
ran
Code:
make
make install
modprobe rt5370sta
and now it works in Wicd after changing the preferences for wlan0 to Ra0 I can connect and it works

Last edited by extraweb1; 02-26-2012 at 01:37 AM. Reason: i fixed my problem
 
Old 02-26-2012, 07:52 PM   #5
Delta_X
LQ Newbie
 
Registered: Oct 2008
Posts: 20

Original Poster
Rep: Reputation: 1
Good to hear you were able to get it working as I no longer own the system that I needed to do this on.
 
1 members found this post helpful.
Old 06-19-2012, 11:55 PM   #6
Luisruiz
LQ Newbie
 
Registered: Jun 2012
Posts: 1

Rep: Reputation: Disabled
HELP!

So im running BT 5 on Virtual box and i cant get BT to detect my Realtek RTL8188CE Wireless LAN 802.11n PCI-E NIC. Can u please help me step by step? I am new to this so if u could help me i would appreciate it a lot. Thanks
 
Old 06-20-2012, 12:01 AM   #7
Delta_X
LQ Newbie
 
Registered: Oct 2008
Posts: 20

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Luisruiz View Post
So im running BT 5 on Virtual box and i cant get BT to detect my Realtek RTL8188CE Wireless LAN 802.11n PCI-E NIC. Can u please help me step by step? I am new to this so if u could help me i would appreciate it a lot. Thanks
Beyond following the steps I posted above I am unable to help any farther.
 
  


Reply

Tags
backtrack, make, makefile, realtek, wirelessnetworking


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] opensuse 11.4 cannot use the tar.gz file from Realtek rtl8192se rusty2 Linux - Networking 9 05-17-2011 07:14 PM
Compiling RTL8192SE Linux driver : Strange error after make jv2112 Linux - Newbie 10 04-22-2011 06:16 AM
[SOLVED] Having real battle, Slack64 13.0, realtek rtl8192se wireless. mrclisdue Slackware 9 03-10-2010 12:43 PM
libogg not installing, make and make install don't give errors, but fail lilmike Linux - Newbie 6 11-14-2009 08:33 PM
Chap 5 Binutils make LDFLAGS & make install errors shotokan Linux From Scratch 5 04-10-2005 04:01 AM


All times are GMT -5. The time now is 04:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration