LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 05-08-2010, 08:01 PM   #1
Syek0sis
LQ Newbie
 
Registered: May 2010
Posts: 1

Rep: Reputation: 0
Exclamation Re enabling Auto eth0 after making a newbie mistake


Hello all,

As you may see i am new to this forum and linux itself (tried Ubuntu 8.10, now on Ubuntu 10.4), and i would appreciate your assistance with a newbie mistake i have made.

While working around with ndiswrapper, trying to get my Broadcom wireless driver to work, a tutorial i was reading said that the default wired connection, Auto eth0, could interfere with the windows driver, and gave instructions on how to disable it. Without thinking, i disabled it and now i have no internet to search for a way to fix it. right now im using a friends computer. i have searched and tried to fix it myself and have not found the solution yet. Since i love forums, and find most help from them, i ask for help enabling the default wired network.

The command that killed it as i recall was something like: "sudo killall dhclient" or something, there was also one after it, but i cannot remember it. ive tried restarting multiple times, and not even the ndiswrapper driver would enable.

Any help would be appreciated
...and im betting a simple terminal command will fix it, huh?

P.S. I love linux, but apparently linux doesnt like acer laptops
 
Old 05-09-2010, 12:16 AM   #2
portamenteff
Member
 
Registered: Feb 2006
Location: Colorado
Distribution: sabayon
Posts: 178
Blog Entries: 1

Rep: Reputation: 36
Welcome to Linux Syek0sis re: dhclient

Quote:
Originally Posted by Syek0sis View Post
Hello all,

As you may see i am new to this forum and linux itself (tried Ubuntu 8.10, now on Ubuntu 10.4), and i would appreciate your assistance with a newbie mistake i have made.

While working around with ndiswrapper, trying to get my Broadcom wireless driver to work, a tutorial i was reading said that the default wired connection, Auto eth0, could interfere with the windows driver, and gave instructions on how to disable it. Without thinking, i disabled it and now i have no internet to search for a way to fix it. right now im using a friends computer. i have searched and tried to fix it myself and have not found the solution yet. Since i love forums, and find most help from them, i ask for help enabling the default wired network.

The command that killed it as i recall was something like: "sudo killall dhclient" or something, there was also one after it, but i cannot remember it. ive tried restarting multiple times, and not even the ndiswrapper driver would enable.

Any help would be appreciated
...and im betting a simple terminal command will fix it, huh?

P.S. I love linux, but apparently linux doesnt like acer laptops
I've used Linux on a couple Acer laptops. Yes Linux does love them. I'm not on one right now though. You just gotto play with it.
OK, the dhclient you are referring to is standard Debian/Ubuntu stuff. If you've lost it with 'sudo killall dhclient' then you can recover it by typing 'sudo dhclient.' It might grumble for some options and refer you to the man pages or help pages. To know if it's running, open a new terminal and type the command 'top'
On the left side of the terminal you'll see the names of programs running. This is very useful when you want to kill unruly programs. the biggest power drains will be there at the top. Once its running, type 'n' to set the maximum number of running programs to display. Oh, and you don't need to plug ndiswrapper into dhclient. It should just work with the right configuration.
On the matter of wifi, you could check the hardware compatibility list because many new linux users use ndiswrapper unnecessarily. I for example simply had to run 'sudo apt-get install rt73' to get mine to work, but didn't know that when I was a noob, hell I'm still a noob at many things.
Do me a favor, open a terminal, type 'lspci' and paste the results into a reply here. I'll look deeper into it later. Get in the habit with hardware issues, of pasting lscpi output in the post. It saves time of me having to ask you to do it. Welcome to linux, Virus-free surfing, entire system updates with one click, tons of free help, and if it don't work, call up ubuntu, tell em you want your money back LOL.
 
Old 05-09-2010, 12:40 AM   #3
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,305

Rep: Reputation: 205Reputation: 205Reputation: 205
If you can still see your network icon, right click it and select Edit Connections. You should see a tab for the wired connection. Your eth0 should be listed here, highlight it then click Edit.

Check that Connect automatically has a tick in the box.

Check you have a MAC address entry.

MTU should be set to automatic

Make sure you have a tick in Available to all users

Under the IPv4 Settings, the Method should be set to Automatic (DHCP).

Click Apply, close the network connections window. Left click on the network icon, you should see Wired Network if it says disconnected click it and see if it connects, failing that do a reboot and see if that works.
 
  


Reply

Tags
auto, eth0, help


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stupid newbie mistake, now lsmod shows nothing.... Romanus81 Slackware 3 04-20-2008 09:41 PM
eth0 Auto Connect, How to auto start on logon cornish Linux - Networking 2 05-09-2005 01:02 PM
Dumb ass newbie mistake...help! craigb Linux - Newbie 4 11-14-2004 01:07 PM
physically / logically re-Enabling eth0 allel Linux - Networking 2 06-08-2003 05:30 AM


All times are GMT -5. The time now is 09:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration