LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 12-01-2008, 12:37 AM   #1
wheeliee
Member
 
Registered: Aug 2008
Posts: 47

Rep: Reputation: 15
problems configuring wpa2 connection on slackware 12.1


Hi,

I'm running Slackware 12.1 on an HP Pavilion S3400T, with an onboard wifi adapter. The router is a Linksys WRT54GL (default firmware). Having entered the proper information in /etc/rc.d/rc.inet1.conf and /etc/wpa_supplicant.conf (using alien's guide, for most parts), my machine does not start up with a working connection.

Here's my rc.inet1.conf:

Quote:
IFNAME[1]="wlan0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]=""
WLAN_WPA[1]="wpa_supplicant"
WLAN_WPADRIVER[1]=""
and here's my wpa_supplicant.conf:

Quote:
# WPA2-PSK
network={
scan_ssid=0
proto=WPA2
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
priority=1
ssid="linksys"
#psk="xxx"
psk=xxxxxxxxxxxxxxxxxxxxxxxxx...
}
/etc/rc.d/rc.inet1 wlan0_restart gives me this:

Quote:
root@lest:/home/met# /etc/rc.d/rc.inet1 wlan0_restart
Error for wireless request "Set Nickname" (8B1C) :
SET failed on device wlan0 ; Operation not supported.
Polling for DHCP server on interface wlan0:
dhcpcd: MAC address = 00:16:44:xx:xx:xx
root@lest:/home/met#
and I get no connection. However . . . when I do #wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf, I get this:

Quote:
# wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - ioctl[SIOCGIWSCAN]: Resource temporarily unavailable
Trying to associate with 00:22:6b:5f:2a:4f (SSID='linksys' freq=2437 MHz)
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - Associated with 00:22:6b:5f:2a:4f
WPA: 4-Way Handshake failed - pre-shared key may be incorrect
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Associated with 00:22:6b:5f:2a:4f
WPA: Invalid EAPOL-Key MIC when using TPTK - ignoring TPTK
WPA: Could not verify EAPOL-Key MIC - dropping packet
Authentication with 00:22:6b:5f:2a:4f timed out.
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
ioctl[SIOCSIWENCODEEXT]: No such file or directory
Trying to associate with 00:22:6b:5f:2a:4f (SSID='linksys' freq=2437 MHz)
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - Associated with 00:22:6b:5f:2a:4f
WPA: Invalid EAPOL-Key MIC when using TPTK - ignoring TPTK
WPA: Could not verify EAPOL-Key MIC - dropping packet
Authentication with 00:22:6b:5f:2a:4f timed out.
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
ioctl[SIOCSIWENCODEEXT]: No such file or directory
Trying to associate with 00:22:6b:5f:2a:4f (SSID='linksys' freq=2437 MHz)
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - Associated with 00:22:6b:5f:2a:4f
WPA: 4-Way Handshake failed - pre-shared key may be incorrect
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Associated with 00:22:6b:5f:2a:4f
WPA: Key negotiation completed with 00:22:6b:5f:2a:4f [PTK=CCMP GTK=TKIP]
CTRL-EVENT-CONNECTED - Connection to 00:22:6b:5f:2a:4f completed (auth) [id=0 id_str=]
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Trying to associate with 00:22:6b:5f:2a:4f (SSID='linksys' freq=2437 MHz)
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - Associated with 00:22:6b:5f:2a:4f
and finally, after executing (and ONLY after)
Quote:
#dhdpcd wlan0
, I get the connection up and running, but here's the weird thing: for the first 40 seconds or so, an internet speed test (http://speedtest.wi.rr.com/) measures my speed to be about 2 mega bits, .. and after those 40 seconds, it drops to about 0.6 mega bits. Technically, I should be getting at least 6 mega bits (which it was, when this machine had Vista on it, so I'm pretty sure the adapter is capable of delivering the speed).

So to conclude, here are the problems
1) SOLVED:[rc.inet1 is unable to connect at boot-up].. not quite sure what it was I did to have this work.. but it does work at boot-up now.
2) and when I do get it running manually, I'm met with this very peculiar behavior (connection speed in the first minute is ~2.5 mega bits/down, then goes to .5 mega bits or so). Also, I noticed, that Kwifimanager reports the connection speed to be 1 MBit/sec in the first 40 seconds that the internet speed is ~3 mega bits/down.. but precisely when Kwifimanager starts reporting the connection speed to be a full 54 MBit/s, the internet speed goes down.

I'm pretty much clueless at what I can do here, so I'll really really appreciate any words.

Thanks,
-wheelie

Last edited by wheeliee; 12-01-2008 at 01:21 PM.
 
Old 12-01-2008, 07:36 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,780
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
I notice that you're never setting the wpa_supplicant driver, either in rc.inet1.conf or when you start wpa_supplicant via command line. That might be part of the problem. For rc.inet1.conf enter wext as the wpa_supplicant driver or from the command line try:

wpa_supplicant.conf -Bw -Dwext -c/etc/wpa_supplicant.conf -iwlan0
 
Old 12-01-2008, 12:42 PM   #3
wheeliee
Member
 
Registered: Aug 2008
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Hangdog42 View Post
I notice that you're never setting the wpa_supplicant driver, either in rc.inet1.conf or when you start wpa_supplicant via command line. That might be part of the problem. For rc.inet1.conf enter wext as the wpa_supplicant driver or from the command line try:

wpa_supplicant.conf -Bw -Dwext -c/etc/wpa_supplicant.conf -iwlan0
Hi Hangdog42,

Thank you for replying.

In alien's guide, http://alien.slackbook.org/dokuwiki/...wpa_encryption -- it said
Quote:
Slackware will tell wpa_supplicant to use the ”wext” protocol if you do not specify a driver yourself. So, basically the line

WLAN_WPADRIVER[1]="wext"

can safely be omitted.
But I did add it anyway, and it makes no identifiable difference.

Thanks,
wheelie
 
Old 12-01-2008, 03:36 PM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,780
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
I guess that makes sense for rc.inet1.conf (I never configure my cards this way, so I hadn't seen alien's guide), but you definitely need to specify wext if you're starting wpa_supplicant from the command line.

Anyway, one thing that might help pinpoint the problem is to temporarily turn off wpa encyrption and see if you have the same speed problems as with wpa encryption. You also might try removing the commented psk line from your wpa_supplicant stanza. I know comments are allowed outside of the stanzas, but I'm not sure they are allowed inside. Finally, you might give wicd a go. There is a slackbuild for it at Slackbuilds.org and in my experience it works MUCH better than either Slackware's approach or wpa_supplicant alone.
 
Old 12-02-2008, 12:06 AM   #5
wheeliee
Member
 
Registered: Aug 2008
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Hangdog42 View Post
I guess that makes sense for rc.inet1.conf (I never configure my cards this way, so I hadn't seen alien's guide), but you definitely need to specify wext if you're starting wpa_supplicant from the command line.

Anyway, one thing that might help pinpoint the problem is to temporarily turn off wpa encyrption and see if you have the same speed problems as with wpa encryption. You also might try removing the commented psk line from your wpa_supplicant stanza. I know comments are allowed outside of the stanzas, but I'm not sure they are allowed inside. Finally, you might give wicd a go. There is a slackbuild for it at Slackbuilds.org and in my experience it works MUCH better than either Slackware's approach or wpa_supplicant alone.
Hangdog42,

Thank you very very much for taking the time to reply once more.

I've had this "problem" for a long while.. in fact, as so far back as 2 months (i.e., the time since first trying a nix OS), and it's unbelievable that neither I, or anyone else I had asked for help could offer the intuitive advice for troubleshooting this problem: .. temporarily disabling WPA2 enc. -- I did, and I seem to be getting a very sturdy and stable 7 or 8 mega bits down. Thank you for this.

So, I've isolated WPA2 as the offending culprit. I guess this leaves me with two choices to go with:
a) use WEP or WPA, or
b) troubleshoot WPA2

I'll try going with option b after coming home from school tomorrow -- hopefully running wpa_supplicant in debugging mode will further point to specific areas of interest. And if mangling with those results doesn't lead to a resolution, I'll either be back here for more help, or just start using some other enc. scheme.

Thanks again,
wheelie

edit: I've heard only good things about wicd (unless of course, if like me you idle in #slackware, .. where there are the vi-vs.-emacs kinds of wars (usually between Rob (workman) and Eric (alien) every other day or so)) -- I'll give that a try. As for putting the commented line in the stanza or not, I don't believe it makes a difference, I only added it this week (after copying alien's suggested configs. verbatim and editing them), I noticed no difference in behavior.

Last edited by wheeliee; 12-02-2008 at 12:13 AM.
 
Old 12-02-2008, 11:54 PM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,780
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
It does look like wpa_supplicant is the problem here, but if you're up for a touch more testing, seeing how WEP and WPA work might be helpful. Although wpa_supplicant can handle WEP, you don't need to use it for WEP, so if that still works at full speed, then wpa_supplicant is definitely the culprit.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Solaris to do Wireless WPA or WPA2? as400 Solaris / OpenSolaris 1 09-17-2008 12:55 PM
LXer: Configuring WPA2 (AES) in Slackware LXer Syndicated Linux News 0 08-15-2008 06:30 AM
Configuring ATI Radeon X1700 at Slackware 12.0 | Wine problems **Cat** Linux - Laptop and Netbook 0 08-21-2007 10:46 AM
Problems configuring Slackware, xf86config, vi, gcc rphook Slackware 6 11-01-2004 10:12 PM
IBM Thinkpad 600E problems configuring sound for slackware 9.1 ic3 Linux - Laptop and Netbook 4 02-08-2004 10:51 PM


All times are GMT -5. The time now is 10:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration