LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 11-11-2007, 08:14 PM   #1
kumar_bst
Member
 
Registered: Jul 2007
Posts: 36
Blog Entries: 1

Rep: Reputation: 15
Problem with Ralink driver and WPA_Supplicant for WPA mode


Hi,
I am using ralink driver 1.0.4.0 and wpa_supplicant 0.4.7 in the linux platform 2.4.22 [RedHat 9].
I am facing piculiar problem. I can associate to the wireless router if I use cofig file rt73sta.dat in the driver using WPA-PSK mode.
But, if I use wpa_supplicant, I am not getting any IP address. Infact, the entry for wireless interface is removed from ifconfig output. I saw the same problem with higher version of wpa_supplicant, 0.5.8 and 0.6.0.
The problem is not there for the ralink driver 1.0.3.3.

I executed the following commands,

# insmod rt73.o
# ifconfig rausb0 up
# wpa_supplicant -c <wpa_supplicant.config file name> -i rausb0 -D ralink -dd
# dhclient

Please help me.

Regards,

Amit
 
Old 11-12-2007, 05:52 AM   #2
kumar_bst
Member
 
Registered: Jul 2007
Posts: 36
Blog Entries: 1

Original Poster
Rep: Reputation: 15
I saw the following error message in the terminal,
ioctl[SIOCGIWAP]: Transport endpoint is not connected

And, in the /var/log/message i found the following error message,

<7>ERROR: CRC ok but CipherErr 3 (len = 163, Mcast=0, Cipher=TKIP, KeyId=)

I configured wpa_supplicant.cfg for

key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
 
Old 11-12-2007, 03:39 PM   #3
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,537

Rep: Reputation: 149Reputation: 149
Moved: This thread is more suitable in Linux-Wireless and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 11-15-2007, 06:43 PM   #4
kumar_bst
Member
 
Registered: Jul 2007
Posts: 36
Blog Entries: 1

Original Poster
Rep: Reputation: 15
I also observed the following Error message,

ERROR: CRC ok but CipherErr 3 (len = 163, Mcast=0, Cipher=TKIP, KeyId=0)
 
Old 11-16-2007, 07:26 AM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
wpa_supplicant -c <wpa_supplicant.config file name> -i rausb0 -D ralink -dd

I don't know if this will help, but you might want to try -D wext instead of -D ralink. You also might want to post your wpa_supplicant.conf in case you've got an error in there.
 
Old 11-23-2007, 12:32 AM   #6
kumar_bst
Member
 
Registered: Jul 2007
Posts: 36
Blog Entries: 1

Original Poster
Rep: Reputation: 15
i am using ralink device not wext
 
Old 11-23-2007, 07:54 AM   #7
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
Originally Posted by kumar_bst View Post
i am using ralink device not wext
You need to do some reading about wpa_supplicant. The driver you specify with the -D flag is to allow wpa_supplicant to communicate with the actual card, and the wext driver is a generic interface that works through iwconfig, and therefore doesn't care what device you have. In many cases it works better than the specific driver for the chipset.
 
Old 11-26-2007, 06:39 AM   #8
kumar_bst
Member
 
Registered: Jul 2007
Posts: 36
Blog Entries: 1

Original Poster
Rep: Reputation: 15
that means, u want to say, I dont need to load device driver for ralink wireless usb ? Or, I need to load the driver but no need to pass the driver name as argument when start wpa_supplicant daemon?
Actually, the packed was dropped by wpa_supplicant at the time of association. anyways, i shall try ur suggestion.
 
Old 11-26-2007, 01:06 PM   #9
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
II dont need to load device driver for ralink wireless usb ? Or, I need to load the driver but no need to pass the driver name as argument when start wpa_supplicant daemon?
No, that isn't what I mean. When you're dealing with wpa_supplicant, you're actually dealing with two drivers, the device driver for the hardware itself (in your case the Ralink driver) and the driver that allows wpa_supplicant to communicate with the device (in this case the wext driver I've been suggesting). The second drivers I'm talking about are included as part of wpa_supplicant, but you must specify which one to use when you start wpa_supplicant.
 
Old 12-10-2007, 02:48 AM   #10
kumar_bst
Member
 
Registered: Jul 2007
Posts: 36
Blog Entries: 1

Original Poster
Rep: Reputation: 15
no result, i passed wext at the start up time, but no result.

wpa_supplicant -c wpa.cfg -irausb0 -Dwext -B

It is throwing some other error.
 
Old 12-10-2007, 07:25 AM   #11
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
It is throwing some other error.
Posting the error will help immensely since nobody besides you can see your screen.
 
Old 12-11-2007, 07:33 PM   #12
kumar_bst
Member
 
Registered: Jul 2007
Posts: 36
Blog Entries: 1

Original Poster
Rep: Reputation: 15
wpa_supplicant -c wpa.cfg -irausb0 -Dwext -B
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x1 - ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 -
 
Old 12-11-2007, 10:06 PM   #13
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
1. Does the device work without any security. It's not clear from your post but if you haven't, try getting an IP address without WEP or WPA. If that doesn't work, you're fighting an uphill battle.

2. modprobe rt73 instead of insmod rt73.o
That will pull in any dependent modules.

3. Use the absolute path for the config file. You can't count on being in the same directory as wpa.cfg, especially if you automate the call to wpa_supplicant at boot.

ex: -c /etc/wpa_supplicant/wpa.cfg (Use your path, I made that one up.)
 
Old 12-11-2007, 11:21 PM   #14
kumar_bst
Member
 
Registered: Jul 2007
Posts: 36
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by 2Gnu View Post
1. Does the device work without any security. It's not clear from your post but if you haven't, try getting an IP address without WEP or WPA. If that doesn't work, you're fighting an uphill battle.
Yes, without wpa_supplicant I am getting IP. even with security, WPA implemented in driver, getting IP.

Quote:
Originally Posted by 2Gnu View Post
2. modprobe rt73 instead of insmod rt73.o
That will pull in any dependent modules.
There is no dependency with other module.

Quote:
Originally Posted by 2Gnu View Post
3. Use the absolute path for the config file. You can't count on being in the same directory as wpa.cfg, especially if you automate the call to wpa_supplicant at boot.

ex: -c /etc/wpa_supplicant/wpa.cfg (Use your path, I made that one up.)
Supplicant is reading the file wpa.cfg properly, i saw in the log.
 
Old 12-12-2007, 07:32 AM   #15
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I did some Googling on the error, but I'm not seeing any definitive answer. The most likely answer, in my opinion, is that the kernel wasn't compiled with a full set of WPA options enabled. Starting around 2.6.13, a lot of the WPA support was moved into the kernel, and the wext driver kind of depends on it. And from what I've been reading, the other drivers that wpa_supplicant has might conflict, so trying to fix wext is the way to go.

Have you compiled your own kernel or is this a stock kernel from your distro?
 
  


Reply

Tags
ralink, rt73, wpasupplicant


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem getting wireless card to use WPA mode. mdorries Linux - Wireless Networking 2 05-27-2007 07:52 PM
problem installing ralink RT61 driver in slackware 10 dark_angel Slackware 7 04-11-2007 01:24 AM
problem installing ralink RT61 driver in slackware 10 dark_angel Slackware 1 10-25-2006 11:10 PM
No luck with WPA and WPA_SUPPLICANT mellin Mandriva 3 04-28-2006 07:08 AM
wpa_supplicant not picking up WPA-PSK AP derfelcadarn Linux - Wireless Networking 2 04-07-2005 11:48 AM


All times are GMT -5. The time now is 09:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration