LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-16-2007, 07:18 AM   #1
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Rep: Reputation: 15
Problem getting ndiswrapper to work FC6


Hey, I have recently installed ndiswrapper, from what I can tell successfully:

ndiswrapper -l gives me:
bcmwl5 : driver installed
device (14E4:4312) present (alternate driver: bcm43xx)

However, the light for my Wireless fails to come on

I then try and activate the wireless network eth1 and dmesg gives output that contains alot about the bcm43xx driver and I have read this one is not as good as the bcmwl5 that I need to use.

I checked ./iwconfig and the eth1 network comes up with an entry like:

eth1 IEEE 802.11 b/g ESSID "" blah blah blah

However, the wireless still doesnt work.

I decided to blacklist the bcm43xx driver in the hope it would stop using it. Interestingly enough when I restarted the wireless light came on!? But then when I checked iwconfig eth1 did not appear anymore - just lo and eth0.

Help me please!!!
 
Old 05-16-2007, 08:56 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Did you perhaps forget to also edit the /etc/modprobe.conf file eth1 line entry??

Recreate the missing /etc/sysconfig/network-scripts/ifcfg-eth1 file, sample below;

TYPE=Wireless
DEVICE=eth1
HWADDR=
BOOTPROTO=dhcp
DOMAIN=
ONBOOT=yes
ONHOTPLUG=yes
USERCTL=yes
IPV6INIT=no
PEERDNS=no
ESSID=
CHANNEL= <<--adjust to the channel shown by the command:iwlist eth1 scan
MODE=
RATE=


FYI: with the freshrpms-release rpm package installed: http://zod.freshrpms.net/

yum install dkms dkms-ndiswrapper

And you will not need to rebuild the ndiswrapper module again after a kernel update. Extra points for rebuilding and installing the dkms-ndisswrapper for the latest release version of ndiswrapper. Just grab the source rpm file and the latest ndiswrapper source. Edit the spec file from the source rpm package to reflect the latest released version and build;

rpmbuild -ba --define 'dist .fc6' <the spec file name here>

If you have a problem then; yum install rpm-build

Last edited by Lenard; 05-16-2007 at 09:02 AM.
 
Old 05-16-2007, 09:27 AM   #3
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Original Poster
Rep: Reputation: 15
Right well I have just changed the modprobe.conf
I presume you mean the line that read:
alias eth1 bcm43xx

So I have changed the bcm43xx to bcmwl5

Restarted but nothing changed, by dmesg says the following when I try and connect:
bcm43xx: set security called .level = 0, .enabled = 0, .encrypt = 0
SoftMAC: Associate: Scanning for networks first
SoftMAC: Associate: Failed to initiate scan. Is device up?
bcm43xx: PHY connected
bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed
bcm43xx: core_up for active 802.11 core failed (-2)

I will try adding the script you mentioned now

Thanks for getting back to me
 
Old 05-16-2007, 09:41 AM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Nope change the line to: alias eth1 ndiswrapper

Then restart the network after creating the ifcfg-eth1 file;

service network restart

Last edited by Lenard; 05-16-2007 at 09:42 AM.
 
Old 05-16-2007, 09:42 AM   #5
intricatic
LQ Newbie
 
Registered: Aug 2005
Location: Plantation, Florida USA
Distribution: Ubuntu Feisty, Gentoo, DragonflyBSD
Posts: 23

Rep: Reputation: 15
Are you sure you're using the correct firmware for your chipset?
 
Old 05-16-2007, 10:06 AM   #6
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Original Poster
Rep: Reputation: 15
Yes I am sure the firmware is right

Okay let me update where I am up to:

- I have re-blacklisted the bcm43xx drivers
- I have modified the modprobe.conf as above
- I have also changed the line in /etc/modprobe.d/ndiswrapper
from
alias wlan0 ndiswrapper to alias eth1 ndiswrapper
(not sure if that was the right thing to do or not - wlan0 seemed quite useless though)
- I then restarted and thankfully the wireless light is now on
- iwconfig shows the expected eth1 interface as before (so this is an improvement )
- The eth1 script is still there, but when I scan with iwlist is says no scan results so I don't think I can set the channel properly
- When I now try and enable the network through system-network-config I get the following output:
Error for wireless request "Set Mode" (8B06) SET failed on device eth1; Invalid argument
- Then when I look at my dmesg I have the following output:
ADDRCONF(NETDEV_UP): eth1: link is not ready

Now then, reading what Lenard just posted:
"Nope change the line to: alias eth1 ndiswrapper"
Do I have to change it to that line as I stated above (where previously it was alias wlan0 ndiswrapper) in /etc/modprobe.d/ndiswrapper?

Okay I will see what happens when I use Lenard's suggestion. Please bear with me - i've been trying to get this thing working for a while now. If any of the steps I have taken above are wrong then please tell me lol.
 
Old 05-16-2007, 10:26 AM   #7
intricatic
LQ Newbie
 
Registered: Aug 2005
Location: Plantation, Florida USA
Distribution: Ubuntu Feisty, Gentoo, DragonflyBSD
Posts: 23

Rep: Reputation: 15
Press the wireless button.

I had the same problem when I upgraded Ubuntu, from the sounds of it. Took me about a week to figure it out, too.
 
Old 05-16-2007, 10:39 AM   #8
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Original Poster
Rep: Reputation: 15
Right I just made that change that Lenard metioned

Unfortunately there seems to be no change in results, the light still comes on but I am receiving the same messages from dmesg and system-config-network.

I noticed that the encryption on the wireless network I am trying to connect to is WPA-PSK encrypted, is ndiswrapper only good for WEP encryption or will it not matter?

I wish it was as easy as pressing the wireless button! Maybe one day it will be...
 
Old 05-16-2007, 10:54 AM   #9
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Why not show use which Broadcom chipset you have, some work just fine with the bcm43xx driver and others do not.

/sbin/lscpi -v

If your chipset is OK then you need to install the firmware from he same file you used with ndiswrapper using the firmware cutter package;

The good/bad bcm43xx list: http://bcm43xx.berlios.de/?go=devices
The bcm43xx-fwcutter can be installed by: yum install bcm43xx-fwcutter
The firmware is installed by typing: bcm43xx-fwcutter -w /lib/firmware <the file name here>

Last edited by Lenard; 05-16-2007 at 10:58 AM.
 
Old 05-16-2007, 11:10 AM   #10
intricatic
LQ Newbie
 
Registered: Aug 2005
Location: Plantation, Florida USA
Distribution: Ubuntu Feisty, Gentoo, DragonflyBSD
Posts: 23

Rep: Reputation: 15
That's about how much of a problem it was for me... lol

WPA, I think you need wpa_supplicant, but if you have the ability, set it to WEP and it should work OK. I've personally never played around with WPA on ndiswrapper, but it is do-able.

You're saying that "iwlist ifname scan" gives you no results, though? It should find the network regardless of encryption.

Last edited by intricatic; 05-16-2007 at 11:12 AM.
 
Old 05-16-2007, 11:14 AM   #11
intricatic
LQ Newbie
 
Registered: Aug 2005
Location: Plantation, Florida USA
Distribution: Ubuntu Feisty, Gentoo, DragonflyBSD
Posts: 23

Rep: Reputation: 15
Like I said, when I upgraded Ubuntu recently I had a problem that sounds exactly like this -- the wireless looked like it should be working, the firmware loaded properly, etc... and the interface was showing up on iwconfig, but it wouldn't do anything on an iwlist.

Pressing FN + F2 (wireless button) got it working like a charm instantly.
 
Old 05-16-2007, 11:29 AM   #12
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Original Poster
Rep: Reputation: 15
Okay good news is some progress has been made!

I messed around with the modprobe.conf file as Lenard suggested, eventually I am now up to the stage where iwlist eth1 scan is giving me some results! Horaahhh!

However, at the moment it is only picking up my neighbours WLAN's and not mine, and yes they are encrypted so I can't even "borrow" them.

I am hoping that after a few tries my network will eventually come up.

What commands should I be using though if (and hopefully when) it comes up? The essid of the network is "woody"

Thanks alot for all of your help so far

P.S I would love to be using yum but I have no internet on FC6 - thats why I'm trying to sort things out. I keep having to reboot into Windoze to post these messages lol.

Last edited by woodpecka_04; 05-16-2007 at 11:31 AM.
 
Old 05-16-2007, 12:16 PM   #13
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Remember this;

TYPE=Wireless
DEVICE=eth1
HWADDR=
BOOTPROTO=dhcp
DOMAIN=
ONBOOT=yes
ONHOTPLUG=yes
USERCTL=yes
IPV6INIT=no
PEERDNS=no
ESSID=
CHANNEL= <<--adjust to the channel shown by the command:iwlist eth1 scan
MODE=
RATE=

Change the ESSID to ESSID=woody

FYI: disable encryption on your wireless router until you see if you get a connection.
FYI: both the wireless router and the Linux wireless device must use the same encryption level 64-bit or 128-bit. The default is 128-bit in Linux.

FYI: it does not matter the alias name for the device as long as ever file uses the same name.
 
Old 05-16-2007, 02:02 PM   #14
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Original Poster
Rep: Reputation: 15
Hey, I've managed to get my home network to show up and I turned the encryption off but it still doesnt seem to connect.

The commands I am using are:
./iwconfig eth1 essid woody channel 11
./dhclient eth1

I don't know what is meant to happen i.e. does it tell me I am connected or what?

What am I doing wrong?

EDIT: Okay I have found it works with no encryption when I restart - wow internet on linux! Im just going to try turning encryption back on

Last edited by woodpecka_04; 05-16-2007 at 02:09 PM.
 
Old 05-16-2007, 03:32 PM   #15
intricatic
LQ Newbie
 
Registered: Aug 2005
Location: Plantation, Florida USA
Distribution: Ubuntu Feisty, Gentoo, DragonflyBSD
Posts: 23

Rep: Reputation: 15
Awesome!

Like I said, you'll probably need wpa_supplicant to get the WPA encryption to work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to install ndiswrapper on fc6 prn Linux - Wireless Networking 2 04-16-2007 01:26 PM
prob with ndiswrapper on FC6 valaskialf Linux - Wireless Networking 1 02-08-2007 01:19 PM
Ndiswrapper on FC6 Sam Liu Linux - Wireless Networking 32 12-05-2006 11:45 AM
ndiswrapper Fedora FC6 Intel 3945ABG problem (not showing) dayeliu Linux - Wireless Networking 2 11-25-2006 11:21 PM
From one problem to another, ndiswrapper, FC6 THOR_Fedora Linux - Wireless Networking 9 10-29-2006 07:48 AM


All times are GMT -5. The time now is 07:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration