LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 02-27-2009, 07:01 PM   #1
hanika98
LQ Newbie
 
Registered: Feb 2009
Posts: 2

Rep: Reputation: 0
Unhappy Please Help - NDISWrapper - Error for wireless request "Set Encode" (8B2A)


I have spent the past two weeks trying to install my Broadcom wireless controller on my HP Compaq presario nx9600 laptop. But still have not been able to get it up and running!

I get the following error when trying to start up the network:
Bringing up interface eth1: Error for wireless request "Set Encode" (8B2A) :
SET failed on device eth1 ; Invalid argument.

Determining IP information for eth1... failed; no link present. Check cable?
[FAILED]

I also get this error when I run
iwconfig eth1 key s:MYKEY
in fact I get this error when I run any of the commands associated with encryption

iwconfig eth1 enc on
Error for wireless request "Set Encode" (8B2A) :
SET failed on device eth1 ; Invalid argument.

If anyone can point me in the right direction it would be much appreciated!

CentOS distro
uname -r
2.6.18-92.1.22.el5xen

lspci
Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

ndiswrapper -l
bcmwl5a : driver installed
device (14E4:4320) present (alternate driver: bcm43xx)

I have not been able to get this alternate driver message to go away. I already black listed the driver and made sure the bcm43xx module isn't even loaded

iwconfig eth1
eth1 IEEE 802.11g ESSIDff/any Nickname:"colombus.lbmsys.com"
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate=54 Mb/s Tx-Power:25 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption keyff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

The device is partially up because I can see my access point when I run
iwlist eth1 scanning

This is a tail form dmesg:
ndiswrapper: using IRQ 17
wlan0: ethernet device 00:90:4b:bc:e2:f2 using NDIS driver: bcmwl5a, version: 0x3461600, NDIS version: 0x501, vendor: 'NDIS Network Adapter', 14E4:4320.5.conf
wlan0: encryption modes supported: WEP; TKIP with WPA; AES/CCMP with WPA
usbcore: registered new driver ndiswrapper
ndiswrapper: changing interface name from 'wlan0' to 'eth1'
ndiswrapper (add_wep_key:841): adding encryption key 1 failed (C0010015)
ADDRCONF(NETDEV_UP): eth1: link is not ready
 
Old 02-28-2009, 12:19 AM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,510
Blog Entries: 3

Rep: Reputation: 205Reputation: 205Reputation: 205
here but if you really want to use a windows driver. I did not see that you posted a Distro if you did I failed to see it so I guess you want to do this in a terminal so here is the direction I prefere the the linux module over the ndiswrapper but I see you have the wraper running.
Next big advice is to try and move to a newer kernel would also help you a lot. have fun with the wlan0 that becomes a eth1 with the ndiswrapper. how about this with the newer kernels it does the opposite
upgrade that distro and cut the firmware for that the old 2.6.18 kernel is just a hassle. centos 5 is alot better.
Quote:
wlan0: ethernet device 00:90:4b:bc:e2:f2 using NDIS driver: bcmwl5a, version: 0x3461600, NDIS version: 0x501, vendor: 'NDIS Network Adapter', 14E4:4320.5.conf
that is ndiswrapper and to make it ready is ifconfig wlan0 up

Last edited by Drakeo; 02-28-2009 at 12:33 AM.
 
Old 03-11-2009, 08:44 AM   #3
hanika98
LQ Newbie
 
Registered: Feb 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks

Thanks for the info. I installed unbuntu and it recongized the wirless card. Got it up and running in a few minutes. I gave up on CentOS. I had built the latest kernel and tried endlessly to get the b43 drivers but it just would not happen for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error: Error for wireless request "Set Mode" (8B06) : invalid argument "roaming" penguin chick Linux - Wireless Networking 5 08-22-2008 01:16 PM
"Set Encode" (8B2A) error while trying to add WEP key dahouse Linux - Wireless Networking 20 04-30-2007 11:41 AM
Error for wireless request "Set Encode" (8B2A), help me jiasen_ma Linux - Wireless Networking 4 05-25-2006 02:33 PM
Error for wireless request "Set Encode" (8B2A) for ath0 Suse 9.0 debasisdan Linux - Wireless Networking 2 04-19-2006 01:28 AM
Startup Errors with wireless networking Error for wireless request "Set Encode" Cryptoniks Linux - Wireless Networking 1 03-21-2006 07:06 AM


All times are GMT -5. The time now is 09:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration