LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-26-2011, 05:27 PM   #1
The_JinJ
Member
 
Registered: Apr 2004
Location: Scotland
Distribution: Suse, OpenWRT
Posts: 299

Rep: Reputation: 30
Question OpenSuse 11.4 WPA/WPA2 - not authenticating - password correct


Hi

I have recently installed OpenSuse 11.4 and I'm attempting to get the wireless working.

lspci
Code:
02:04.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 02)
I have updated the firmware so it is functioning, detecting network etc

When I try to connect (using Network Manager) is asks for the WPA key which I enter correctly (checked a million times )

Seems to have an issue with authenticating
Code:
May 26 22:23:18 linux-iv0x NetworkManager[18567]: <info> Activation (wlan0) starting connection 'CrocketandTubs'
May 26 22:23:18 linux-iv0x NetworkManager[18567]: <info> (wlan0): device state change: 3 -> 4 (reason 0)
May 26 22:23:18 linux-iv0x NetworkManager[18567]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
May 26 22:23:18 linux-iv0x NetworkManager[18567]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
May 26 22:23:18 linux-iv0x NetworkManager[18567]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
May 26 22:23:18 linux-iv0x NetworkManager[18567]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
May 26 22:23:18 linux-iv0x NetworkManager[18567]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
May 26 22:23:18 linux-iv0x NetworkManager[18567]: <info> (wlan0): device state change: 4 -> 5 (reason 0)
May 26 22:23:18 linux-iv0x NetworkManager[18567]: <info> Activation (wlan0/wireless): access point 'CrocketandTubs' has security, but secrets are required.
May 26 22:23:18 linux-iv0x NetworkManager[18567]: <info> (wlan0): device state change: 5 -> 6 (reason 0)
May 26 22:23:18 linux-iv0x NetworkManager[18567]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
May 26 22:23:20 linux-iv0x NetworkManager[18567]: <info> (wlan0): device state change: 6 -> 9 (reason 7)
May 26 22:23:20 linux-iv0x NetworkManager[18567]: <warn> Activation (wlan0) failed for access point (CrocketandTubs)
May 26 22:23:20 linux-iv0x NetworkManager[18567]: <info> Marking connection 'CrocketandTubs' invalid.
May 26 22:23:20 linux-iv0x NetworkManager[18567]: <warn> Activation (wlan0) failed.
May 26 22:23:20 linux-iv0x NetworkManager[18567]: <info> (wlan0): device state change: 9 -> 3 (reason 0)
May 26 22:23:20 linux-iv0x NetworkManager[18567]: <info> (wlan0): deactivating device (reason: 0).
Connection fails as you can see.

Router is a Netgear WNR2000v2 and key is set as WPA-PSK [TKIP] + WPA2-PSK [AES]

My key has no special characters but does have an @

Any ideas what is going wrong?

Last edited by The_JinJ; 05-26-2011 at 06:43 PM.
 
Old 05-26-2011, 05:46 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,944

Rep: Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671
Quote:
Originally Posted by The_JinJ View Post
Hi
I have recently installed OpenSuse 11.4 and I'm attempting to get the wireless working.

lspci -
Code:
02:04.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 02)
I have updated the firmware so it is functioning, detecting network etc. When I try to connect (using Network Manager) is asks for the WPA key which I enter correctly (checked a million times ) Seems to have an issue with authenticating. Connection fails as you can see.

Router is a Netgear WNR2000v2 and key is set as WPA-PSK [TKIP] + WPA2-PSK [AES]
My key has no special characters but does have an @
Any ideas what is going wrong?
No, but I can guess, given the reports that have floated around, and my recent experience with loading 11.4.

Apparently, the KDE Network Manager is broken...yet, bizzarely, enabled by default. You have to go into Yast->Software Management, and install the plasmoid-networkmanagement. *THAT* was broken in previous releases, but now works. Yast will complain about having to un-install the network management applet, but confirm the install. Once done, add the network plasmoid onto your desktop (wherever you'd like), and it should work fine from there.
 
Old 05-26-2011, 06:32 PM   #3
The_JinJ
Member
 
Registered: Apr 2004
Location: Scotland
Distribution: Suse, OpenWRT
Posts: 299

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by TB0ne View Post
No, but I can guess, given the reports that have floated around, and my recent experience with loading 11.4.

Apparently, the KDE Network Manager is broken...yet, bizzarely, enabled by default. You have to go into Yast->Software Management, and install the plasmoid-networkmanagement. *THAT* was broken in previous releases, but now works. Yast will complain about having to un-install the network management applet, but confirm the install. Once done, add the network plasmoid onto your desktop (wherever you'd like), and it should work fine from there.
Thank you! Working a treat now

Last edited by The_JinJ; 05-26-2011 at 06:38 PM.
 
Old 05-27-2011, 10:40 AM   #4
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,944

Rep: Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671
Quote:
Originally Posted by The_JinJ View Post
Thank you! Working a treat now
Great to hear...and that is the MOST bizzare thing I've ever encountered. openSUSE *KNOWS* it's broken...even posts about it on their site, but left it the 'default' network manager in the distro. I kind of expected better from them.
 
Old 10-19-2011, 06:56 PM   #5
lshantz
LQ Newbie
 
Registered: Oct 2011
Location: Phoenix, AZ
Distribution: Opensuse
Posts: 19

Rep: Reputation: Disabled
NO!

Nooooo!!! Don't do it! This is the second time I have read this. I made the mistake of believing it. IT cost me a couple of hours to undo the "fix". It totally hosed my networking and I had to go back to the old fashioned ifconfig for awhile. This does NOT fix it apparently in all circumstances. I caution the user, if they consider these instructions to be prepared to have an almost totally borked networking. If it works, great! Watch carefully to what it says it is automatically removing, because you will need to put it back. If it borks it, remove plasmoid-networkmanagement. Then you have to go back and install knetworkmanager-kde!

Quote:
Originally Posted by TB0ne View Post
No, but I can guess, given the reports that have floated around, and my recent experience with loading 11.4.

Apparently, the KDE Network Manager is broken...yet, bizzarely, enabled by default. You have to go into Yast->Software Management, and install the plasmoid-networkmanagement. *THAT* was broken in previous releases, but now works. Yast will complain about having to un-install the network management applet, but confirm the install. Once done, add the network plasmoid onto your desktop (wherever you'd like), and it should work fine from there.
 
Old 10-20-2011, 11:07 AM   #6
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,944

Rep: Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671
Quote:
Originally Posted by lshantz View Post
Nooooo!!! Don't do it! This is the second time I have read this. I made the mistake of believing it. IT cost me a couple of hours to undo the "fix". It totally hosed my networking and I had to go back to the old fashioned ifconfig for awhile. This does NOT fix it apparently in all circumstances. I caution the user, if they consider these instructions to be prepared to have an almost totally borked networking. If it works, great! Watch carefully to what it says it is automatically removing, because you will need to put it back. If it borks it, remove plasmoid-networkmanagement. Then you have to go back and install knetworkmanager-kde!
If you say so, sure. Bear in mind this post was back in May, and the OP posted that things were working fine after doing it.

openSUSE reported this as a bug on their own forums, and SUGGESTED this method of fixing it. The absolute worst that can happen, is that you'll have to use ifconfig/ifup to bring up your network, and go through YAST and re-install knetworkmanager. If it took you a couple of hours to undo this, I have NO IDEA what you did, since it takes less than five minutes to undo/redo it all.
 
  


Reply

Tags
authentication, wpa


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
scripts (kommander and command line) to start wireless devices with wpa/wpa2/wpa-aes Fluxx Linux - Wireless Networking 4 06-28-2010 03:51 AM
Not working wpa/wpa2 for ad hoc mode linux_21 Linux - Newbie 2 02-26-2010 11:59 PM
Does wpa/wpa2 work in adhoc mode?? linux_21 Linux - Newbie 0 02-24-2010 03:36 AM
Configuring Solaris to do Wireless WPA or WPA2? as400 Solaris / OpenSolaris 1 09-17-2008 01:55 PM
Need help with checking if opensuse 10.2 password is correct through php derekalan18 Suse/Novell 2 02-03-2008 12:03 PM


All times are GMT -5. The time now is 08:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration