LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 07-17-2004, 03:34 PM   #1
hornett
LQ Newbie
 
Registered: Jul 2004
Location: England
Distribution: Suse
Posts: 5

Rep: Reputation: 0
Odd problems - Suse 9.1 Netgear Ma101


Hello there!

Firstly I apologise for asking for help with my first post.

And onto my problem....

The helpful guys at Neowin.net's forums have helped me to get my wireless usb point recognised under Suse 9.1 pro which is great but still I am unable to connect the the web. I looked up the iw commands in the manuals and recorded information I thought might help somebody to see what the problem is.

Code:
linux:/home/hornett # iwconfig wlan0
wlan0     IEEE 802.11-DS  ESSID:"TW84623100"  Nickname:"802.11"
          Mode:Managed  Channel:6  Access Point: 00:09:5B:57:xx:xx
          Bit Rate:11Mb/s   Tx-Power=15 dBm
          Retry limit:8   RTS thr=1536 B   Fragment thr=1536 B
          Encryption key:8153-4855-5554-4247-0000-0000-00   Security mode: open
          Power Management: off
          Link Quality:0/0  Signal level:40/100  Noise level:0/0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Code:
linux:/home/hornett # iwlist wlan0 scanning

wlan0     Scan completed :
          Cell 01 - Address: 00:09:5B:57:xx:xx
                    ESSID:"TW84623100"
                    Mode:Managed
                    Channel:6
                    Encryption key: on
                    Quality:0/0  Signal level:17/100  Noise level:0/0
                    Bit Rate:1Mb/s
                    Bit Rate:2Mb/s
                    Bit Rate:5.5Mb/s
                    Bit Rate:11Mb/s
Code:
linux:/home/hornett # iwlist wlan0 key
wlan0     2 key sizes : 40, 104bits
          4 keys available :
                [1]: 8153-4855-5554-4247-0000-0000-00 (104 bits)
                [2]: off
                [3]: off
                [4]: off
          Current Transmit Key: [1]
          Security mode: open
OK the first odd problem is that I seem to be connected to the 'TW...' access point which is correct however I have no web access. I've tried running dhcp wlan0 which didn't fix the problem. Also I've used ifconfig wlan0 up to ensure that the interface is up (which it is).

Second problem is that the signal strength appears to be very low (in Windows XP I always get 90%+ signal strength on the same device).

Unfortunatley, this device came as part of a kit my family chose which included cheap broadband so unfortunatley I have no details about the devices other than I need to use a 128 bit WEP key (which is odd because it is listed as 104 bit above).

Hope somebody can help me out. It seems like I'm so close to having a working internet connection in Linux!

Info

Distribution : Suse 9.1 Professional (free from Novell)
Hardware : x86 with Netgear MA101b (atmel AT76C503A chipset - firmware installed correctly via .rpm)

Thanks.

Andy.

Last edited by hornett; 07-17-2004 at 03:36 PM.
 
Old 07-17-2004, 04:57 PM   #2
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
The command to use is dhcpcd wlan0 which should then get you an IP address.

If it does check ifconfig wlan0 to see that it's got an IP address and route to see if it's also given you a default route for wlan0.

If you have more than one NIC with dhcp you'll have to disable the non wireless one ifconfig eth0 down.

If dhcpcd is still not setting default route then you'll need to put some bits in /etc/sysconfig/network/ifcfg-wlan0

Have a read of ifcfg.template, config, dhcp and wireless in /etc/sysconfig/network folder - you can copy anything you need out of those files into ifcfg-wlan0.

For instance my ifcfg-wlan0 looks like:

STARTMODE='hotplug'
BOOTPROTO='dhcp'
DHCLIENT_MODIFY_RESOLV_CONF='yes'
DHCLIENT_SET_DEFAULT_ROUTE='yes'

WIRELESS_ESSID='your_ESSID'
WIRELESS_KEY=''
WIRELESS_AP=''
WIRELESS_AUTH_MODE=''
WIRELESS_BITRATE='auto'
WIRELESS_CHANNEL=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_FREQUENCY=''
WIRELESS_KEY_0='your_key'
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_POWER='yes'

The difference between key length 128 and the real key length of 104 is because the first 24 bits are static!

Good luck.
 
Old 07-17-2004, 06:13 PM   #3
hornett
LQ Newbie
 
Registered: Jul 2004
Location: England
Distribution: Suse
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by andrewdodsworth
Good luck.
Thanks!

Well I tried what you suggested and it has helped me in as much as automatically entering the data for iwconfig instead of me manually doing it each time however I still have no luck with dhcpcd.

Code:
linux:/etc/sysconfig/network # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

wlan0     IEEE 802.11-DS  ESSID:"TW34623100"  Nickname:"802.11"
          Mode:Managed  Channel:6  Access Point: 00:09:5B:57:10:75
          Bit Rate:11Mb/s   Tx-Power=15 dBm
          Retry limit:8   RTS thr=1536 B   Fragment thr=1536 B
          Encryption key:5153-4855-5554-4247-0000-0000-00   Security mode:open
          Power Management:off
          Link Quality:0/0  Signal level:42/100  Noise level:0/0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

	  
	  
	  
	  
linux:/etc/sysconfig/network # ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:09:5B:57:07:C8
          inet6 addr: fe80::209:5bff:fe57:7c8/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:2820 (2.7 Kb)

	  
	  
	  
linux:/etc/sysconfig/network # dhcpcd wlan0



linux:/etc/sysconfig/network # man route
Reformatting route(8), please wait...


linux:/etc/sysconfig/network # route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
linux:/etc/sysconfig/network #
Seems like it's not getting assigned an IP address then?! Also I noticed that I get a warning at boot suggesting that "Encryption is not enabled" when clearly it is in my settings.

I'm right about ready to give up on this... thing is I _really_ want to get into using Linux properly (and also I don't like being beaten )
 
Old 07-18-2004, 04:35 AM   #4
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
Well it looks like it's contacting the AP - when I've had problems with the key for example it won't get the AP address so it's pretty obvious, however, always useful doublechecking key is correct.

Do you know what internal IP address the AP dhcp server is running on? For example if it is 192.168.1.1 you could always try manually setting your card to say 192.168.1.10 and then try pinging the AP. If that works then try route add default gw 192.168.1.1 wlan0 and see if you can then ping an external IP address or name.
 
Old 07-18-2004, 05:44 AM   #5
hornett
LQ Newbie
 
Registered: Jul 2004
Location: England
Distribution: Suse
Posts: 5

Original Poster
Rep: Reputation: 0
Well, thanks again - but still no luck.

Code:
linux:/home/hornett # ifconfig wlan0 up
linux:/home/hornett # route add default gw 83.46.83.1 wlan0
SIOCADDRT: Network is unreachable
linux:/home/hornett #
I tried a few different IP addresses I copied down from the Windows XP wireless connection status dialog but all with the same end result. I still don't know why my connection is being reported as having 0 link quality and a signal strength of 12/100 when right now in XP it is 87%.


Thanks for your help Andrew!

Last edited by hornett; 07-18-2004 at 05:46 AM.
 
Old 07-18-2004, 06:20 AM   #6
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
Under XP if you open a command box and run ipconfig /all it should tell you what the IP addresses and default routes are. If your AP is using NAT and providing it with a dhcp assigned address then that should be something like 192.168.1.1. It sounds from your post that it could be giving out a real ISP address in which case it's not using dhcp.

By the way I should have mentioned it earlier but it's a good idea to disguise or blank out real IP addresses, MAC addresses, keys etc in your posts - you never know. Obviously some bits are safe ie private IP addresses like 192.168.x.x.
 
Old 07-27-2004, 11:19 AM   #7
ToniT
Senior Member
 
Registered: Oct 2003
Location: Zurich, Switzerland
Distribution: Debian/unstable
Posts: 1,357

Rep: Reputation: 47
hornett:

Could you give the link to the discussion in "Neowin.net's forums" where you got help on configuring SuSE and Netgear Ma101. An other fellow in other thread is strugling with the same problem.
 
Old 07-27-2004, 12:26 PM   #8
hornett
LQ Newbie
 
Registered: Jul 2004
Location: England
Distribution: Suse
Posts: 5

Original Poster
Rep: Reputation: 0
Posted http://www.neowin.net/forum/index.ph...pic=188520&hl=
 
Old 10-12-2004, 09:56 PM   #9
samatman
LQ Newbie
 
Registered: Mar 2004
Distribution: Mandrake 9.2
Posts: 25

Rep: Reputation: 15
how i got it to work

i had that same combination of wireless device and OS.
i got it to work mostly by monkeying with the following: ifup ifdown iwconfig ifconfig dhcpcd route.

on my box the surefire solution i worked out was:

first manually write a /etc/sysconfig/network/ifcfg-wlan0
ifdown wlan0 (just for a fresh start)
ifup wlan0
dhcpcd wlan0 (you really can just do this one and not the ifup i think)
route
route wlan0 (tho sometimes route wlan0 didn' do anything)
after that i could pretty much ping yahoo each time i did this. tho i have no idea about rebooting, if it still woked after that. i've pretty much been blazing through linux distros like a sample appetizer platter.

hope it helps
 
Old 10-12-2004, 09:57 PM   #10
samatman
LQ Newbie
 
Registered: Mar 2004
Distribution: Mandrake 9.2
Posts: 25

Rep: Reputation: 15
oh...and i had to install the pcmcia package too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with netgear ma101 in mandrake 10 cmsdgore Linux - Wireless Networking 6 03-03-2005 03:28 AM
NetGear MA101 and FC2 Lemur Linux - Wireless Networking 10 12-13-2004 03:53 PM
suse 9.0 pro and a netgear ma101 samatman Linux - Wireless Networking 1 06-10-2004 01:25 PM
NetGear MA101 walterw Linux - Networking 1 12-27-2002 09:11 PM
RHL 7.2 Netgear fa311 odd problems rsbecker007 Linux - Networking 0 12-30-2001 09:38 PM


All times are GMT -5. The time now is 03:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration