LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-10-2006, 05:56 AM   #1
bob cashman
LQ Newbie
 
Registered: Jan 2004
Location: panama city florida
Posts: 8

Rep: Reputation: 0
no pci card response on toshiba satellite a65


I have a toshiba satellite a65 (S1062) and have a few problems. I am running red hat enterprise 4 and can't see my pci wireless card. The card is a Dlink dwl-g630. The card and slot both work with windows xp(using it now). I have tried using ndiswrapper and show the driver present but never see the hardware.
lspci output:
00:00.0 Host bridge: ATI Technologies Inc R200 AGP Bridge [Mobility Radeon 7000 IGP] (rev 05)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
00:13.0 USB Controller: ATI Technologies Inc OHCI USB Controller #1 (rev 01)
00:13.1 USB Controller: ATI Technologies Inc OHCI USB Controller #2 (rev 01)
00:13.2 USB Controller: ATI Technologies Inc EHCI USB Controller (rev 01)
00:14.0 SMBus: ATI Technologies Inc ATI SMBus (rev 18)
00:14.1 IDE interface: ATI Technologies Inc ATI Dual Channel Bus Master PCI IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc: Unknown device 434c
00:14.4 PCI bridge: ATI Technologies Inc: Unknown device 4342
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97 Audio Controller
00:14.6 Modem: ATI Technologies Inc IXP AC'97 Modem (rev 01)
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility 7000 IGP02:06.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
02:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
[root@localhost hotplug.d]#

pcmcia_core 59913 2 ds,yenta_socket

[root@localhost hotplug.d]# tail -f /var/log/messages
Jul 9 09:26:08 localhost su(pam_unix)[3221]: session opened for user root by bob(uid=500)
Jul 9 09:27:20 localhost hal.hotplug[3262]: DEVPATH is not set
Jul 9 09:27:41 localhost kernel: PCMCIA: socket f6332c44: *** DANGER *** unable to remove socket power
Jul 9 09:28:07 localhost hal.hotplug[3272]: DEVPATH is not set
Jul 9 09:28:10 localhost kernel: PCMCIA: socket f6332c44: *** DANGER *** unable to remove socket power
Jul 9 09:34:02 localhost hal.hotplug[3297]: DEVPATH is not set
Jul 9 09:34:06 localhost kernel: PCMCIA: socket f6332c44: *** DANGER *** unable to remove socket power
Jul 9 09:35:20 localhost kernel: PCMCIA: socket f6332c44: *** DANGER *** unable to remove socket power
Jul 9 09:36:22 localhost last message repeated 2 times
Jul 9 09:36:56 localhost hal.hotplug[3308]: DEVPATH is not set

any help would be appreciated.
 
Old 07-13-2006, 01:08 PM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,395

Rep: Reputation: 81
Your hardware does not seem to be recognized at pcmcia level. Does any other pcmcia card work?
 
Old 07-13-2006, 02:13 PM   #3
bob cashman
LQ Newbie
 
Registered: Jan 2004
Location: panama city florida
Posts: 8

Original Poster
Rep: Reputation: 0
I dont have another pcmcia card to try, but i agree it doesn't appear to be recognized. I do know that the slot does work in windows as does the card, so the hardware does work.
 
Old 07-15-2006, 09:32 AM   #4
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,395

Rep: Reputation: 81
1. There had been quite a chenge how pccard slot is managed. I do not know how your distro works. Check if you need pcmcia-cs package, if so if installed. It seems that hotplug is working, although I am not sure working correct. Check kernel options.

2. G630 has several versions and different versions use different chip sets. You need to find out what chipset is used on your card. check ndiswrapper page and atheros site.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
toshiba satellite a65 pci and fan problem bob cashman Linux - Laptop and Netbook 2 07-10-2006 06:02 AM
problem shuting down Toshiba A65 S126 with RedHat 9 luizebs Linux - Laptop and Netbook 2 03-24-2006 07:58 PM
video card problem on toshiba satellite emanresu Linux - Hardware 7 11-20-2005 05:22 PM
Internet access on Toshiba A65 laptop moonrover Linux - Networking 1 01-28-2005 12:36 PM
Toshiba Satellite A65 Dual Boot Overheats with Fedora only jpc1258 Linux - Laptop and Netbook 4 01-20-2005 03:10 PM


All times are GMT -5. The time now is 05:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration