LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 09-15-2008, 04:53 PM   #1
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,564
Blog Entries: 1

Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
networking in centos (through virtualbox)


I installed centos on virtualbox. During the install I configured network
adapter 1 (NAT) as dhcp to see if it'll pick up the network. It did. Then I changed the config files to assign a static ip to it. I'm connected to the internet through a router (192.168.1.1)

/etc/sysconfig/network:

Code:
NETWORKING=yes
NETWORKING_IPV6=no
HOSTNAME=localhost.localdomain
GATEWAY=192.168.1.1

# route

Code:
Destination         Gateway     Genmask              Flags    Metric      Ref   use  Iface
192.168.1.0          *                   255.255.255.0     U           0                0        0     eth0
169.254.0.0          *                   255.255.0.0         U            0               0        0     eth0
default                192.168.1.1 0.0.0.0                 UG           0              0          0    eth0
/etc/sysconfig/networking/devices/ifcfg-eth0

Code:
DEVICE=eth0
BOOTPROTO=none
HWADDR=08:00:27:90:F9:62
ONBOOT=yes
NETMASK=255.255.255.0
IPADDR=192.168.1.222
GATEWAY=192.168.1.1
TYPE=Ethernet
/etc/sysconfig/network-scripts/ifcfg-eth0

Code:
DEVICE=eth0
BROADCAST=192.168.1.255
BOOTPROTO=none
HWADDR=08:00:27:90:f9:62
ONBOOT=yes
NETMASK=255.255.255.0
IPADDR=192.168.1.222
GATEWAY=192.168.1.1
NETWORK=192.168.1.0
TYPE=Ethernet
/etc/resolv.conf

Code:
search localdomain
nameserver 192.168.1.1
ping 192.168.1.1 gives 'destination not reachable

yum install somefile gives
[Errno 4] IOError ...Temporary failure in name resolution...

Why is it like that - resolv.conf seems to be ok, isn't it.

I don't know if it matters, but it's on a fedora laptop connected
to the router through wireless connection (ndiswrapper)

any hints

thanks

edit: sorry for the output of 'route' I haven't found a way of copying/pasting from virtualbox (centos) to fedora- I just retyped it.

Last edited by sycamorex; 09-15-2008 at 04:55 PM.
 
Old 09-16-2008, 12:13 PM   #2
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 5.4, Mac OS 10.4 (tiger)
Posts: 1,005

Rep: Reputation: 79
search localdomain should be the last line of the resolv.conf file really and not the first, however it shouldn't be causing that error =/.
 
Old 09-16-2008, 12:35 PM   #3
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,564
Blog Entries: 1

Original Poster
Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
Quote:
Originally Posted by r3sistance View Post
search localdomain should be the last line of the resolv.conf file really and not the first, however it shouldn't be causing that error =/.
thanks for your reply, however, it hasn't helped.

btw, what's this part of route's output:

Code:
169.254.0.0                    *                        255.255.0.0
Why does the network part take 2 octets? Is it anything to do with the fact that it's through virtualbox? Perhaps the nameserver and/or gateway should not be my router's address, should it?
 
Old 09-16-2008, 12:49 PM   #4
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 5.4, Mac OS 10.4 (tiger)
Posts: 1,005

Rep: Reputation: 79
Doesn't surprise me to be honest.

I don't have much (aka any) experience with virtual box. If it's a VM kinda program then it might be that your on a guest and may have to route via your guest. However I would have thought a bridge method might have been better. If you are using VMs might also be an idea just to check you are actually taking a free ip.
 
Old 09-16-2008, 12:55 PM   #5
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,564
Blog Entries: 1

Original Poster
Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
I've read the fine manual and it turns out that virtualbox's NAT only supports static ip's with the help of portforwarding.
So the option that would be better for me is Host Interface Networking. This, in turn, according to virtualbox's manual, works only with wired network hardware.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Latest Version of VirtualBox Kernel Errors on CentOS 5, i386 Doctorzongo Linux - Desktop 15 04-21-2012 08:42 AM
virtualbox install of centos bic Linux - Software 1 06-15-2008 09:30 PM
VirtualBox and networking AQG Linux - Software 2 06-02-2008 12:50 PM
Virtualbox networking madness! ddales Linux - Networking 1 01-28-2008 10:49 PM
LXer: VirtualBox On FC6 / CentOS 4 / OpenSuSE 10.2 LXer Syndicated Linux News 0 02-06-2007 07:03 PM


All times are GMT -5. The time now is 09:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration