LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 07-22-2007, 02:21 PM   #1
DraaX
Member
 
Registered: Jul 2003
Location: B.C. Canada
Distribution: Slackware 14
Posts: 94

Rep: Reputation: 15
Netgear wg111v2, Slackware 12, ndiswrapper,


I am currently running Slackware 12 with default kernel and am trying to get my netgear wg111v2 usb adapter running.

I have installed ndiswrapper and loaded a driver that should work but I have no idea how to configure ndiswrapper so it will recognize my adapter, my network and load on startup.

running "ndiswrapper -l" I see that the "driver installed" and the "device (0846:6a00) present"

Can someone offer me some suggestions on how to get my card to work?

Thanks,


draAx
 
Old 07-23-2007, 11:16 PM   #2
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
modprobe ndiswrapper should load the module and present the interface. Check with iwconfig. You should see a wlan0.

Use iwconfig to set the wireless parameters. Example:
# iwconfig wlan0 essid your_ssid mode Managed key 01234567

Use ifconfig to set the network parameters. If using DHCP, just run dhcpcd to pull an IP address:
dhcpcd wlan0

Exit /etc/rc.d/rc.inet1.conf to store your network and wireless parameters so that they persist after a reboot.
 
Old 07-24-2007, 08:08 PM   #3
DraaX
Member
 
Registered: Jul 2003
Location: B.C. Canada
Distribution: Slackware 14
Posts: 94

Original Poster
Rep: Reputation: 15
Thanks 2Gnu for your reply.

I have tried to set up ndiswrapper using iwconfig and ifconfig but I am still not connected to the net.....

Running iwconfig this is the output :

wlan0 IEEE 802.11g ESSIDff/any Nickname:"draAx"
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate=54 Mb/s Tx-Power:20 dBm Sensitivity=0/3
RTS thr=2432 B Fragment thr=2432 B
Encryption keyff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

And here is my ifconfig output :

wlan0 Link encap:Ethernet HWaddr 00:18:4D:00:C0:9B
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

I am not sure what else I need to do in order to get up and running. I am kind of new to networking. Any suggestions would be greatly appreciated.

Thanks

draAx
 
Old 07-24-2007, 10:08 PM   #4
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
Is your router broadcasting the SSID? If not, turn it on.

What security, if any, are you using? If WPA, there's a whole other step to this. Turn off WPA, WEP and MAC address filtering for now.

Try to bring the interface up first:
# iwconfig wlan0 up

Then, set the SSID and look at the output:
# iwconfig wlan0 essid blah_blah
# iwconfig wlan0

In your example, the NIC is not associated with the router:
Code:
wlan0     IEEE 802.11g ESSID:off/any Nickname:"draAx"
          Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
          Bit Rate=54 Mb/s Tx-Power:20 dBm Sensitivity=0/3
          RTS thr=2432 B Fragment thr=2432 B
          Encryption key:off
          Power Management:off
          Link Quality:0 Signal level:0 Noise level:0
It should look more like this:
Code:
wlan0     IEEE 802.11g  ESSID:"herb"  Nickname:"dipstick"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 01:A3:85:11:B7:90   
          Bit Rate=54 Mb/s   Tx-Power:25 dBm   
          RTS thr=2347 B   Fragment thr=2346 B   
          Encryption key:off
          Power Management:off
          Link Quality:54/100  Signal level:-61 dBm  Noise level:-96 dBm
Note the "Not associated" message is replaced with the BSSID (MAC address) of the router and there are valid numbers for signal strength and noise. Once you are associated, run dhcpcd to get an IP address.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Netgear WG111v2 + ndiswrapper installation problems craigles_penguin Linux - Wireless Networking 9 06-05-2007 05:16 PM
slack11 ndiswrapper and netgear wg111v2 DraaX Linux - Wireless Networking 3 03-10-2007 11:17 PM
Mandriva 2007 (Free) Netgear WG111v2 wireless connectivity using ndiswrapper fluffypenguin Linux - Wireless Networking 1 03-01-2007 02:57 AM
Netgear WG111v2 with RHEL Rai42 Linux - Wireless Networking 2 10-13-2006 10:13 AM
using Netgear WG111v2 in Ubuntu aoberoi Linux - Hardware 0 05-19-2006 02:46 PM


All times are GMT -5. The time now is 11:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration