LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   ndiswrapper worked fine "ESSID:off/any" ??? cant put in an ssid?? (http://www.linuxquestions.org/questions/linux-wireless-networking-41/ndiswrapper-worked-fine-essid-off-any-cant-put-in-an-ssid-282979/)

fatrandy13 01-27-2005 02:19 PM

ndiswrapper worked fine "ESSID:off/any" ??? cant put in an ssid??
 
i am not that new to linux, but still run into problems now and then.....i used ndiswrapper to install the driver for my wireless card, which went through smoothly...the problem now is that when i do iwconfig wlan0, under ESSID it says off/any and i cant change it. i ahve tried many ways including "iwconfig wlan0 essid WIRELESS" and also editing my /etc/rc.d/rc.wireless.conf file ...........any suggestions?

snecklifter 01-27-2005 04:10 PM

If you have encryption you will need to set the key first. You might also want to run
iwlist wlan0 scan
and see if it can see your AP.
Cheers
Chris

fatrandy13 01-27-2005 04:18 PM

yea i tried setting the encryption first and it didnt work....also iwspy wlan0 scan shows nothing.....

snecklifter 01-28-2005 02:42 AM

not iwspy notice, iwlist.

BlitzIsOn 02-27-2005 03:59 AM

I am having the same problem. I got everything installed with no problems. My little "E" light is on meaning the wireless card is "alive". But when I enter iwlist wlan0 scan, the result is "No Scan Results".
The Fn + F2 buttons activate and de-activate the wireless card as they are supposed to.
I configured my essid, but when I enter: iwconfig wlan0, it lists the ESSID is "off/any".

I am using a eMachine M6805, the card is broadcom 54g Max Performance.

Helppp :)

Thanks in advance guys

MRXGRCH 10-28-2007 12:02 PM

Not that this helps...
 
But I have the same problem, or at least a similar one. I cannot get the darn essid to change from "off/any" unless I put it into ad-hoc mode. Then when I change it back to managed, the essid reverts back to "off/any". I have tried using wpa supplicant regardless, and it doesnt work (since I have a WPA secured network). I am quite at wits end...is there any other way to change the essid other than using iwconfig??

2Gnu 10-28-2007 12:09 PM

Try bringing the interface up first:

ifconfig wlan0 up
iwconfig wlan0 essid <my_ssid>

Cotobear 11-11-2007 03:44 AM

Finally a post with the same problem I'm having. On top of that the previous suggestion also does not work (ifconfig wlan0 up --> no results for iwconfig...)

I've had this problem both with Slackware 12 and Fluxbuntu 7.10RC. Wired connections work no problem. iwconfig fails to change any settings.. just as stated above tried manipulation of both rc.wireless.conf and rc.inet1.conf (Slackware).

Using the DLink WUA 2340 wireless usb key personally, ndiswrapper functioning properly, no dice on network configuration :( :(.

Cotobear 11-11-2007 04:03 AM

Wow.. this is a very old thread 0_o

Edit: Playing around more with this stuff I found something even more interesting occuring. Running iwconfig gave essid as "off/any", however upon running iwconfig 10 times over the course of a few seconds, it actually yielded a couple of times essid as "Home" as required.

Is this a symptom of two different pieces of software competeing for control? It seems like perhaps there's another program with a different config file that's over ruling this.

LinuxorDeath 08-21-2008 01:14 PM

Wireless Network Problem in Ubuntu 8
 
I installed the driver with NDisWrapper and I can't seem to connect. I entered in all my wireless router info in network settings. Below is what I got when I ran inwcofig.

matt@2WIRE396:~$ sudo iwconfig
wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:20 dBm Sensitivity=0/3
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Any ideas on what the problem is and what I should do. I wonder what the Host name should be set to.

Hangdog42 08-21-2008 03:34 PM

Why don't you start a new thread. Since this one is so old, it might not really get noticed.

LinuxorDeath 08-22-2008 11:14 AM

http://www.linuxquestions.org/questi...untu-8-664392/

Da_Nuke 08-21-2011 11:32 PM

Bumping this thread because this just happened to me:

Quote:

Originally Posted by Cotobear (Post 2954992)
Edit: Playing around more with this stuff I found something even more interesting occuring. Running iwconfig gave essid as "off/any", however upon running iwconfig 10 times over the course of a few seconds, it actually yielded a couple of times essid as "Home" as required.

Is this a symptom of two different pieces of software competeing for control? It seems like perhaps there's another program with a different config file that's over ruling this.

This happens when you have the network-manager daemon running. Debian and Ubuntu have it enabled by default because the KDE and GNOME desktop environments use it to manage your network settings and to connect to wireless networks from the GUI; as a result, it interferes with what you do from the command line, and if you want to control your wireless interface with good ol' iwconfig and ifconfig, you have to disable it.

To do so, write this:

Code:

# sudo /etc/init.d/network-manager stop
I did this and it worked right away, dhclient fetched properly the IP address from my wireless modem immediately afterwards.

Hope you find it useful. :3


All times are GMT -5. The time now is 05:05 AM.