LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 07-18-2004, 09:32 AM   #1
chr15t0
Member
 
Registered: Jun 2002
Location: London
Distribution: Slackware
Posts: 201

Rep: Reputation: 30
ndiswrapper with Broadcom WLAN mini-PCI :: iwconfig returns ESSID:""


Guys, I am using ndiswrapper to try and get my Broadcom WLAN card working under slack 10

here's a snipped of my history to show what commands I'm running:

Code:
  560  ndiswrapper -i /etc/ndiswrapper/bcmwl5.inf
  561  ndiswrapper -l
  562  ndiswrapper -m
  563  ifconfig eth0
  564  ifconfig eth0 down
  565  iwconfig wlan0 essid "spiration"
  566  iwconfig wlan0 key xxxxxxxxxxxxxxxxxxxxxxxxxx
  567  iwconfig wlan0
everything looks good and ndiswrapper -l shows:

Code:
root@feodor:/etc/ndiswrapper# ndiswrapper -l
Installed ndis drivers:
bcmwl5
also dmesg reports the following:

Code:
ndiswrapper version 0.8 loaded
ndiswrapper adding bcmwl5.sys
PCI: Found IRQ 11 for device 02:03.0
PCI: Sharing IRQ 11 with 00:1f.5
PCI: Sharing IRQ 11 with 00:1f.6
wlan0: ndiswrapper ethernet device 00:90:96:bf:12:3f using driver bcmwl5.sys
But, when I run iwconfig wlan0 to test the settings, the ESSID is always blank.:
Code:
wlan0     IEEE 802.11g  ESSID:""
          Mode:Managed  Frequency:2.462GHz  Access Point: FF:FF:FF:FF:FF:FF
          Bit Rate:54Mb/s   Tx-Power:25 dBm
          RTS thr:2347 B   Fragment thr:2346 B
          Encryption key:8008-1355-8008-1355-8008-1355-80   Security mode:restricted
          Power Management:off
          Link Quality:100/100  Signal level:-10 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:942   Missed beacon:0
What is going on here? I also notice that the Access Point: value in tihe iwconfig output reports FF:FF:FF:FF:FF:FF, which doesn't look like ea valid mac address to me!

Out of interest, iwlist scanning reports that the wireless network is visible, and correctly detects the essid and AP mac address:

Code:
wlan0     Scan completed :
          Cell 01 - Address: 00:80:C8:37:F8:8F
                    ESSID:"spiration"
                    Protocol:IEEE 802.11b
                    Mode:Managed
                    Frequency:2.437GHz
                    Quality:0/100  Signal level:-39 dBm  Noise level:-256 dBm
                    Encryption key:on
                    Bit Rate:1Mb/s
                    Bit Rate:2Mb/s
                    Bit Rate:5.5Mb/s
                    Bit Rate:11Mb/s
Any help in getting iwconfig to work here would be much appreciate.

thanks

christo
 
Old 07-18-2004, 11:07 AM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Moved: This thread is more suitable in Wireless Networking and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 07-18-2004, 11:23 AM   #3
donbellioni
Member
 
Registered: Mar 2004
Location: UK
Distribution: Slackware 10
Posts: 137

Rep: Reputation: 15
Im still trying to get my wireless card working under slack 10 too, so i cant be much help to you, but i did notice one thing which doesnt seem to be quite right with your setup.

Typing "ndiswrapper -l" should display:

Code:
Installed ndis drivers:
bcmwl5   present
The "present" part doesnt seem to be there in what you pasted, i would suggest that you uninstall your current bcmwl5 driver and try a different one untill "ndiswrapper -l" shows something similar to the above.

Cheers.
 
Old 07-18-2004, 01:21 PM   #4
Halli
LQ Newbie
 
Registered: Jan 2003
Location: Reykjavik
Distribution: Suse 9.1 Personal
Posts: 10

Rep: Reputation: 0
Hi.

I've managed to get the same card working under Suse 9.1 Personal. It's just a matter of fiddling arround until you get it working. donbellioni is right about the "present" needing to be there. One tip I could give you is to try the bcmwl5a.inf driver instead of bcmwl5.

Here are the forum discussions I found most useful, just print'em out and try until you succeed:

The 'a' version might work better
Good step-by-step instructions
This should explane the 'present' issue, among other things
my experience


And finally, I'm trying to get some help to automate everything here at Suse forums


Don't give up. There are many approaches to this ndiswrapper thing, just have to find one that works for you :O I'm writing this reply using my wireless card under linux, and it feels GREAT!!!



---------------------------
Specs: Suse 9.1 Personal on a Dell Latitude D400, Dell TrueMobile 1300 WLan Mini-PCI card (Broadcom BCM94360 802.11g)
 
Old 07-18-2004, 02:12 PM   #5
chr15t0
Member
 
Registered: Jun 2002
Location: London
Distribution: Slackware
Posts: 201

Original Poster
Rep: Reputation: 30
you're right, but that's because I'd been fidding with it all afternoon.. so just to show again what's happening:

Code:
root@feodor:/home/system/temp/AR# ndiswrapper -l
Installed ndis drivers:
bcmwl5a present
root@feodor:/home/system/temp/AR# insmod ndiswrapper
Using /lib/modules/2.4.26/misc/ndiswrapper.o
root@feodor:/home/system/temp/AR# iwconfig wlan0 essid spiration
root@feodor:/home/system/temp/AR# iwconfig wlan0 mode Managed
root@feodor:/home/system/temp/AR# iwconfig wlan0 key xxxxxxxxxxxxxxxxxxxxxxxxxx
root@feodor:/home/system/temp/AR# iwconfig wlan0
wlan0     IEEE 802.11g  ESSID:""
          Mode:Managed  Frequency:2.462GHz  Access Point: FF:FF:FF:FF:FF:FF
          Bit Rate:54Mb/s   Tx-Power:25 dBm
          RTS thr:2347 B   Fragment thr:2346 B
          Encryption key:8008-1355-8008-1355-8008-1355-80   Security mode:restricted
          Power Management:off
          Link Quality:100/100  Signal level:-10 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:90   Missed beacon:0
Any idea why ths ESSID refuses to set itself?

christo
 
Old 07-18-2004, 02:35 PM   #6
donbellioni
Member
 
Registered: Mar 2004
Location: UK
Distribution: Slackware 10
Posts: 137

Rep: Reputation: 15
From my own experience with the broadcom chipset card i have, its best to set the mode to Auto.

Code:
iwconfig wlan0 mode Auto
then set your essid and it should appear when you query iwconfig.
 
Old 07-18-2004, 02:41 PM   #7
chr15t0
Member
 
Registered: Jun 2002
Location: London
Distribution: Slackware
Posts: 201

Original Poster
Rep: Reputation: 30
still no cigar.. I'm' still getting no ESSID and a dodgy AP mac address:

Code:
root@feodor:/home/system/temp/AR# ndiswrapper -i bcmwl5a.inf
Installing bcmwl5a
root@feodor:/home/system/temp/AR# ndiswrapper -l
Installed ndis drivers:
bcmwl5a present
root@feodor:/home/system/temp/AR# insmod ndiswrapper
Using /lib/modules/2.4.26/misc/ndiswrapper.o
root@feodor:/home/system/temp/AR# iwconfig wlan0 essid spiration
root@feodor:/home/system/temp/AR# iwconfig wlan0 key xxxxxxxxxxxxxxxxxxxxxxxxxx
root@feodor:/home/system/temp/AR# iwconfig wlan0 mode Auto
root@feodor:/home/system/temp/AR# iwconfig wlan0
wlan0     IEEE 802.11g  ESSID:""
          Mode:Auto  Frequency:2.462GHz  Access Point: FF:FF:FF:FF:FF:FF
          Bit Rate:54Mb/s   Tx-Power:25 dBm
          RTS thr:2347 B   Fragment thr:2346 B
          Encryption key:8008-1355-8008-1355-8008-1355-80   Security mode:restricted
          Power Management:off
          Link Quality:100/100  Signal level:-10 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:4   Missed beacon:0
I'm wondering if the linuxant option might be worth a try? is it free, or is there a 30-day catch there?

christo
 
Old 07-18-2004, 02:47 PM   #8
donbellioni
Member
 
Registered: Mar 2004
Location: UK
Distribution: Slackware 10
Posts: 137

Rep: Reputation: 15
I would set essid last, but i have the same problem as you with regards to the dodgy AP MAC address.

Linuxant is an option im exploring also, and yes after 30 days you must buy a $20 lifetime license to continue to use it.
 
Old 07-19-2004, 05:15 AM   #9
chr15t0
Member
 
Registered: Jun 2002
Location: London
Distribution: Slackware
Posts: 201

Original Poster
Rep: Reputation: 30
I have posted about this on the ndiswrapper maling list and I'm going to have another poke at it this evening when I get home.. possible options involve just fiddling with the AP - trying it without WEP to see if that works (altho I tried that yesterday anyway). It has also been suggested that every time the setup is changed, you should remove the modulde and re-insert (insmod). I'll post back later when I've tried all this out.

christo
 
Old 07-19-2004, 01:33 PM   #10
burnt_toast
Member
 
Registered: Aug 2003
Distribution: RedHat (What else?)
Posts: 36

Rep: Reputation: 15
I'm having the same problem

I made a post to the forum yesterday (with no response as of yet) with a similar problem. Everything seems to be loading fine, but the essid won't seem to set, and the service fails to start (it states that there is no such device). I'd appreciate any input that anyone could give on this subject.

My original post is here

Thanks in advance

Last edited by burnt_toast; 07-19-2004 at 01:34 PM.
 
Old 07-22-2004, 09:23 AM   #11
efanning
Member
 
Registered: Jul 2004
Distribution: Right now - Ubuntu 7.04
Posts: 81

Rep: Reputation: 15
I'm having similar problems with my

HP Pavilion ze4805us
Mandrake 10 - Official
Broadcomm Wireless chipset

The only way that I can get it reconize my essid is if I turn off WEP on my Linksys router and then boot my Linux. Then I turn WEP back on, I loose essid until I put in my encryption, then I can see it again. But if I reboot Mandrake, then I'm screwed. It won't find the Linsys router again and it won't keep my encryption.

I'm looking at adding the information into the ifcfg-wlan0 file.
 
Old 07-22-2004, 09:47 AM   #12
burnt_toast
Member
 
Registered: Aug 2003
Distribution: RedHat (What else?)
Posts: 36

Rep: Reputation: 15
The way that I got it to recognize was by putting my WEP key as OPEN instead of RESTRICTED. After that, it kept my essid without a problem, and it picked up the MAC address of my router.
 
Old 07-22-2004, 09:57 AM   #13
Halli
LQ Newbie
 
Registered: Jan 2003
Location: Reykjavik
Distribution: Suse 9.1 Personal
Posts: 10

Rep: Reputation: 0
efannig, here's a good post about how to edit the ifcfg-wlan0, by an Andrew Symington:

a little quote:
Quote:
Step 1 : Plug the card into the PCMCIA bay and ensure PCMCIA kernel support is enabled on your laptop. Also ensure ndiswrapper has been compiled and installed as per the instructions on their website.

Step 2 : Activate The card
You have to log in as root...
#> modprobe ndiswrapper

if you type iwconfig you should see something like the following

wlan0 IEEE 802.11b ESSID:"" Nickname:""
Mode:Managed Frequency:2.472GHz Access Point: 00:0C:CE:2A:EB:5C
Bit Rate=11Mb/s Tx-Power:9 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:off
Power Management:off
Link Quality:97/100 Signal level:-55 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:6200 Invalid misc:250236 Missed beacon:0

This means that the card is active. However, you still need to bring the card/interface up...

Step 3 : Bringing the card up
In the /etc/sysconfig/network directory create a file called ifcfg-wlan0
In it, put the following information (where XYZ = network name (ESSID))

######################
BOOTPROTO='dhcp'
DHCLIENT_SET_DOWN_LINK='yes'
MTU=''
REMOTE_IPADDR=''
STARTMODE='hotplug'
UNIQUE=''
WIRELESS_ESSID='XYZ'
WIRELESS_KEY=''
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
######################

Now, save this file. As root, type 'ifup wlan0' or (for more safety) 'ifup wlan0 wlan0' - (the first argument specifies that ifup should use the configuration file ifcfg-wlan0 to bring up the device).

Step 4 : Uncertainty
Sometimes, DHCPCD doesn't play nice
So, what you have to do is type dhcpcd wlan0 to get all the info again...
It may prompt you to delete a /var/run/dhcp-wlan.pid file. You can safely delete it and retry 'dhcpcd wlan0'. Press CTRL+C if it hangs (donno why it does this).

Step 5: Test!
Type 'ping www.yahoo.com' and you should get a response on the commandline. Mozilla should also operate to a decent degree. However, I have had problems making Konqueror play ball. Life is pain!

I always have to follow step 4 and type dhcpcd wlan0 (no deleting needed though), then I get wlan0 warning: using NO encryption

... then it hangs (have to do ctrl+c) - but it does the trick!
 
Old 07-22-2004, 01:04 PM   #14
efanning
Member
 
Registered: Jul 2004
Distribution: Right now - Ubuntu 7.04
Posts: 81

Rep: Reputation: 15
Thanx Halli, I'll give it a try when I get home. I'll post my results.
 
Old 07-23-2004, 03:09 PM   #15
efanning
Member
 
Registered: Jul 2004
Distribution: Right now - Ubuntu 7.04
Posts: 81

Rep: Reputation: 15
Halli, that unfortunatly didn't work. When I put in my wireless key and ran ifup wlan0 it came back and said trying to connect to xxxxxxxxxx <---my wireless key then hung. I'm trying ndiswrapper 0.8. Going to try 0.7 and see if there is a difference.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ndiswrapper worked fine "ESSID:off/any" ??? cant put in an ssid?? fatrandy13 Linux - Wireless Networking 12 08-21-2011 11:32 PM
Dell wireless WLAN 1450 Dual Band WLAN Mini-PCI card not recognised pitts68 Linux - Wireless Networking 102 02-28-2005 07:21 AM
ndiswrapper, linksys 802.11g, essid not "sticking" bishiraver Linux - Wireless Networking 4 07-18-2004 03:48 PM
"Anaconda" and "mini-wm" lost connection to display :1.0;??? cbrittain Fedora - Installation 2 03-14-2004 11:22 AM
"Anaconda" and "mini-wm" lost connection to display :1.0;??? cbrittain Linux - General 0 02-24-2004 05:04 PM


All times are GMT -5. The time now is 07:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration