LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 01-13-2005, 08:01 PM   #1
sketchydave
Member
 
Registered: Nov 2004
Location: Boston, MA
Distribution: Fedora Core and Ubuntu 6.06
Posts: 48

Rep: Reputation: 15
ndiswrapper with broadcom on fedora core 3


Ugh, I'm at a loss. I'm running Fedora Core 3 on a Compaq Presario 2585US. Here's the version:
Linux version 2.6.10-1.737_FC3 (bhcompile@porky.build.redhat.com) (gcc version 3
.4.2 20041017 (Red Hat 3.4.2-6.fc3)) #1 Mon Jan 10 13:50:10 EST 2005

Now I'm trying to get ndiswrapper to work and I'm getting stuck. I downloaded ndiswrapper, the windows drivers, and I think gcc is installed. Does this mean it is:
[sketchydave@localhost ~]$ gcc
gcc: no input files

And I go to run it and I get stuck at "bash: ndiswrapper: command not found"
Here's everything from the terminal...any ideas?


[root@localhost ndiswrapper-1.0rc2]# make install
make -C driver install
make[1]: Entering directory `/home/sketchydave/ndiswrapper-1.0rc2/driver'
make -C /lib/modules/2.6.10-1.737_FC3/build SUBDIRS=/home/sketchydave/ndiswrapper-1.0rc2/driver \
NDISWRAPPER_VERSION=1.0rc2 \
EXTRA_VERSION= modules
make[2]: Entering directory `/lib/modules/2.6.10-1.737_FC3/build'
/home/sketchydave/ndiswrapper-1.0rc2/driver/Makefile:59: CONFIG_DEBUG_SPINLOCK conflicts with spinlocks used by Windows driver. There is a workaround for it inndiswrapper, but it may not work correctly. Don't complain about kernel crashesuntil CONFIG_DEBUG_SPINLOCK is disabled.
Building modules, stage 2.
MODPOST
make[2]: Leaving directory `/lib/modules/2.6.10-1.737_FC3/build'


*** WARNING: Kernel is compiled with 4K stack size option (CONFIG_4KSTACKS); many Windows drivers will not work with this option enabled. Disable CONFIG_4KSTACKS option, recompile and install kernel


mkdir -p /lib/modules/2.6.10-1.737_FC3/misc
install -m 0644 ndiswrapper.ko /lib/modules/2.6.10-1.737_FC3/misc
/sbin/depmod -a
make[1]: Leaving directory `/home/sketchydave/ndiswrapper-1.0rc2/driver'
make -C utils install
make[1]: Entering directory `/home/sketchydave/ndiswrapper-1.0rc2/utils'
install -D -m 755 loadndisdriver /sbin/loadndisdriver
install -D -m 755 ndiswrapper /usr/sbin/ndiswrapper
install -D -m 755 ndiswrapper-buginfo /usr/sbin/ndiswrapper-buginfo
make[1]: Leaving directory `/home/sketchydave/ndiswrapper-1.0rc2/utils'
mkdir -p -m 0755 /usr/share/man/man8
install -m 644 ndiswrapper.8 /usr/share/man/man8
[root@localhost ndiswrapper-1.0rc2]# ndiswrapper -i /home/sketchydave/bcmwl5.inf
bash: ndiswrapper: command not found
 
Old 01-13-2005, 08:26 PM   #2
tormented_one
Member
 
Registered: Oct 2004
Location: Small Town USA
Distribution: slamd64 2.6.12 Slackware 2.4.32 Windows XP x64 pro
Posts: 383

Rep: Reputation: 30
I didnt have to do any of that to get my ndiswrapper driver working. I un-tared the .tar.gz file, mounted the cd with the windows drivers, then from /ndiswrapper/utils/./ndiswrapper -i *the .inf file from cd(Mine was /media/cdrom/drivers/***.inf, then had to lspci -v to find the pci number for the card and then lspci -n and match the numbers and find the pciid to bind to it will be a 0000:0000 number

hers my lspci -n:
00:00.0 Class 0600: 8086:7190 (rev 02)
00:01.0 Class 0604: 8086:7191 (rev 02)
00:0d.0 Class 0200: 8086:1229 (rev 05)
00:0e.0 Class 0300: 10de:002d (rev 15)
00:0f.0 Class 0400: 11de:6057 (rev 02)
00:10.0 Class 0401: 1274:5000
00:14.0 Class 0601: 8086:7110 (rev 02)
00:14.1 Class 0101: 8086:7111 (rev 01)
00:14.2 Class 0c03: 8086:7112 (rev 01)
00:14.3 Class 0680: 8086:7113 (rev 02)

the last one is my wireless card so I would: torm@darkside~ndiswrapper/utils/./ndiswrapper -d 0680:8086. Then all I had to do was modprobe ndiswrapper then do the if/iw config to set it up. Also you have to do the ./ndiswrapper -i and ./ndiswrapper -d from the /utils in your ndiswrapper dir.
Never did I do any type of make or make install, I believe its ready to go when you un-tar the tar.gz file.


*also just try cd to utils from the ndiswrapper dir that might fix it.

Last edited by tormented_one; 01-13-2005 at 08:28 PM.
 
Old 01-13-2005, 11:34 PM   #3
PEACEYALL
Member
 
Registered: Jan 2005
Posts: 41

Rep: Reputation: 15
Well i think your ndiswrapper is installed. NOw just put ure windows drivers in a folder and cd to it in terminal. Now make sure ure root and type ndiswrapper -i drivername.ini . So now the driver is loaded. Now type ndiswrapper -m . And now modprobe ndiswrapper. Now evrything should be fine. The last step is to type dhclient wlan0 and thats it. Now each time u restart ur eocmputer just in terminal type : modprobe ndiswrapper and dhclient wlan0 and the internet will work.

Thats how i got mine to work so hope it worx on ures too.
 
Old 01-14-2005, 07:44 AM   #4
sketchydave
Member
 
Registered: Nov 2004
Location: Boston, MA
Distribution: Fedora Core and Ubuntu 6.06
Posts: 48

Original Poster
Rep: Reputation: 15
The problem I'm having is when I try to type in the command, this is what I'm getting:

[root@localhost ndiswrapper-1.0rc2]# ndiswrapper -i /home/sketchydave/bcmwl5.inf
bash: ndiswrapper: command not found

When I type in "ndiswrapper" it comes up with "command not found". I haven't gotten past this step. I'm wondering if I'm putting in the right syntax or what.
 
Old 01-14-2005, 08:01 AM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
A) Are you running the ndiswrapper command as root.
B) If you su'd to root, try running 'bash -l' just incase your paths aren't setup, then run 'which ndiswrapper' to see if it is present. If not, you may need to install it.
C) You may also check if you have the wireless-tools package installed.
 
Old 01-14-2005, 08:26 AM   #6
sketchydave
Member
 
Registered: Nov 2004
Location: Boston, MA
Distribution: Fedora Core and Ubuntu 6.06
Posts: 48

Original Poster
Rep: Reputation: 15
Thank you jschiwal! I ran "bash -l" and it suddenly is working! No more command not found. Now I'm having issues finding the right driver, but that I should be able to figure out on my own.

Just for my knowlege, why did "bash -l" fix it? I googled it and got some info on the command, but I wonder what the issue was.

Thanks again!
 
Old 01-14-2005, 09:36 AM   #7
sketchydave
Member
 
Registered: Nov 2004
Location: Boston, MA
Distribution: Fedora Core and Ubuntu 6.06
Posts: 48

Original Poster
Rep: Reputation: 15
DONE!

woohoo!!! found the right driver. For anyone who has a similar problem, you need to get the drivers from a Dell TrueMobile 1300 extract it on a PC and find the bcmwl5.inf driver. Then I emailed it to myself and loaded it (while wired) onto the linux machine. For some reason I was getting corrupt drivers from Compaq and other locations. I remember when I reinstalled Windows XP the wireless drivers were a bit of a pain to install as well. At any rate the driver works for the Broadcom BCM94306MP.

My particular problem was I kept getting "command not found" when I typed in ndiswrapper. And I do have gcc installed. I logged in as root, typed in "bash -l" as suggested and then it reconized the command. I followed one of the several ndiswrapper tutorials on the site and we have success!

wlan0: ndiswrapper ethernet device 00:90:4b:43:63:75 using driver bcmwl5
wlan0: encryption modes supported: WEP, WPA with TKIP, WPA with AES/CCMP
ndiswrapper: driver bcmwl5 (Broadcom,11/27/2004, 3.100.35.0) added

Thanks again everyone!
 
Old 01-16-2005, 07:43 AM   #8
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
To answer your last question, the '-l' option stands for 'login shell'.

You don't want to have paths set by .bashrc because this script is run every time you start a new terminal such as konsole. 'bash -l' will run the ~/.profile or ./.bash_login script, depending on which is present. Since root never logged in, the login script(s) never ran.
 
Old 01-16-2005, 10:59 AM   #9
big_mac126
Member
 
Registered: Oct 2004
Location: Toronto
Distribution: Fedora Core 4
Posts: 58

Rep: Reputation: 15
ndiswrapper (the executable) is actually located in the /usr/sbin dir (if you did "make install") so if /usr/sbin isnt in your path, you need to add it (either temp or in a bash_profile or bash_rc)
 
Old 01-17-2005, 12:02 AM   #10
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I had a thought that I thought I might add. Linux distro's have a way so simply adjust the amount of security that you want for your system. A higher level may by default not include the directorys /sbin and /usr/sbin.
 
Old 01-17-2005, 05:53 AM   #11
sketchydave
Member
 
Registered: Nov 2004
Location: Boston, MA
Distribution: Fedora Core and Ubuntu 6.06
Posts: 48

Original Poster
Rep: Reputation: 15
I'll check it out. Thanks for the tip!

Still having issues with wireless. I posted in a new entry, the problem I was having is now fixed. Now its an issue with viewing my AP and picking up an IP address.

After checking the boards I'm apparently not alone. Fedora and broadcom don't always seem to play nice. I might try another distro in a couple weeks to see if that improves it.

The plus side is I've learned a whole lot about Linux in the process and I can still use a wired network.
 
Old 04-29-2005, 10:53 AM   #12
mico3002
LQ Newbie
 
Registered: Apr 2005
Posts: 5

Rep: Reputation: 0
Hi,sketchydave

I have read all your posts, sketchydave but I still do not have Internet working.
I also have the same Wireless card as you and correctly installed ndiswrapper with correct driver.
The problem is with IP (wlan0 cannot determine it) and says ACCESS POINT: UNKNOWN

Can you explain to me in more detail what you did to get IP address?

Thanks a lot;

PS If you do not want to post it on this forum, my email is zdjuric@gmail.com
 
Old 04-29-2005, 10:55 AM   #13
mico3002
LQ Newbie
 
Registered: Apr 2005
Posts: 5

Rep: Reputation: 0
Here is the screenshot of the situation (more or less);

http://www.freewebs.com/goldenpine/screenshot.png
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NDISWRAPPER 1.1 and FEDORA CORE 3 basketkase999 Linux - Wireless Networking 2 03-19-2005 03:06 PM
Fedora Core 1, Ndiswrapper, and Broadcom wireless card... bmike30 Linux - Wireless Networking 1 09-30-2004 12:26 AM
Broadcom Corporation BCM94306 802.11g on Fedora core 2. honest Linux - Newbie 1 06-27-2004 08:57 AM
Broadcom V.92 MDC Modem for Dell Inspiron 1100 not being recognized by Fedora Core 1. cddesjar Linux - Hardware 1 02-07-2004 08:07 PM
Broadcom V.92 MDC Modem for Dell Inspiron 1100 not being recognized by Fedora Core 1. cddesjar Linux - Laptop and Netbook 0 01-22-2004 11:31 AM


All times are GMT -5. The time now is 02:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration