LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Ndiswrapper/ Wireless keeps disconnecting (http://www.linuxquestions.org/questions/linux-wireless-networking-41/ndiswrapper-wireless-keeps-disconnecting-557448/)

woodpecka_04 05-29-2007 10:10 AM

Ndiswrapper/ Wireless keeps disconnecting
 
Hello,

I have recently set up wireless on my laptop in FC6, all seemed to be working fine. However, I keep finding that when I am inactive (and even sometimes when I'm not) for a few minutes the network disconnects then reconnects straight away. It is quite bizarre. Part of my dmesg says:

ndiswrapper (iw_set_freq:384): setting configuration failed (00010003)

and I don't know what this means. I have messed with the power settings so I don't think they are causing the network to die. It is beginning to get quite annoying having the message pop up constantly in the corner of the screen. I am currently using NetworkManager to connect.

Does anyone know what may be causing this line in my dmesg and how I can stop it?

Cheers

Lenard 05-29-2007 11:24 AM

Review this thread: http://www.linuxquestions.org/questi...d.php?t=554326

Shadow_7 06-04-2007 10:38 AM

It sounds like your card might be using it's power management capabilities. Or trying to anyway.

try
# iwconfig wlan0 power off
or
# iwconfig wlan0 power all

In the first one, you're not actually turning the power off, you're turning the power management off. Which means it doesn't try to turn off the device when it's not being used. The # thing just means to do it as root. Not that this is your issue, but it sounds like it could be.

dburnett77 06-04-2007 10:39 AM

Add, also, that in your firewall you might need to set access for bootps (port 67). It took me a while to figure this one out. If your card sends on this request, and gets blocked, it re-initializes everything. At least, on my system.

woodpecka_04 06-04-2007 11:14 AM

I tried the power saving commands, but unfortunately they don't seem to be recognised (I'm using eth0 rather than wlan0):

root - sbin > ./iwconfig eth0 power all
Error for wireless request "Set Power Management" (8B2C) :
SET failed on device eth0 ; Operation not supported.

root - sbin > ./iwconfig eth0 power off
Error for wireless request "Set Power Management" (8B2C) :
SET failed on device eth0 ; Operation not supported.

I looked at my firewall policy as well but could not find bootps anywhere. Where about is it exactly?

Thanks for getting back to me

dburnett77 06-05-2007 06:24 AM

Sometimes, ports 53 and 67 need to be open on your system for proper access. 53=DNS, 67-68=DHCP (bootps).

I know if I try to access my router remotely, and port 67 is not open; then everything gets resequenced. I use Firestarter and just set a Policy for access.

You could try setting up these ports, but be sure to set your IP as the only one that can access them.


All times are GMT -5. The time now is 05:35 PM.