LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 11-08-2004, 04:34 AM   #1
toddncl
Member
 
Registered: Jul 2003
Location: north of england
Distribution: suse 9.1
Posts: 56

Rep: Reputation: 15
ndiswrapper: unsupported module


Hi all, i have been having one or two problems with ndiswrapper. i have installed it myself sevral time now but have had no luck getting it to work. i always get the same error

dmesg:
Code:
ndiswrapper: unsupported module, tainting kernel.
ndiswrapper version 0.10 loaded (preempt=no,smp=no)
ndiswrapper (wrapper_init:2287): loadndiswrapper failed (1536);check utils version mismatch
and modprobeing gives:
Code:
linux:~ # modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.8-24.3-default/extra/ndiswrapper.ko): Invalid module format
however:
Code:
linux:~ # ndiswrapper -l
Installed ndis drivers:
3c154g72        driver present, hardware present
linux:~ #
hmm...
browsing the forums led me into thinking it was a kernel problem so i downloaded the latest kernel and source (suse 9.2) 'make clean' 'make' 'make install' ndiswrapper (the cvs build as the 3com 3c154g72 had a few issues only just resolved.) and i still get the bloody error!! any ideas on where i can go from here or is it a trip to linuxant that i require?

cheers.

EDIT:-

right then, i have now re-installed suse 9.2 and i still get the same errors using the default kernel any ideas anyone??

Code:
Installed ndis drivers:
3c154g72        driver present, hardware present
linux:~/wifi/ndiswrapper # modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.8-24-default/extra/ndiswrapper.ko): Invalid module format
linux:~/wifi/ndiswrapper #

Last edited by toddncl; 11-08-2004 at 03:13 PM.
 
Old 11-08-2004, 03:53 PM   #2
snecklifter
Member
 
Registered: Mar 2004
Location: UK/West Yorkshire/Huddersfield
Distribution: Fedora 7
Posts: 982

Rep: Reputation: 30
Hi toddncl,

I think this might be one for the irc chatroom. Pop in and have a word with the dudes who actually compile the stuff (I'm assuming you have a means of internet access!) and see what they say.

irc.freenode.net #ndiswrapper

Regards
Chris
 
Old 11-21-2004, 03:45 PM   #3
mp3johnnyb
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
solution

hi

i found a solution, having the same problem with suse 9.2:

I followed another hint found via google and did the following easy steps:
rm /lib/modules/$(uname -r)/extra/ndiswrapper.ko
cp /lib/modules/$(uname -r)/misc/ndiswrapper.ko /lib/modules/$(uname -r)/extra


it worked perfectly out

please tell me if it worked out for you as well!

kind regards!
 
Old 11-30-2004, 02:59 PM   #4
Gayle
LQ Newbie
 
Registered: Jan 2003
Posts: 10

Rep: Reputation: 0
Ah, perfection

The Suse RPM didn't work with my USB adapter so I downloaded 0.12 and got the same error you reported. Your fix worked perfectly, now to work out exactly what to do with this thing...
 
Old 11-30-2004, 08:26 PM   #5
buldir
Member
 
Registered: Mar 2004
Location: Fairbanks, AK USA
Posts: 135

Rep: Reputation: 15
I have the same problem, but I have no "misc" directory in /lib/modules/. Any thoughts?

Last three lines from dmesg:

ndiswrapper: unsupported module, tainting kernel
ndiswrapper version 0.8 loaded
ndiswrapper adding w70n51.sys

I am running Suse 9.1 with an Intel 2100 WIFI card. I installed ndiswrapper via Yast.
 
Old 11-30-2004, 09:11 PM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
Originally posted by buldir
I have the same problem, but I have no "misc" directory in /lib/modules/. Any thoughts?

Last three lines from dmesg:

ndiswrapper: unsupported module, tainting kernel
ndiswrapper version 0.8 loaded
ndiswrapper adding w70n51.sys

I am running Suse 9.1 with an Intel 2100 WIFI card. I installed ndiswrapper via Yast.
It looks fine so far. Don't worry about the unsupported module error. All that means is that ndiswrapper isn't released under the same license as the kernel. The next two lines show that the ndiswrapper module loaded successfully and that it found the driver you pointed it towards.

In theory, you should be able to configure the card with iwconfig and then get an IP address from a DHCP server or assign one with ifconfig.

By the way, if you have an Intel 2100 card, you are really going to want to check out the ipw2100 project. That would give you native linux driver support instead of using Windows drivers.
 
Old 11-30-2004, 10:30 PM   #7
buldir
Member
 
Registered: Mar 2004
Location: Fairbanks, AK USA
Posts: 135

Rep: Reputation: 15
OK, but when I do a dmesg | tail , I never get anything like:

wlan0: ndiswrapper ethernet device xx:xx:xx:xx:xx:xx using driver xxxxx

In fact, when I type iwconfig I have eth1 as my wireless device.

lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11b ESSID:"" Nickname:"ipw2100"
Mode:Managed Channel:0 Access Point: 00:00:00:00:00:00
Bit Rate=0kb/s Tx-Power=0 dBm
Retryn RTS thr=2304 B Fragment thr:2332 B
Encryption keyff

sit0 no wireless extensions.

Is my next step to do:

iwconfig eth1 essid NetName mode Managed enc on key HEXKEY?
 
Old 11-30-2004, 11:30 PM   #8
buldir
Member
 
Registered: Mar 2004
Location: Fairbanks, AK USA
Posts: 135

Rep: Reputation: 15
OK. Farther up in the dmesg output is this stuff:

ipw2100: Intel(R) PRO/Wireless 2100 Network Driver, 0.39
ipw2100: Copyright(c) 2003-2004 Intel Corporation
PCI: Found IRQ 11 for device 0000:02:02.0
Detected ipw2100 PCI device at 0000:02:02.0, dev: eth1, mem: 0xD0220000-0xD0220FFF -> e0a1a000, irq
: 11
eth1: Using hotplug firmware load.
eth1: Firmware not available or load failed
eth1: ipw2100_get_firmware failed: -2
eth1: Failed to power on the adapter.
eth1: Failed to start the firmware.

It seems eth1 is being managed by hotplug, but how do I turn it off?
 
Old 12-01-2004, 03:19 AM   #9
mp3johnnyb
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
yast

how

i think you can turn your ipw2000 off via yast (perhaps)

i don't know, why hotplug is automatically enabled, but is this really a problem? did you try iwconfig eth1 enc <hexkey>?
does it work or doesnt it even work out at all?


Last edited by mp3johnnyb; 12-01-2004 at 03:21 AM.
 
Old 12-01-2004, 07:42 AM   #10
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
OK, but when I do a dmesg | tail , I never get anything like:

wlan0: ndiswrapper ethernet device xx:xx:xx:xx:xx:xx using driver xxxxx
That is probably because you've never gotten ndiswrapper installed. This is a message specific to that driver.

Quote:
In fact, when I type iwconfig I have eth1 as my wireless device.
This is not a problem. In fact it is an extremely good thing. It means that your system has recognized your wireless card, has called it eth1, and it may be ready to configure.

At this point I would try to use iwconfig to configure the card. If it works your good to go. If I were you, I'd forget about ndiswrapper and concentrate on using ipw2100 since it seems to be working. If you can configure the card and it works, you can ignore the hotplug stuff.
 
Old 12-01-2004, 01:48 PM   #11
buldir
Member
 
Registered: Mar 2004
Location: Fairbanks, AK USA
Posts: 135

Rep: Reputation: 15
Thanks for your comments. I did finally get it working with ndiswrapper and WinXP drivers. After a reboot eth1 became wlan0 and I got:

wlan0: ndiswrapper ethernet device xx:xx:xx:xx:xx:xx using driver xxxxx

in dmesg. However, the card does not connect to the access point after I type:

ifup wlan0

I have a file called ifcfg-wlan0-id-`My Wireless MAC Address` in /etc/sysconfig/network containing the ESSID, WEP key, etc. However, when I want to change something in it I have to physically do it using vi or text editor, meaning:

iwconfig wlan0 essid "test"

does not change the essid ID to test. No matter what I try and change using iwconfig, it does not write to that file. I put my wireless config file in that directory because that is where my eth0 config file is. When I do make changes, they do show up in the network devices configuration in Yast. Then I reboot. Still doesn't connect. I do:

dmesg

and get many errors related to ipv6. So I disabled ipv6 by changing /etc/modules.conf:

# alias net-pf-10 ipv6
alias net-pf-10 off

After a depmod -a and a reboot, the errors in the dmesg output were gone...AND IT WORKS! Jesus. Then I try:

ifdown wlan0

just for kicks. It goes down, but the wireless LED on the lappy is still on. The I try:

ifup wlan0

to turn it back on...and nothing. Web pages will not open. I get "blah could not be found". So, to sum up, it works...sometimes. I don't know what the filthy word is going on, but I am seriously considering scrapping the whole ndiswrapper thing and trying the native ipw2100 Linux driver...go figure! Here is output from dmesg when it was working:

wlan0: ndiswrapper ethernet device xx:xx:xx:xx:xx:xx using driver w70n51.sys
wlan0: no IPv6 routers present
SFW2-IN-IPv6_PROHIB IN=wlan0 OUT= MAC=xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx SRC=fe80:0000:0000:0000:0230:65ff:fe1b:8b19 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=89 TC=0 HOPLIMIT=1 FLOWLBL=0 PROTO=UDP SPT=49486 DPT=5353 LEN=49
SFW2-IN-IPv6_PROHIB IN=wlan0 OUT= MAC=xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx SRC=fe80:0000:0000:0000:0230:65ff:fe1b:8b19 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=89 TC=0 HOPLIMIT=1 FLOWLBL=0 PROTO=UDP SPT=49490 DPT=5353 LEN=49
 
Old 12-01-2004, 08:00 PM   #12
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
No matter what I try and change using iwconfig, it does not write to that file.
Believe it or not, that is a good thing since iwconfig is only suposed to change the card configuration. It doesn't actually save those changes anywhere.

I'm not familiar with Suse, but the general procedure for configuring the card shouldn't be all that different from Slackware. If you successfully modprobe the ndiswrapper module, the next step would be to set the SSID and wEP key if you use one. Try using iwconfig to set the key first, followed by the SSID. If that doesn't work, try reversing the order. For some reason, sometimes the order you set things in can matter. You also might try setting the mode to AUTO. Again, sometimes that helps. Once you've got the card configured properly, then you can try getting an IP address with ifup, or better yet, with dhclient. If I remember correctly, ifup is just a script that requests an IP address and the uses ifconfig to bring the card up.

I think all the IPV6 errors are due to the card not associating with an access point. I wouldn't worry too much about them just yet.
 
Old 12-01-2004, 08:41 PM   #13
buldir
Member
 
Registered: Mar 2004
Location: Fairbanks, AK USA
Posts: 135

Rep: Reputation: 15
SUCCESS!

I uninstalled ndiswrapper, installed the native Linux ipw2100 driver from SourceForge, slapped the firmware into the hotplug directory, set up my wireless configuration in YaST, rebooted, and CONNECT IT DID! No errors, nothing! I am as happy as a pig in fodder! Thanks for all your suggestions and punctual replies.
 
Old 04-30-2005, 04:25 AM   #14
nilbog32
LQ Newbie
 
Registered: Jan 2004
Posts: 17

Rep: Reputation: 0
Re: solution

Quote:
Originally posted by mp3johnnyb
hi

i found a solution, having the same problem with suse 9.2:

I followed another hint found via google and did the following easy steps:
rm /lib/modules/$(uname -r)/extra/ndiswrapper.ko
cp /lib/modules/$(uname -r)/misc/ndiswrapper.ko /lib/modules/$(uname -r)/extra


First line worked, but the second line did not, because there is no misc folder. Now ndiswrapper.ko is completly gone. I have tried uninstalling and reinstalling it through YaSt but that ndiswrapper.ko file never came back.

I get the error now when running "modprobe ndiswrapper":
"FATAL: Module ndiswrappe not found."

How can I get the module back?
 
Old 04-30-2005, 07:35 AM   #15
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
You're going to have to recompile ndiswrapper. By running the rm command you deleted the file and unless you have a backup somewhere, it is gone.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ndiswrapper module not loadable quarry_06 Linux - Wireless Networking 9 08-10-2005 08:25 PM
ndiswrapper suse 9.2 module not found sarge extreme Linux - Wireless Networking 4 01-28-2005 05:37 PM
compiling a module (ndiswrapper) r.stiltskin Debian 4 10-23-2004 02:14 PM
Missing ndiswrapper module Norky Linux - Wireless Networking 0 05-08-2004 07:28 AM
need help with ndiswrapper module marzojl Linux - Wireless Networking 6 02-14-2004 02:42 PM


All times are GMT -5. The time now is 11:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration