LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-11-2007, 12:27 AM   #1
0x12d3
LQ Newbie
 
Registered: May 2007
Posts: 2

Rep: Reputation: 0
ndiswrapper shows 'driver present, hardware present' but no wlan0


I've been troubleshooting and Googling for 3 days now, but have had no success in configuring my USB wireless adapter. ndisswrapper seems to work but wlan0 (or any interface) never shows up. Any help is very graciously appreciated!

I'm running:
-Crux Linux 2.3; with kernel 2.6.20.3
-ndiswrapper 1.43

I've run out and purchased another usb wireless nic (a Dlink WUA-2340 with the same results...)

But I'm currently troubleshooting a Belkin F5D7050B

#> lsusb
Bus 1 Device 4: ID 050d:705a

(while inside driver directory of manuf. cd)
#> ndiswrapper -i rt73.inf

#> ndiswrapper -l
rt73 driver present, hardware present

#> modprobe ndiswrapper
#> ndiswrapper -m

#>ifconfig -a
lo [...]

#> iwconfig
lo no wireless extensions

Here's what /var/log/message says about it all:
Code:
May 11 05:51:25 shoes kernel: usb 1-1: Product: Belkin 54g USB Network Adapter
May 11 05:51:25 shoes kernel: usb 1-1: Manufacturer: Belkin
May 11 05:51:25 shoes kernel: usb 1-1: configuration #1 chosen from 1 choice
May 11 06:00:58 shoes kernel: ndiswrapper version 1.43 loaded (smp=no)
May 11 06:00:59 shoes kernel: usbcore: registered new interface driver ndiswrapper
ndiswrapper -l is completely clean except for the rt73 driver. No other drivers/modules are being loaded by the kernel / modprobe. Thanks again for your help.
 
Old 05-11-2007, 05:29 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
Check with 'lsmod' to make sure ndiswrapper is loaded. In that case, check dmesg for additional messages from the ndiswrapper module.
 
Old 05-11-2007, 07:43 PM   #3
0x12d3
LQ Newbie
 
Registered: May 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks Matir, I've checked lsmod and ndiswrapper is loaded and "used by 0".

dmesg | grep ndiswrapper
returns the follow (repeated a bunch of times):

usbcore: deregistering interface driver ndiswrapper
ndiswrapper version 1.43 loaded (smp=no)
usbcore: registered new interface driver ndiswrapper
ndiswrapper 1-1:1.0: usb_probe_interface
ndiswrapper 1-1:1.0: usb_probe_interface - got id

Thanks again for your help, this is the 3rd nic I'm trying and out of ideas.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
f5d7000 v5, ndiswrapper,FC4. hardware present but no wlan0 Sabrelinux Linux - Newbie 3 05-22-2006 05:31 PM
Ubuntu: driver present, hardware present, now what! Nathan1993 Linux - Wireless Networking 2 03-12-2006 06:19 PM
ndiswrapper driver and hardware present but no wlan0 OneSeventeen Linux - Laptop and Netbook 5 07-28-2005 11:03 AM
ndiswrapper-hardware present but no driver sachmo Linux - Wireless Networking 4 03-28-2005 05:06 PM
ndiswrapper - driver present:harware present but no connection esteeven Linux - Wireless Networking 2 12-26-2004 04:06 PM


All times are GMT -5. The time now is 02:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration