LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-21-2006, 06:56 PM   #1
lonelydreamer
LQ Newbie
 
Registered: Jan 2005
Posts: 3

Rep: Reputation: 0
Ndiswrapper + NetworkManager + wpa_supplicant


I've installed and setup ndiswrapper and have it working when encryption is disabled. Now trying to get NetworkManager and WPA to work, I do the following:
1) Click on the NM icon.
2) Click on my network name.
3) Fill out the screen that prompts for the password.
4) Get a line saying
Code:
NetworkManager: <WARNING> real_act_stage2_config (): Activation (wlan0/wireless): couldn't connect to the supplicant.
I think this might be a problem with my WPA_Supplicant config
Code:
ctrl_interface=/var/run/wpa_supplicant

network={
    ssid="linksys_SES_5444"
    psk="11111111"
    key_mgmt=WPA-PSK
    proto=WPA
}
I dont know very much about WPA_supplicant but I looked to see if anything was at /var/run/wpa_supplicant and there wasn't so I dont know if that could have been a problem either.
 
Old 05-26-2006, 11:47 PM   #2
calvinshields
LQ Newbie
 
Registered: May 2006
Posts: 11

Rep: Reputation: 0
wpa_supplicant: .config and make errors

I'm pretty new, so bear with me! I think this might be more of a "make" and configuration question, than it is a problem with wpa_supplicant. The wpa_supplicant README says:

Quote:
In order to be able to build wpa_supplicant, you will first need to
select which parts of it will be included. This is done by creating a
build time configuration file, .config, in the wpa_supplicant root
directory.
If you try to make without creating .config, the error message tells you to use defconfig as a template. I use ndiswrapper, so I uncommented this line in defconfig:

Code:
# Driver interface for ndiswrapper
CONFIG_DRIVER_NDISWRAPPER=y
I left everything else as a default, and then copied defconfig to a new file called .config. This felt wrong, but I couldn't tell what else to uncomment in the defconfig file. (I have my Linksys wireless router configured to use WPA, AES.) When I ran make, it seemed to be running fine, but then I got pages of errors, so here is are the beginning and end of the printed errors:

beginning:
Code:
tls_openssl.c:539: warning: implicit declaration of function ‘SSL_alert_desc_string_long’
tls_openssl.c:539: warning: format ‘%s’ expects type ‘char *’, but argument 4 has type ‘int’
tls_openssl.c:539: warning: format ‘%s’ expects type ‘char *’, but argument 5 has type ‘int’
tls_openssl.c:540: error: ‘SSL3_AL_FATAL’ undeclared (first use in this function)
tls_openssl.c:542: warning: implicit declaration of function ‘SSL_get_app_data’
tls_openssl.c:542: error: ‘SSL’ undeclared (first use in this function)
tls_openssl.c:542: error: syntax error before ‘)’ token
tls_openssl.c:544: error: dereferencing pointer to incomplete type
tls_openssl.c:546: error: dereferencing pointer to incomplete type
tail:
Code:
tls_openssl.c: In function ‘tls_connection_get_keyblock_size’:
tls_openssl.c:2129: error: syntax error before ‘*’ token
tls_openssl.c:2130: error: syntax error before ‘*’ token
tls_openssl.c:2132: error: dereferencing pointer to incomplete type
tls_openssl.c:2133: error: dereferencing pointer to incomplete type
tls_openssl.c:2134: error: dereferencing pointer to incomplete type
tls_openssl.c:2135: error: dereferencing pointer to incomplete type
tls_openssl.c:2138: error: ‘c’ undeclared (first use in this function)
tls_openssl.c:2138: error: dereferencing pointer to incomplete type
tls_openssl.c:2139: error: ‘h’ undeclared (first use in this function)
tls_openssl.c:2139: error: dereferencing pointer to incomplete type
tls_openssl.c:2141: warning: implicit declaration of function ‘EVP_CIPHER_key_length’
tls_openssl.c:2142: warning: implicit declaration of function ‘EVP_MD_size’
tls_openssl.c:2143: warning: implicit declaration of function ‘EVP_CIPHER_iv_length’
make: *** [tls_openssl.o] Error 1
Thanks!
calvinshields
 
Old 05-27-2006, 12:06 AM   #3
calvinshields
LQ Newbie
 
Registered: May 2006
Posts: 11

Rep: Reputation: 0
forgot to post

2.6.16-1.2108_fc4
 
Old 06-13-2006, 04:50 AM   #4
calvinshields
LQ Newbie
 
Registered: May 2006
Posts: 11

Rep: Reputation: 0
for i in wpa_supplicant wpa_passphrase wpa_cli; do cp $i /usr/local/sbin/$i; done

Since the last posts, I have solved some of my problems. First, I didn't have the gcc compiler. Second, there is a line in .config which I had to uncomment, because I'm running Fedora 4:

Quote:
# Some Red Hat versions seem to include kerberos header files from OpenSSL, but
# the kerberos files are not in the default include path. Following line can be
# used to fix build issues on such systems (krb5.h not found).
CFLAGS += -I/usr/include/kerberos
So now, I did a make clean, and then make, which worked. Hooray. But now, when I do make install, I get this error:

Code:
for i in wpa_supplicant wpa_passphrase wpa_cli; do cp $i /usr/local/sbin/$i; done
I have no idea what this means. Help!
 
Old 06-13-2006, 05:20 AM   #5
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,779

Rep: Reputation: 207Reputation: 207Reputation: 207
Quote:
Originally Posted by calvinshields
But now, when I do make install, I get this error:
Code:
for i in wpa_supplicant wpa_passphrase wpa_cli; do cp $i /usr/local/sbin/$i; done
That's not an error. Everything should be fine after it does this.
 
Old 06-13-2006, 07:45 AM   #6
calvinshields
LQ Newbie
 
Registered: May 2006
Posts: 11

Rep: Reputation: 0
thank you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless NIC can't Authenticate to AP using WPA; ndiswrapper/wpa_supplicant patkalolo Linux - Wireless Networking 8 07-31-2006 02:47 PM
wpa_supplicant and ndiswrapper rabidus Linux - Wireless Networking 2 10-20-2005 10:02 AM
ndiswrapper, wpa_supplicant, prism duette WORKS! esl537 Linux - Wireless Networking 3 08-28-2005 05:57 PM
ndiswrapper, driverloader, wpa_supplicant, libranet (debian), smc2835W esl537 Linux - Wireless Networking 1 08-27-2005 05:17 PM
wpa_supplicant/ndiswrapper seifenblasen Linux - Laptop and Netbook 3 03-24-2005 12:40 PM


All times are GMT -5. The time now is 03:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration