LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 04-05-2008, 02:50 PM   #1
tardebut
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Rep: Reputation: 0
ndiswrapper in Fedora 8


Hello there!

I'm eternally new to Linux.
I'm running Fedora 8 in Dell XPS M1513 with a Broadcom BCM4312 wireless network controller. In order to have it running I have tried b43 drivers and also ndiswrapper. I haven't been successful enough so far despite trying for several days with lots of googling. I'm now struggling with ndiswrapper. The WIFi led in the computer is on. When I try to connect

Quote:
[root@localhost network-scripts]# ifup wlan0

Determining IP information for wlan0... failed; no link present. Check cable?
The output I got with the usually recommended commands is:

This is my controller:

Quote:
[root@localhost network-scripts]# lspci -v
...
0b:00.0 Network controller: Broadcom Corporation BCM4312 802.11a/b/g (rev 01)
Subsystem: Dell Unknown device 0007
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at f9efc000 (32-bit, non-prefetchable) [size=16K]
Capabilities: [40] Power Management version 2
Capabilities: [58] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
Capabilities: [d0] Express Legacy Endpoint, MSI 00
Kernel driver in use: ndiswrapper
Kernel modules: ssb

It seems that ndiswrapper and the driver are properly installed:

Quote:
[root@localhost Omar]# ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4312) present (alternate driver: ssb)
and the relevant content of modprobe.conf in /etc is:

Quote:
alias wlan0 ndiswrapper
options ndiswrapper if_name=wlan0
My wireless network ODINGA is being detected:

Quote:
[root@localhost Omar]# iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:1E:2A:6E:39:B0
ESSID:"ODINGA"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:100/100 Signal level:-15 dBm Noise level:-96 dBm
Encryption key: on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK

But the configuration of wlan0 seems not to be adequate, despite setting the ESSID to ODINGA using the Network Configuration tool in System>Administration:

Quote:
[root@localhost Omar]# iwconfig
lo no wireless extensions.

wlan0 IEEE 802.11g ESSID: off/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:32 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key: off
Power Management: off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth1 no wireless extensions.

virbr0 no wireless extensions.
By the way, the content of the file ifcfg-wlan0 in /etc/sysconfig/network-scripts/ is:

Quote:
# Broadcom Corporation BCM4312 802.11a/b/g
DEVICE=wlan0
BOOTPROTO=dhcp
ONBOOT=no
HWADDR=00:1f:3a:12:d4:d0
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
TYPE=Wireless
USERCTL=yes
PEERDNS=yes
IPV6INIT=yes
NM_CONTROLLED=yes
ESSID=ODINGA
CHANNEL=6
MODE=Managed
RATE='54 Mb/s'
and the relevant logs are:

Quote:
[root@localhost /]# dmesg | grep wlan0
wlan0: ethernet device 00:1f:3a:12:d4:d0 using NDIS driver: bcmwl5, version: 0x4281300, NDIS version: 0x501, vendor: 'NDIS Network Adapter', 14E4:4312.5.conf
wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
ADDRCONF(NETDEV_UP): wlan0: link is not ready
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
ADDRCONF(NETDEV_UP): wlan0: link is not ready
ADDRCONF(NETDEV_UP): wlan0: link is not ready
and:

Quote:
[root@localhost /]# dmesg | grep ndiswrapper
ndiswrapper version 1.52 loaded (smp=yes, preempt=no)
ndiswrapper (link_pe_images:576): fixing KI_USER_SHARED_DATA address in the driver
ndiswrapper: driver bcmwl5 (Broadcom,03/23/2006, 4.40.19.0) loaded
ndiswrapper: using IRQ 17
usbcore: registered new interface driver ndiswrapper
ndiswrapper (iw_set_bitrate:442): setting bit rate failed (C00000BB)
ndiswrapper (iw_set_bitrate:442): setting bit rate failed (C00000BB)
ndiswrapper (iw_set_bitrate:442): setting bit rate failed (C00000BB)
Maybe it helps to know that as I had tried b43 driver with f-cutter I have blacklisted:

Quote:
blacklist bcm43xx_mac80211
What could be the problem?
I look forward for help.
Thanks in advance.
 
Old 04-06-2008, 04:11 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Blacklist the ssb, b43, b43legacy, mac80211, bcm43xx as well. List loaded modules to see if anything is strange. Also I would disable any security on the router and just make a plain non encrypted connection. Once you get that then turn on and get that working.

Brian
 
Old 04-06-2008, 05:28 PM   #3
tardebut
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks Brian. OK, I have now blacklisted ssb, b43, b43legacy, mac80211, bcm43xx as well. Here you have the loaded modules:

Quote:
[HTML][root@localhost network-scripts]# lsmod
Module Size Used by
ipt_MASQUERADE 11457 1
iptable_nat 14661 1
nf_nat 25581 2 ipt_MASQUERADE,iptable_nat
bridge 59241 0
rfcomm 43105 0
l2cap 28865 9 rfcomm
autofs4 28361 2
fuse 50289 5
sunrpc 176969 3
nf_conntrack_ipv4 17353 5 iptable_nat
ipt_REJECT 12353 4
iptable_filter 11073 1
ip_tables 25897 2 iptable_nat,iptable_filter
nf_conntrack_ipv6 23057 2
xt_state 10689 5
nf_conntrack 65201 6 ipt_MASQUERADE,iptable_nat,nf_nat,nf_conntrack_ipv4,nf_conntrack_ipv6,xt_state
xt_tcpudp 11713 12
ip6t_ipv6header 10817 2
ip6t_REJECT 12993 2
ip6table_filter 10945 1
ip6_tables 21129 2 ip6t_ipv6header,ip6table_filter
x_tables 23241 9 ipt_MASQUERADE,iptable_nat,ipt_REJECT,ip_tables,xt_state,xt_tcpudp,ip6t_ipv6header,ip6t_REJECT,ip6_t ables
ib_iser 38073 0
rdma_cm 33461 1 ib_iser
ib_cm 35816 1 rdma_cm
iw_cm 16841 1 rdma_cm
ib_sa 27297 2 rdma_cm,ib_cm
ib_mad 41189 2 ib_cm,ib_sa
ib_core 55617 6 ib_iser,rdma_cm,ib_cm,iw_cm,ib_sa,ib_mad
ib_addr 14665 1 rdma_cm
iscsi_tcp 29505 0
libiscsi 29377 2 ib_iser,iscsi_tcp
scsi_transport_iscsi 36689 4 ib_iser,iscsi_tcp,libiscsi
cpufreq_ondemand 15697 1
acpi_cpufreq 17105 2
loop 22853 0
dm_multipath 24785 0
ipv6 273417 16 nf_conntrack_ipv6,ip6t_REJECT
kvm_intel 29677 0
kvm 88609 1 kvm_intel
snd_hda_intel 391145 5
snd_seq_dummy 11589 0
snd_seq_oss 38721 0
snd_seq_midi_event 15041 1 snd_seq_oss
snd_seq 60769 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 15445 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 52545 0
snd_mixer_oss 23233 1 snd_pcm_oss
snd_pcm 87241 3 snd_hda_intel,snd_pcm_oss
snd_timer 28873 2 snd_seq,snd_pcm
video 27093 0
snd_page_alloc 16721 2 snd_hda_intel,snd_pcm
uvcvideo 56773 0
snd_hwdep 16457 1 snd_hda_intel
output 11713 1 video
hci_usb 22877 2
i2c_i801 16861 0
firewire_ohci 28101 0
snd 65129 19 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd _timer,snd_hwdep
compat_ioctl32 16321 1 uvcvideo
sdhci 24133 0
bluetooth 60132 7 rfcomm,l2cap,hci_usb
firewire_core 46665 1 firewire_ohci
i2c_core 27969 1 i2c_i801
mmc_core 55113 1 sdhci
iTCO_wdt 20113 0
videodev 33601 1 uvcvideo
ricoh_mmc 11841 0
soundcore 15073 1 snd
crc_itu_t 10433 1 firewire_core
serio_raw 14277 0
pcspkr 11201 0
v4l1_compat 19653 2 uvcvideo,videodev
dcdbas 16113 0
sky2 51909 0
ac 13257 0
sr_mod 23653 0
battery 19017 0
cdrom 40425 1 sr_mod
iTCO_vendor_support 11845 1 iTCO_wdt
v4l2_common 25921 3 uvcvideo,compat_ioctl32,videodev
button 15969 0
sg 40281 0
joydev 18881 0
ndiswrapper 221184 0
ata_piix 26181 0
dm_snapshot 22921 0
dm_zero 10305 0
dm_mirror 26945 0
dm_mod 60473 9 dm_multipath,dm_snapshot,dm_zero,dm_mirror
ahci 33989 4
libata 144241 2 ata_piix,ahci
sd_mod 33217 5
scsi_mod 150009 8 ib_iser,iscsi_tcp,libiscsi,scsi_transport_iscsi,sr_mod,sg,libata,sd_mod
ext3 128209 2
jbd 52073 1 ext3
mbcache 15809 1 ext3
uhci_hcd 30561 0
ohci_hcd 28997 0
ehci_hcd 39501 0 [/HTML]
Do you see something strange?

On the other hand, unless it were strictly required I prefer to keep my connection encrypted.

I look forward to hear from you.
Thanks in advance.
 
Old 04-06-2008, 05:51 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
I just want to eliminate the module setup as the issue not working versus just the encryption setup not working. I just perfer to keep the connection simply as possible to begin with. From the looks using Network_Manager so can't help there. Never liked it.

But now what does ' ndiswrapper -l ' say?

Then as root issue the following commands.
/sbin/ifdown eth0
/sbin/ifdown wlan0
/sbin/ifup wlan0

Does it get an IP?

Brian
 
Old 04-06-2008, 06:17 PM   #5
tardebut
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Brian, here you have:

Quote:
[root@localhost /]# ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4312) present (alternate driver: ssb)
Then, after ifdown eth1 and ifdown wlan0, I got:

Quote:
[root@localhost /]# ifup wlan0

Determining IP information for wlan0... failed; no link present. Check cable?
I understand that by removing the encryption we make things easier, but the fact that a iwconfig shows (see first post) that not even the ESSID is the one that should be according to the settings suggest that there is at least one encryption-independent problem.

What do you think?
Thanks in advance.
 
Old 04-06-2008, 06:41 PM   #6
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
I would say issue with the NetworkManager setup. I would do this for testing and to do this set the router to no security.

Edit ifcfg-wlan0 to this.
Code:
# Broadcom Corporation BCM4312 802.11a/b/g
DEVICE=wlan0
BOOTPROTO=dhcp
ONBOOT=no
# HWADDR=00:1f:3a:12:d4:d0
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
TYPE=Wireless
USERCTL=yes
PEERDNS=yes
IPV6INIT=yes
# NM_CONTROLLED=yes
ESSID=ODINGA
# CHANNEL=6
MODE=Managed
# RATE='54 Mb/s'
Not knowing if there is a wired nic but if so and is eth0 then edit ifcfg-eth0 and put a # infront of NM_CONTROLLED and set ONBOOT=no

Now run the following commands as root
/sbin/service NetworkManager stop
/sbin/chkconfig --level 2345 NetworkManager off
/sbin/service network restart
/sbin/ifup wlan0

Did it connect to your access point
If not post
/sbin/iwconfig
/sbin/ifconfig -a
/sbin/iwlist wlan0 scan
ndiswrapper -l
cat /etc/modprobe.conf

Also try rebooting if something else has gotten in there. On reboot it will not start networkManager service because of the chkconfig command and neither wired or wireless will start on boot. Once up as root issue as root.
/sbin/ifup wlan0

Brian
 
Old 04-06-2008, 11:55 PM   #7
tardebut
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Brian! Thanks, I've wireless connection now but it is unencrypted. Let me tell you, for the record, what I did. First, I did everything you suggested me in your last reply except removing the encryption. I made no progress at all. Just when I remove the encryption, I got connection. I don't know if the changes plus removing the encryption made the trick or it was just a matter of removing the encryption.
Now, what can I do to have the encryption back and keep the wireless connectivity? Whenever I go encrypted I loss the connection.
What to do?
Thanks in advance.
 
Old 04-07-2008, 07:29 PM   #8
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
This is the way I do it for wpa. If wpa2 then just a line code of change.
Run this command to generate the encrypted passphrase. Be sure to make sure if anything is capital that you do it exactly the same for ESSID and passphrase. Both are case sensitive.
Code:
/usr/sbin/wpa_passphrase YOUR_AP_SSID “YOUR_WPA_PSK_PASSPHRASE”

Example:
/usr/sbin/wpa_passphrase NETGEAR “linuxisgreat”
Now take that piece of generate code and place in /etc/wpa_supplicant/wpa_supplicant.conf file.
Here is and example of mine as wpa
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
# update_config=1

network={
        ssid="NETGEAR"
        #psk="linuxisgreat"
        psk=6890cc1ba4d9742b1cac7e6b8a100532c34035798defb93048f2b9121cba5b61
        proto=WPA
}

# WPA for WPA
# RSN for WPA2
Change proto to RSN if using WPA2.
Change router back to encryption mode.
Issue this command to test. It should say connection establish after several lines of info going by.
Code:
   /usr/sbin/wpa_supplicant -dd -Dwext -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
Then /sbin/ifup wlan0. It may have to run before the above line. Been a while dealing with DHCP. Normally use defined static IPs.

To automate on start then do the following. Be sure the command is on a single line. May have to turn off line wrap for editor you are using.
Place this line at the end of /etc/sysconfig/network-scripts/ifup-wireless.
Code:
   /usr/sbin/wpa_supplicant -dd -Dwext -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
Now edit your ifcfg-wlan0 and change ONBOOT=yes.
As root issue the command /sbin/service network restart

Brian

Last edited by Brian1; 04-07-2008 at 07:31 PM.
 
Old 04-08-2008, 07:52 AM   #9
tardebut
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Brian, I'm stuck at:

Code:
   /usr/sbin/wpa_supplicant -dd -Dwext -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
It took so long that I stopped at some point just to realize that after "ifup wlan0" I got no connection at all. The story is longer and goes through having killed a wpa_supplicant process ($ kill -KILL wpa_supplicant) in order to manually delete the file wlan0 at /var/run/wpa_supplicant, something that was suggested by the lines that followed a second try of the code above just to have nothing at the end.

Now, I'm trying the command above again, after bringing back wlan0 to /var/run/wpa_supplicant and rebooting. I see no wpa_supplicant process running ($ ps). As you may have realized I know nothing about what I'm doing. I'm just following your suggestions, and reading the lines that pop up after the command above, etc. I'm lost, as simple as that.
On the other hand, I don't follow you when you said: "Then /sbin/ifup wlan0. It may have to run before the above line. Been a while dealing with DHCP. Normally use defined static IPs." It is clear that I should ifup wlan0, just as I did but what do you mean by "It may have to run before the above line. Been a while dealing with DHCP. Normally use defined static IPs."?

I look forward to hear from you.

Omar
 
Old 04-08-2008, 05:23 PM   #10
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Get back to you later tonight or tomorrow.

I normally use static IP so the network nic is up before I start wpa_supplicant. Not sure how to handle this for dhcp but would think the way I done this would work. You may have to define a static IP for the moment till I can google for DHCP and WPA setup under Redhat or Fedora.

Brian
 
Old 04-08-2008, 10:32 PM   #11
tardebut
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks Brian.
I have the wireless connection back at the expense of non-encryption.
What IP should I enter, the router IP?
I have found this:

http://linux.derkeiler.com/Mailing-L.../msg02438.html

I will be trying to follow it but I look forward to hear from you.
Thanks.
Omar
 
Old 04-13-2008, 10:33 AM   #12
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Been out of town working. Have you had any success?

Brian
 
Old 04-27-2008, 10:45 AM   #13
tardebut
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Coming back

Brian, I have been also out. Having a wireless connection, even if non-encrypted, turned me into the main course. I don't know exactly how much am I risking by doing this. I'm now taking a look at http://www-users.york.ac.uk/~mdc1/fedora_wireless.html and I see some new lines to be included in wpa_supplicant.conf and /etc/sysconfig/wpa_supplicant but I don't know yet if this is going to solve the problem. Have you found a solution? In any case I really appreciate your help. It has allowed me to have this wireless fired up and ready to go.

Regards,

Omar
 
  


Reply

Tags
broadcom, dell, fedora, wireless, xps


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ndiswrapper, ndiswrapper-utils, and Fedora Core 6 alkaholic Linux - Wireless Networking 1 02-03-2007 08:46 PM
Ndiswrapper, fedora fc6 THOR_Fedora Linux - Wireless Networking 3 10-28-2006 11:16 AM
ndiswrapper on fedora 5 Koop Linux - Software 10 08-02-2006 06:42 PM
Fedora 5 and NdisWrapper njager Fedora 7 04-09-2006 12:56 AM
ndiswrapper - fedora - 2.6.1-53 - help r0x Linux - Wireless Networking 0 01-25-2004 08:28 AM


All times are GMT -5. The time now is 07:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration