LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 09-09-2006, 07:05 AM   #1
psy_toon
LQ Newbie
 
Registered: Sep 2006
Posts: 7

Rep: Reputation: 0
Ndiswrapper/Fedora Core 5/Speedtouch 121g problem


Hi,

My first post on here and i will admit to being a newbie as far as linux goes.

I have followed the guide on these forums on how to get ndiswrapper working in Fedora Core 5, (can't post url as i need to make 3 posts first) but keep hitting the same problem.

Everything seems to go smoothly until i get to
Code:
ifconfig wlan0 up
Upon entering this command all I get is the output "wlan0: unknown interface: No such device"

I am now completely stuck as to what to do at this point and am in need of some help.

Thanks in advance,

Psy
 
Old 09-09-2006, 02:00 PM   #2
con
Member
 
Registered: Jul 2005
Location: Finland
Distribution: Slackware
Posts: 213

Rep: Reputation: 30
post the output of the following commands
ndiswrapper -l
iwconfig
lspci
dmesg|tail #after you have modprobe'd ndiswrapper

Is the card an integrated laptop card, usb nic, pcmcia or what-other-choices-are-there
 
Old 09-09-2006, 03:52 PM   #3
psy_toon
LQ Newbie
 
Registered: Sep 2006
Posts: 7

Original Poster
Rep: Reputation: 0
It's a USB adaptor and output (if memory serves correctly) of ndiswrapper -l is "bt4501g driver installed, hardware present"

Not sure of rest as at work at the moment, will post results up as soon as I get home.
 
Old 09-09-2006, 05:46 PM   #4
psy_toon
LQ Newbie
 
Registered: Sep 2006
Posts: 7

Original Poster
Rep: Reputation: 0
output is as follows:

Code:
[root@localhost ~]# ndiswrapper -l
Installed drivers:
bt4501g         driver installed, hardware present
[root@localhost ~]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

[root@localhost ~]# lspci
00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev a2)
00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev a2)
00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev a2)
00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev a2)
00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev a2)
00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev a2)
00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a3)
00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a3)
00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3)
00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev a2)
02:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX - nForce GPU] (rev a3)
[root@localhost ~]# dmesg|tail
Bluetooth: Core ver 2.8
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.8
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.7
Bluetooth: HIDP (Human Interface Emulation) ver 1.1
 
Old 09-09-2006, 07:48 PM   #5
psy_toon
LQ Newbie
 
Registered: Sep 2006
Posts: 7

Original Poster
Rep: Reputation: 0
also get this when i check dmesg

Code:
ndiswrapper version 1.23 loaded (preempt=no,smp=no)
usb 3-3: reset high speed USB device using ehci_hcd and address 2
ndiswrapper: driver bt4501g (THOMSON,08/23/2004, 3.0.19.2) loaded
ndiswrapper (NdisWriteErrorLogEntry:239): log: C000138A, count: 3, return_address: deb401ef
ndiswrapper (NdisWriteErrorLogEntry:242): code: 3221225473
ndiswrapper (NdisWriteErrorLogEntry:242): code: 1835619394
ndiswrapper (NdisWriteErrorLogEntry:242): code: 55
ndiswrapper (miniport_init:264): couldn't initialize device: C0010006
ndiswrapper (pnp_start_device:428): Windows driver couldn't initialize the device (C0000001)
ndiswrapper (miniport_halt:327): device c3c8c2c0 is not initialized - not halting
ndiswrapper: device eth%d removed
unregister_netdevice: device eth%d/c3c8c000 never was registered
ndiswrapper: probe of 3-3:1.0 failed with error -22
usbcore: registered new driver ndiswrapper
eth0: no IPv6 routers present
 
Old 09-10-2006, 09:11 AM   #6
con
Member
 
Registered: Jul 2005
Location: Finland
Distribution: Slackware
Posts: 213

Rep: Reputation: 30
Think you need to try another driver...have you checked the ndiwrapper compability list?
 
Old 09-10-2006, 10:52 AM   #7
psy_toon
LQ Newbie
 
Registered: Sep 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Yeah, and I've got the driver it suggests and have also tried the driver from original installation cd (which is a newer version than the downloadable one).

I've disabled 4K stack limit, have also reinstalled Fedora a couple of times.
 
Old 09-10-2006, 11:37 AM   #8
con
Member
 
Registered: Jul 2005
Location: Finland
Distribution: Slackware
Posts: 213

Rep: Reputation: 30
when you installed the driver with ndiswrapper -e(?cant remember) where you in the same directory as the *.sys file?
 
Old 09-10-2006, 06:02 PM   #9
psy_toon
LQ Newbie
 
Registered: Sep 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Have uninstalled ndiswrapper and started from fresh, this is a full list of what happens.

Code:
[root@localhost ~]# cd Ndiswrapper
[root@localhost Ndiswrapper]# cd ndiswrapper-1.23
[root@localhost ndiswrapper-1.23]# make distclean
make -C driver clean
make[1]: Entering directory `/root/Ndiswrapper/ndiswrapper-1.23/driver'
rm -rf ndiswrapper.ko ndiswrapper.o hal.o iw_ndis.o loader.o misc_funcs.o ndis.o ntoskernel.o ntoskernel_io.o pe_linker.o pnp.o proc.o wrapmem.o wrapndis.o wrapper.o usb.o divdi3.o usb.o win2lin_stubs.o \
   divdi3.o workqueue.o .*.ko.cmd .*.o.cmd \
   ndiswrapper.mod.[oc] *~ .tmp_versions Modules.symvers Module.symvers
make[1]: Leaving directory `/root/Ndiswrapper/ndiswrapper-1.23/driver'
make -C utils clean
make[1]: Entering directory `/root/Ndiswrapper/ndiswrapper-1.23/utils'
rm -f *~ *.o loadndisdriver
make[1]: Leaving directory `/root/Ndiswrapper/ndiswrapper-1.23/utils'
rm -f *~
rm -fr ndiswrapper-1.23 ndiswrapper-1.23.tar.gz patch-stamp
make -C driver distclean
make[1]: Entering directory `/root/Ndiswrapper/ndiswrapper-1.23/driver'
rm -rf ndiswrapper.ko ndiswrapper.o hal.o iw_ndis.o loader.o misc_funcs.o ndis.o ntoskernel.o ntoskernel_io.o pe_linker.o pnp.o proc.o wrapmem.o wrapndis.o wrapper.o usb.o divdi3.o usb.o win2lin_stubs.o \
   divdi3.o workqueue.o .*.ko.cmd .*.o.cmd \
   ndiswrapper.mod.[oc] *~ .tmp_versions Modules.symvers Module.symvers
rm -f *_exports.h .\#* win2lin_stubs.h
make[1]: Leaving directory `/root/Ndiswrapper/ndiswrapper-1.23/driver'
make -C utils distclean
make[1]: Entering directory `/root/Ndiswrapper/ndiswrapper-1.23/utils'
rm -f *~ *.o loadndisdriver
rm -f .\#*
make[1]: Leaving directory `/root/Ndiswrapper/ndiswrapper-1.23/utils'
rm -f .\#*
[root@localhost ndiswrapper-1.23]# make install KSRC=/usr/src/kernels/2.6.17-1.2174_FC5.stk16-smp-i686
make -C driver install
make[1]: Entering directory `/root/Ndiswrapper/ndiswrapper-1.23/driver'
make -C /lib/modules/2.6.17-1.2174_FC5.stk16smp/build SUBDIRS=/root/Ndiswrapper/ndiswrapper-1.23/driver
make[2]: Entering directory `/usr/src/kernels/2.6.17-1.2174_FC5.stk16-smp-i686'
  Building modules, stage 2.
  MODPOST
make[2]: Leaving directory `/usr/src/kernels/2.6.17-1.2174_FC5.stk16-smp-i686'
echo /lib/modules/2.6.17-1.2174_FC5.stk16smp/misc
/lib/modules/2.6.17-1.2174_FC5.stk16smp/misc
mkdir -p /lib/modules/2.6.17-1.2174_FC5.stk16smp/misc
install -m 0644 ndiswrapper.ko /lib/modules/2.6.17-1.2174_FC5.stk16smp/misc
/sbin/depmod -a 2.6.17-1.2174_FC5.stk16smp -b /
make[1]: Leaving directory `/root/Ndiswrapper/ndiswrapper-1.23/driver'
make -C utils install
make[1]: Entering directory `/root/Ndiswrapper/ndiswrapper-1.23/utils'
install -D -m 755 loadndisdriver /sbin/loadndisdriver
install -D -m 755 ndiswrapper /usr/sbin/ndiswrapper
install -D -m 755 ndiswrapper-buginfo /usr/sbin/ndiswrapper-buginfo

NOTE: Windows driver configuration file format has changed since 1.5. You must re-install Windows drivers if they were installed before.
make[1]: Leaving directory `/root/Ndiswrapper/ndiswrapper-1.23/utils'
mkdir -p -m 0755 /usr/share/man/man8
install -m 644 ndiswrapper.8 /usr/share/man/man8
[root@localhost ndiswrapper-1.23]# ndiswrapper -m
modprobe config already contains alias directive

[root@localhost ndiswrapper-1.23]# cd
[root@localhost ~]# cd Driver
[root@localhost Driver]# dir
BT4501G1.sys  BT4501G.inf  Driver.2K  Driver.ME
BT4501G.cat   BT4501G.sys  Driver.98
[root@localhost Driver]# ndiswrapper -i BT4501G.inf
Installing bt4501g
[root@localhost Driver]# ndiswrapper -l
Installed drivers:
bt4501g         driver installed, hardware present
[root@localhost Driver]# depmod -a
[root@localhost Driver]# modprobe ndiswrapper
[root@localhost Driver]# ifconfig eth0 down
[root@localhost Driver]# ifconfig wlan0 up
wlan0: unknown interface: No such device
 
Old 09-11-2006, 10:49 AM   #10
con
Member
 
Registered: Jul 2005
Location: Finland
Distribution: Slackware
Posts: 213

Rep: Reputation: 30
I dont know what to say...try the ndiswrapper forums or maybe someone else here has a clue...cant belive i misspelled were
 
Old 09-11-2006, 03:53 PM   #11
psy_toon
LQ Newbie
 
Registered: Sep 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Heh, no problem, will post over there. If anyone has any clue on this please let me know, thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Speedtouch Modem in Fedora Core 5 thraldur Fedora 4 04-19-2006 03:48 PM
speedtouch usb modem in fedora core 3 alikote Fedora 2 01-05-2006 12:38 PM
ndiswrapper problem on Fedora Core 4 c_mcgeecc Linux - Wireless Networking 5 08-27-2005 09:22 AM
Netgear WG311 and Fedora Core 2 problem, and ndiswrapper = confusion emiphiste Linux - Wireless Networking 2 08-18-2005 05:23 PM
ndiswrapper routing problem under fedora core 2? rpdillon Linux - Wireless Networking 2 06-01-2004 06:26 PM


All times are GMT -5. The time now is 09:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration