LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Ndiswrapper compile failed (http://www.linuxquestions.org/questions/linux-wireless-networking-41/ndiswrapper-compile-failed-458581/)

matazar42 06-26-2006 07:03 PM

Ndiswrapper compile failed
 
Hey guys,
I've done some web searching and messing around and still get this not-so-descriptive error when compiling ndiswrapper-1.17.

make spitts out this

In file included from include/asm/thread_info.h:16,
from include/linux/thread_info.h:21,
from include/linux/spinlock.h:12,
from include/linux/capability.h:45,
from include/linux/sched.h:7,
from include/linux/module.h:10,
from /home/matthew/ndiswrapper-1.17/driver/hal.c:17:
include/asm/processor.h:87: error: array type has incomplete element type
In file included from include/asm/mpspec.h:5,
from include/asm/smp.h:18,
from include/linux/smp.h:17,
from include/linux/sched.h:23,
from include/linux/module.h:10,
from /home/matthew/ndiswrapper-1.17/driver/hal.c:17:
include/asm/mpspec_def.h:78: warning: 'packed' attribute ignored for field of type 'unsigned char[5u]'
In file included from include/linux/netdevice.h:151,
from /home/matthew/ndiswrapper-1.17/driver/hal.c:18:
include/linux/skbuff.h: In function 'skb_add_data':
include/linux/skbuff.h:1018: warning: pointer targets in passing argument 2 of 'csum_and_copy_from_user' differ in signedness
make[3]: *** [/home/matthew/ndiswrapper-1.17/driver/hal.o] Error 1
make[2]: *** [_module_/home/matthew/ndiswrapper-1.17/driver] Error 2
make[1]: *** [default] Error 2
make: *** [all] Error 2



Can anyone make sense of that?
I'm running slackware 10 on a very old IBM thinkpad 600.
I compiled as root becuse as a user I ran into some Permission Denied error.

Help is appreciated.

Thanks

-Matt

Brian1 06-26-2006 07:55 PM

Is this Redhat 9 distro as in your ID tag?
If so which kernel?
Do you have the kernel source installed if custom kernel or the kernel-devel if using precompile rpm kernels?

Check on ndiswrapper with possiable issues with 2.4 kernels and latest version.

Brian1

matazar42 06-26-2006 09:01 PM

Sorry, This is a different machine than the one in my profile.

I am using Slackware and just installed a 2.6.8 kernel because it was one of the prerequisites.
I have all the sources in /usr/src/linux-2.6.8 and a link to that directory in /lib/modules/2.6.8

I'm not sure what this error is even trying to tell me.
Can it not find some header file skbuff.h?

thanks

matazar42 06-26-2006 09:14 PM

Hmm, you know now that I'm thinking about it, this might be a problem with gcc.
I just upgraded to gcc-4.1.1 as it was another prerequisite. And this is the first thing I have tried to compile with it. Maybe I should try compiling something else and see if I get a similar error.

matazar42 06-26-2006 10:03 PM

Ok, I just succesfully compiled nano, this little command line text editor. The build went fine. That dosn't mean that it's not a compiler issue though. There may still be some library out of place. I don't know. I don't even know what the error is.

Hangdog42 06-27-2006 07:11 AM

The latest versions of ndiswrapper require a newer gcc than is in Slackware 10.2. The easiest way around this is to use an older ndiswrapper (I think 1.15 or older). I'm not sure if Slackware current has a newer version of gcc or not (you can check a mirror), but if it does, you could upgrade to -current. Personally, I would try an older ndiswrapper first as I don't really like running boxes off of -current.

matazar42 06-27-2006 12:35 PM

What is "-current"?
I already upgraded to gcc-4.1.1 It seems to work well as far as I can tell.
Do you recognize or even understand the error?

Hangdog42 06-27-2006 01:46 PM

Quote:

What is "-current"?
Slackware has two branches. The numbered branches (like 10.2) are very stable and the packages are usually only updated for bug fixes and security patches. On the other hand, the current branch is the testing ground for the next release of Slackware. It has the latest and greatest, but because of that, it is also frequently changing and sometimes those changes break your install unless you're paying attention to the changelogs.

One of the problems with upgrading gcc is that stuff compiled with newer versions of gcc aren't always compatible with stuff compiled with older gcc versions. I know you said nano compilied cleanly, but nano doesn't have any kernel dependencies like ndiswrapper does. In your first post, you say you're on Slackware 10. Is that 10 or 10.x? If you are still on 10, then I would believe that upgrading just gcc is causing all sorts of problems.

The errors you've got look like broken code, but I haven't seen any reports that ndiswrapper 1.17 is that broken. If this were generally happening, there would be a lot more fuss going on. That leads me to suspect that upgrading gcc to 4.1.1, while running on a machine largely compiled with earlier versions, is leading to trouble. If I were in your shoes, I'd roll back the gcc upgrade and try an earlier ndiswrapper version. Either that or update your entire box to be on the current branch, including the kernel.


All times are GMT -5. The time now is 12:19 PM.