LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 10-26-2004, 04:43 AM   #1
Delusions
LQ Newbie
 
Registered: Oct 2004
Location: Tampa, FL
Distribution: Slack 10.2
Posts: 26

Rep: Reputation: 16
Ndiswrapper .11 and Suse 9.1 Help needed


Ok i reinstalled suse so I started from scratch now I update the kernal to 2.6.5-7.108 after i installed.

Now I made ndiswrapper 11. (Happy Happy Joy Joy)

I did the ndiswrapper -i WUSB54G.inf woot it loaded and hardware is present (like before)

Now When I did the modprobe here is the error message i recived

NDISWARPPER Unsupported Module (Tainting Kernal)
NDISWRAPPER v .8 Loaded
NDISWRAPPER loadndiswrapper Failed (256)

Can anyone tell me what I did wrong here
 
Old 10-26-2004, 05:13 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Check with dmesg and take a look also at /var/log/syslog to find out what is the problem
 
Old 10-26-2004, 05:41 AM   #3
Delusions
LQ Newbie
 
Registered: Oct 2004
Location: Tampa, FL
Distribution: Slack 10.2
Posts: 26

Original Poster
Rep: Reputation: 16
Those are the message I got with dmesg
 
Old 10-26-2004, 05:50 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Quote:
NDISWRAPPER v .8 Loaded
That should be version .11 according to you post. So I guess there is an old ndiswrapper module installed during Suse installation which is not compiled for your new kernel.
 
Old 10-26-2004, 05:55 AM   #5
Delusions
LQ Newbie
 
Registered: Oct 2004
Location: Tampa, FL
Distribution: Slack 10.2
Posts: 26

Original Poster
Rep: Reputation: 16
The Suse defualt is .6 I have no clue where its pulling the .8 from the only thing i can think of is that the .8 is included in the new kernal. I think I am gonna drop to linux and poke around in the moudles.dep and see if i can find anymore refs to ndiswrapper.

Last edited by Delusions; 10-26-2004 at 05:58 AM.
 
Old 10-26-2004, 09:29 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Actually, the safest thing to do is uninstall ndiswrapper and have another run at instaling .11. There is a guide to uninstalling ndiswrapper at the ndiswrapper wiki.
 
Old 11-18-2004, 01:59 PM   #7
lberger
LQ Newbie
 
Registered: Nov 2004
Location: Munich, Germany
Distribution: suse pro 9.1
Posts: 6

Rep: Reputation: 0
I exactly got the same problem. 2 times I have reinstalled Linux.
There is a Installation guide at http://sourceforge.net/projects/ndiswrapper
and in Prerequsites written

"You need a recent kernel (at least 2.6.6 or 2.4.26)". Does that mean, that I have to install kernel 2.6.6 and than it will work?
But I found kernel 2.6.9 to install, but I'm afraid, then Suse may not work probably!

so I may try to uninstall ndiswrapper 0.11 and install ndiswrapper 0.8., or can I take the risk to install the most recent Kernel?
 
Old 11-18-2004, 02:49 PM   #8
lberger
LQ Newbie
 
Registered: Nov 2004
Location: Munich, Germany
Distribution: suse pro 9.1
Posts: 6

Rep: Reputation: 0
Exactly: I have uninstalled ndiswrapper 0.11 and installed ndiswrapper 0.8 instead. Now I got the diod on the card blinking.

Best regards and success!

Greetings

Lutz
 
Old 12-04-2004, 01:33 PM   #9
pete.piano
LQ Newbie
 
Registered: Dec 2004
Posts: 3

Rep: Reputation: 0
I thought the wusb54g was only supported in recent ndiswrappers ?

I get the problem that ndiswrapper says the driver and hardware are OK, but
get a message saying that the windows driver couldn't intialise the device.

Tried ndiswrapper 11 and 12.

Also tried drivers from orig disk, and the v1 and v2 drivers from the Linksys website.

Does anyone have a combination known to work for sure ?

I'm running 2.6.9 kernel on suse 9.1/

Any thoughts appreciated. :-)

Pete
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NDISWrapper + Suse 9.2 Agizor Suse/Novell 16 03-17-2006 01:11 AM
Finding the kernel headers needed for Ndiswrapper? gandhi Debian 2 03-19-2005 09:02 PM
Suse 9.1 and ndiswrapper keith2045 Linux - Wireless Networking 5 02-21-2005 12:29 PM
Does SuSE 9.2 contain ndiswrapper? JWHolloway Linux - Software 4 12-17-2004 10:44 AM
ndiswrapper help needed? extremebfn Linux - Wireless Networking 0 06-25-2004 04:00 AM


All times are GMT -5. The time now is 06:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration