LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 07-14-2008, 06:53 PM   #1
david7333
LQ Newbie
 
Registered: Jul 2008
Posts: 3

Rep: Reputation: 0
My wlan0 switch automaticaly to another ESSID


Hi everybody,

I have some troubles with my ralink wireless interface.

Just after the startup, everything works fine. But randomly, the ESSID switch for an other one.

/etc/network/interfaces :

# /etc/network/interfaces
auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
wireless-essid BTHomeHub-1234
wireless-mode managed
wireless-key 0123456789



iwconfig wlan0 output after startup:

wlan0 RT61 Wireless ESSID:"BTHomeHub-1234"
Mode:Managed Frequency:2.462 GHz Access Point: 00:18:F6:95:7E:9D
Bit Rate=54 Mb/s
RTS thrff Fragment thrff
Encryption key:AB9B-21A9-AA
Link Quality=100/100 Signal level:-39 dBm Noise level:-79 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:



After few minutes, the network stops working. An "iwconfig wlan0" shows that the interface is configured for another ESSID.
In order to temporary "fix" the problem, I have to "iwconfig wlan0 essid BTHomeHub-1234".

Does anyone know how come the essid changes randomly?

Thanks
 
Old 07-15-2008, 06:32 AM   #2
AFI
LQ Newbie
 
Registered: Nov 2005
Distribution: Fedora Core 4
Posts: 7

Rep: Reputation: 0
Chipset playing bad?

I've seen this several times. In my case it happened because the Wi-Fi chipset was "kind of intelligent" and was trying to do things on its own.
The solutions depending on the chipset were:
* Run special software from the manufacturer (usually only runs on Win$) and disable that feature.
* In the worst case, modify our drivers to produce a hard reset of the chipset on each restart or wakeup of the machine.

If you have double boot with Win$ you might try to see any options on the connection manager that came with the machine or check on the chipset manufacturer website.
Be aware that sometimes the manufacturer is not the one that shows on the card. For instance Dell have some models where the it publishes the chipset as Dell, but it is in fact Broadcom

Hope it helps
 
Old 07-15-2008, 08:00 AM   #3
hattrick
Member
 
Registered: Oct 2007
Posts: 32

Rep: Reputation: 15
My card used to do that
this is what I did to fix it:

*note, I use fedora Core 9*

on the top toolbar where u see the wifi icon, right click, and click edit connections..


delete all of them, add the one u WANT and set it to auto.


hope this helps.
 
Old 07-15-2008, 08:50 AM   #4
jmfv
LQ Newbie
 
Registered: Nov 2006
Distribution: Debian Stable
Posts: 17

Rep: Reputation: 1
Try to configure your network card using wpa_supplicant

http://www.debian-administration.org/articles/312

Cheers
 
Old 07-15-2008, 12:56 PM   #5
svarmido
Member
 
Registered: Apr 2006
Posts: 78

Rep: Reputation: 15
My wlan0 switch...

If you are using NetworkManager to control your nic, N.M. will automatically attempt to connect to the strongest signal regardless of your preferred ESSID. If you have an understanding of how to control your n.i.c. from within a console - i.e., using the commands "iwconfig", "iwlist scanning", "ifup" and "ifdown" then you may better control what your n.i.c. does. You may use the network device control g.u.i. in order to specific whether or not you wish for NetworkManager to control your n.i.c. or not. Also, if you always use the same ESSID you can specify the ESSID name using the device control g.u.i.. This way, your n.i.c. will always connect to that ESSID if it is available. If not, provided you select "auto" in the device control settings (or with the iwconfig command), the n.i.c. will connect to next strongest available network. Sorry for not providing more specific information. I'm feeling lazy today....
 
Old 07-16-2008, 01:34 AM   #6
ShaiN
LQ Newbie
 
Registered: Jun 2008
Posts: 7

Rep: Reputation: 0
you first need to decide wether or not to use the network manager and its graphical interface.

assuming you choose to do so then
1. right click on its ICON
2. choose the "EDIT Connection"
3. GoTo Wireless Tab
4. choose the wireless network you wish to connect to , e.g. "BTHomeHub-1234"
5. click on the edit button for it
6. make sure the check box for connect automatically is checked.
7. remove all other un-wanted WiFi connections.
8. save and close
*** I'd advise to restart the service after completion to make sure changes take affect

Good Luck
 
Old 07-16-2008, 03:34 AM   #7
david7333
LQ Newbie
 
Registered: Jul 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Wink

Thanks everybody.

I'm using a debian etch and I have removed the NetworkManager package because I first thought it was the cause of the problem.

I'll try your solutions and will update this thread soon!
 
Old 07-16-2008, 04:18 AM   #8
shinybeast
LQ Newbie
 
Registered: Jun 2008
Posts: 5

Rep: Reputation: 0
Network Manager was my bet too

At first read i thought Network Manager might be the problem too. I just do my configuration in /etc/network/interfaces and don't bother with Network Manager. Never had this problem. If i don't specify ESSID (or specify off/any) and go to a public wireless spot, it connects fine without Network Manager anyway.
 
Old 07-26-2008, 06:28 PM   #9
david7333
LQ Newbie
 
Registered: Jul 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Talking

Hi Folks,

- Some more informations about the bug :

dmesg displayed the lines below when the bug happens :
[drm] Loading R300 Microcode
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
IPv6 over IPv4 tunneling driver
wlan0: no IPv6 routers present


- And how I solved the problem :

I upgraded my ralink rt2x00 serialmonkeydriver, from rt61-cvs-2008050207 to rt61-cvs-2008072607.

Up to now, everything works fine!

Thanks everybody for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
automaticaly set up pc card PhoenixofMT Linux - Hardware 2 01-13-2006 08:53 PM
getting X to start automaticaly (again) matttail Debian 10 10-26-2005 01:33 PM
auto switch eth0/wlan0 ogross74 Linux - Networking 0 01-16-2005 01:38 PM
Broadcom wireless with ndiswrapper: ifconfig wlan0 works; ifup wlan0 fails orangechicken Linux - Wireless Networking 2 04-17-2004 05:39 PM
Cant enter runlevel 3 automaticaly pawn-o-matic Linux From Scratch 3 12-28-2003 03:19 PM


All times are GMT -5. The time now is 02:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration