LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   modprobe can't find ndiswrapper (http://www.linuxquestions.org/questions/linux-wireless-networking-41/modprobe-cant-find-ndiswrapper-455745/)

tomecook 06-17-2006 03:56 PM

modprobe can't find ndiswrapper
 
OK, I'm taking the challenge at the top of the newbie page, htis is my first post.

I just installed FC5 and I am trying to get my WPC54G nic card working using ndiswrapper.
I can get:
Code:

ndiswrapper -l
to respond with:
Quote:

lsbcmnds driver loaded-hardware present.
The
Quote:

How-To
I am going by says the next step is to run:
Code:

depmod -a
That takes several seconds to complete and seems to complete successfully.
The next command is:
Code:

modprobe ndiswrapper
.
It returns
"modprobe: Cannot find Module ndiswrapper"
I have a listing of a terminal session showing this if that will help. Keep in mind I am a newbie to Linux so don't assume I know anything!
If I run the command to show my hardware configuration the PCMCIA NIC shows up properly as a broadcom 4306.

HELP!

I posted this on one other forum before I foound this one so don't yell at me.

repo 06-17-2006 05:17 PM

ndiswrapper -l
ndiswrapper -m
modprobe ndiswrapper


Regards

Brian1 06-18-2006 11:52 AM

What steps did you do to install ndiswrapper? From rpm or from precompiled rpm that matches kernel?
What link did you follow to install.

To me it looks like you do not have it compiled to match the current running kernel. The ndiswrapper module must be built to match current running kernel. If you upgrade the kernel you need to update ndiswrapper.

Brian1

tomecook 06-19-2006 07:42 AM

modprobe-what did I do
 
I found a package for ndiswrapper on (I believe) livna and installed it with yum. If I remember correctly the name was kmod-ndiswrapper yum did find dependencies and installed them.
After I ran the command
Code:

ndiswrapper lsbcmnds.inf
from the directory where the files extracted from the driver for my card are located.
That returned:
Quote:

lsbcmnds driver installed
Code:

ndiswrapper -l
returned:
Quote:

lsbcmnds driver installed hardware present
Then I ran
Code:

depod -a
it ran for about 30 seconds and returned the prompt.
Then:
Code:

modprobe ndiswrapper
returned:
Quote:

modprobe could not find Module ndiswrapper
Please explain what I did wrong or what I should try next.

repo 06-19-2006 09:29 AM

Hi,

Take a look at
http://www.ampersand.com/nx6110_fc5/#wireless
for a step to step guide.

Regards


All times are GMT -5. The time now is 05:46 AM.