LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 03-05-2008, 11:16 PM   #1
Brettley
LQ Newbie
 
Registered: Mar 2008
Posts: 1

Rep: Reputation: 0
madwifi, wpa_supplicant and slackware v12 madness


Hey all,

Long time reader first time poster here.

I have a home network with Linksys WRT45G or whatever router. I have it set up with WPA2 Personal wireless encryption. I cannot seem to get it working with wpa_supplicant.

I have been trying to work on this for two whole days and I am getting nowhere.

I installed the madwifi driver from madwifi's website.
I was able to do the make and make install with no problems.
So now I have an ath0 interface. It works with no encryption.
When I turn on my wireless encryption (WPA2 Personal PSK Mixed) the DHCP doesn't work which is fine.

I downloaded the wpa_supplicant install and was not able to build it. It keeps giving me the error:

"Building wpa_supplicant requires a configuration file
(.config). See README for more instructions. You can
run "cp defconfig .config" to create an example
configuration.
make: *** [verify_config] Error 1"

I did as it said and created a .config file in the root directory of wpa_supplicant.

Here are the links that I am following:

document from madwifi Slackware Distro Install How To
document from madwifi 802.11i

<sorry can't post URLs b/c of first time post>

I also read the wpa_supplicant README.

The files that I have are as follows:

= The .config file for wpa_supplicant is in the root directory of wpa_supplicant /root/wpa_supplicant. I just copied the defconfig file and renamed it wifi.config.

= My rc.inet1.conf file; I just added:
#Config information for ath0 (using dhcp):
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]=""

= My rc.wireless.conf; I just added:
#My Wireless Settings
00:0B:CD:59:E8:A1)
INFO="AR5212 802.11abg NIC"
ESSID="<Disabled>" (yes this is actually my ssid)
KEY="I used the wpa_passphrase program to create this"
WPA[1]="wpa_supplicant"
WPADRIVER[1]="wext"
WPACONF[1]="/etc/wpa_supplicant.conf"
WPAOPTS[1]=" -Dwext -iath0 -c/etc/wpa_supplicant.conf"
;;

The last couple of entries WPA[1] etc. I added because I have been looking all over. I think these might be redundant so please tell me if they are.

Lastly, ZOMFG PLZ HELP!
 
Old 03-06-2008, 01:19 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Welcome to LQ!

You configure your network settings for Slackware in /etc/rc.d/rc.inet1.conf ... leave rc.wireless alone.

Use AlienBob's guides ... he wrote those scripts. And get the packages from his repository when you can, rather than building from source.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching to Root in Slackware v12 bo_akins Linux - Newbie 10 10-04-2007 05:06 PM
madwifi and wpa_supplicant, won't authenticate. mr.gizm0 Linux - Wireless Networking 2 09-12-2007 06:48 AM
wpa_supplicant without madwifi support? dlock Slackware 3 07-13-2007 01:41 PM
centos & madwifi rpm madness (weird dependency issue) angryfirelord Linux - Wireless Networking 3 10-05-2006 03:35 PM
madwifi madness help! sniff Linux - Wireless Networking 3 05-12-2006 05:16 PM


All times are GMT -5. The time now is 06:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration