LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   madwifi, wpa_supplicant and slackware v12 madness (http://www.linuxquestions.org/questions/linux-wireless-networking-41/madwifi-wpa_supplicant-and-slackware-v12-madness-626045/)

Brettley 03-05-2008 11:16 PM

madwifi, wpa_supplicant and slackware v12 madness
 
Hey all,

Long time reader first time poster here.

I have a home network with Linksys WRT45G or whatever router. I have it set up with WPA2 Personal wireless encryption. I cannot seem to get it working with wpa_supplicant.

I have been trying to work on this for two whole days and I am getting nowhere.

I installed the madwifi driver from madwifi's website.
I was able to do the make and make install with no problems.
So now I have an ath0 interface. It works with no encryption.
When I turn on my wireless encryption (WPA2 Personal PSK Mixed) the DHCP doesn't work which is fine.

I downloaded the wpa_supplicant install and was not able to build it. It keeps giving me the error:

"Building wpa_supplicant requires a configuration file
(.config). See README for more instructions. You can
run "cp defconfig .config" to create an example
configuration.
make: *** [verify_config] Error 1"

I did as it said and created a .config file in the root directory of wpa_supplicant.

Here are the links that I am following:

document from madwifi Slackware Distro Install How To
document from madwifi 802.11i

<sorry can't post URLs b/c of first time post>

I also read the wpa_supplicant README.

The files that I have are as follows:

= The .config file for wpa_supplicant is in the root directory of wpa_supplicant /root/wpa_supplicant. I just copied the defconfig file and renamed it wifi.config.

= My rc.inet1.conf file; I just added:
#Config information for ath0 (using dhcp):
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]=""

= My rc.wireless.conf; I just added:
#My Wireless Settings
00:0B:CD:59:E8:A1)
INFO="AR5212 802.11abg NIC"
ESSID="<Disabled>" (yes this is actually my ssid)
KEY="I used the wpa_passphrase program to create this"
WPA[1]="wpa_supplicant"
WPADRIVER[1]="wext"
WPACONF[1]="/etc/wpa_supplicant.conf"
WPAOPTS[1]=" -Dwext -iath0 -c/etc/wpa_supplicant.conf"
;;

The last couple of entries WPA[1] etc. I added because I have been looking all over. I think these might be redundant so please tell me if they are.

Lastly, ZOMFG PLZ HELP!

Bruce Hill 03-06-2008 01:19 AM

Welcome to LQ!

You configure your network settings for Slackware in /etc/rc.d/rc.inet1.conf ... leave rc.wireless alone.

Use AlienBob's guides ... he wrote those scripts. And get the packages from his repository when you can, rather than building from source.


All times are GMT -5. The time now is 01:07 PM.