LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 01-20-2010, 09:04 AM   #61
phillywill
Member
 
Registered: Nov 2009
Location: Philadelphia, PA
Distribution: Ubuntu 13.10
Posts: 52

Original Poster
Rep: Reputation: 15

william@william-laptop:~$ ps aux|grep wpa_supplicant
root 777 0.0 0.4 4780 1204 ? S 08:56 0:00 /sbin/wpa_supplicant -u -s
william 1393 0.0 0.3 3040 872 pts/0 S+ 09:02 0:00 grep --color=auto wpa_supplicant
 
Old 01-20-2010, 11:34 AM   #62
pomard
LQ Newbie
 
Registered: Jan 2010
Posts: 9

Rep: Reputation: 1
ps show that wpa_supplicant try to connect to william instead of will. That is the cause of your problem.

your interfaces file should be as follow (/etc/network/interfaces):
Code:
auto lo
iface lo

auto wlan1
iface wlan1 inet dhcp
pre-up wpa_supplicant -B -Dwext -iwlan1 -c/etc/wpa_supplicant.conf
post-down killall -q wpa_supplicant

auto eth0
iface eth0 inet dhcp
your /etc/wpa_supplicant.conf (there was 2 mistakes in a previous post, remove proto=WPA and set auth_alg to SHARED)
Code:
network={
        ssid="will"
        key_mgmt=NONE
        wep_key0=9E67733554 #Here type your wep key in hex, it s given by your router
        wep_tx_keyidx=0
        auth_alg=SHARED
  }
The following commands should work as root
ifdown eth0
ifdown wlan1

Check if wpa_supplicant is still running by typing ps ... as described in a previous post. If it s still running kill it by typing as root "kill -9 777" replace 777 by the pid of your process.

Restart wlan1 by typing as root ifup wlan1

It should go on. if not, restore your interfaces file as it was initialy set.
Normaly on ubuntu configuration is easy through the graphic interface.Remove all your wireless connection and create it again, be ware to type will instead william. Follow any tuto on the web.

Last edited by pomard; 01-20-2010 at 11:47 AM.
 
Old 01-20-2010, 07:53 PM   #63
Surendar.linuxquestions
LQ Newbie
 
Registered: Jan 2010
Posts: 1

Rep: Reputation: 0
Unhappy

Please help me. Im new Here.
I am using ubuntu 9.10 and windows xp.
I didnt like the name 'auto etho' for my connection.
so i copied the mac address from there and pasted it in another new wiredconnection(i added one more connection) and deleted 'auto etho'.
I am able to use internet in xp but not in ubuntu. It says 'Wired Connection is disconnected.'. Please tell me also the guide for me to post new threads.
 
Old 01-21-2010, 07:57 AM   #64
phillywill
Member
 
Registered: Nov 2009
Location: Philadelphia, PA
Distribution: Ubuntu 13.10
Posts: 52

Original Poster
Rep: Reputation: 15
SURENDAR:
Go to the top of this page and you'll see: "LinuxQuestions.org > Forums > Linux > Linux - Networking > Linux - Wireless Networking"
"Click on Linux - Wireless Networking" (If that's the topic forum you want to post) and click on "New Thread"
I also had your same problem with the wired connection. After doing all the above suggestions, I still couldn't connect wireless, but all of a sudden I could no longer connect with the ethernet cable. I went in and changed all my files back to their original content and then went into SYSTEMS > PREFERENCES > Network Connections and deleted all wired and wireless connections.
Then I shut down/restarted with the ethernet cable connected and it set it back up again automatically. The only problem is you have the name you don't want for the wired connection: "Auto eth0"
 
Old 01-21-2010, 08:08 AM   #65
phillywill
Member
 
Registered: Nov 2009
Location: Philadelphia, PA
Distribution: Ubuntu 13.10
Posts: 52

Original Poster
Rep: Reputation: 15
After starting from scratch all over again, when I Go into Network Connections I see "Auto Eth0" for Wired and "Auto Will" for Wireless. "Will" is shown as "Available" as a wireless connection in my notification area. However, when I click to connect I get a window "Wireless Network Authentication Required" asking me for the WEP Key, and I enter the WEP key for AP "Will" - It never connects, the same window just keeps appearing. I tried changing the "Wireless Security" drop down box to Dynamic WEP (802.1x), but that won't even let me click on "connect".
I think I'll try to find an external wireless attachment that's exclusively for Linux, if there is such a thing. Maybe the Linksys I'm using is only for Windows?
 
Old 01-21-2010, 09:40 PM   #66
pomard
LQ Newbie
 
Registered: Jan 2010
Posts: 9

Rep: Reputation: 1
Type lspci to get the chipset of your linksys card and check if it is supported in the following link
https://help.ubuntu.com/community/Ha...rkCardsLinksys

You can also try to change the security settings on your router to WPA/PSK.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] DSL connection slow on Linux wired connection but fast on Windows wireless Pandarsson Linux - Wireless Networking 9 12-17-2010 06:55 PM
Slackware 13.0 & WICD - Slow wired connection, no wireless connection xTyrant Linux - Laptop and Netbook 2 10-15-2009 12:58 AM
Wireless and Wired connection on Belkin wireless G F5D7230 not working together ernie79 Linux - Hardware 1 02-10-2008 07:50 AM
with APM I have no battery monitor, but with ACPI I lose my wireless connection mantis Linux - Laptop and Netbook 2 04-08-2005 07:11 PM
Wireless vs wired connection on same laptop rps63ifid Fedora 7 02-02-2005 10:38 PM


All times are GMT -5. The time now is 06:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration