LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 01-17-2010, 04:08 PM   #46
phillywill
Member
 
Registered: Nov 2009
Location: Philadelphia, PA
Distribution: Ubuntu 13.10
Posts: 52

Original Poster
Rep: Reputation: 15

You lost me again.
When I connect the ethernet cable and I click on the connection symbol it shows:
____________________________________________________________________________________________________ _________________
Wired Network
Auto eth0
Disconnect

Wireless Networks
disconnected

-----------Available--------------------

08FX03045873

Will

----------------------------------------
VPN Connections >
----------------------------------------
Connect to Hidden Wireless Network...
Create New Wireless Network...

____________________________________________________________________________________________________ _______________

I have no idea what "08FX03045873" is. I've gone into SYSTEM > PREFERENCES > Network Connections and deleted it, but it keeps showing up.

"Will" is a Wireless Network Connection created on my Windows 7 Laptop.
 
Old 01-17-2010, 04:14 PM   #47
phillywill
Member
 
Registered: Nov 2009
Location: Philadelphia, PA
Distribution: Ubuntu 13.10
Posts: 52

Original Poster
Rep: Reputation: 15
I'm using a Linksys Wireless-G USB Network adapter in my Linux laptop. My router is a Westell Modem/Router provided by Verizon DSL.
My WINDOWS 7 Laptop has an internal Dell Wireless 1295 WLAN Moni-card with Broadcom 440 X 10/100 Integrated Controller
 
Old 01-17-2010, 04:18 PM   #48
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Quote:
Originally Posted by phillywill View Post
"Will" is a Wireless Network Connection created on my Windows 7 Laptop.
Are you trying to connect to AP "Will" on windows 7?
 
Old 01-18-2010, 05:16 PM   #49
phillywill
Member
 
Registered: Nov 2009
Location: Philadelphia, PA
Distribution: Ubuntu 13.10
Posts: 52

Original Poster
Rep: Reputation: 15
No. Sorry, that's what it sounded like. "Will" is the Network that my 2 Windows computers are on.
 
Old 01-19-2010, 10:51 AM   #50
pomard
LQ Newbie
 
Registered: Jan 2010
Posts: 9

Rep: Reputation: 1
"iwlist wlan1 scan" found only one access point: "will", obviously your router since windows is connected to will.
On your linux iwconfig is associated to william.
wiliam access point has 2 adresses(96:1C:A6:92:CF:54 and 56:9E:51:35:25:AA) , that is not normal. I suspect you have configured your linux as a host access point since its IP adress is 10.42.43.1. Adress finishing by 1 are generaly reserved to routers and on your windows, adress own to the 192.168.1.0 network. vYou should give to your linix the settings of will access point.

So you should fix your interfaces file and your wpa_supplicant.conf file if it exists.

Your /etc/wpa_supplicant.conf should be like this if your are using wpa encryption:
Code:
  network={
        ssid="will"
        proto=WPA
        key_mgmt=WPA-PSK
        psk="your passphrase"
  }
or like this if your are using wep:
Code:
network={
        ssid="will"
        key_mgmt=NONE
        wep_key0=9E67733554 #Here type your wep key in hex, it s given by your router
        wep_tx_keyidx=0
        auth_alg=SHARED 
}
your /etc/network/interfaces

Code:
auto lo
iface lo

auto wlan1
iface wlan1 inet dhcp
pre-up wpa_supplicant -B -Dwext -iwlan1 -c/etc/wpa_supplicant.conf
post-down killall -q wpa_supplicant
auto eth0
...
I hope this will finaly help.
Good luck

Last edited by pomard; 01-20-2010 at 10:49 AM.
 
Old 01-19-2010, 12:35 PM   #51
phillywill
Member
 
Registered: Nov 2009
Location: Philadelphia, PA
Distribution: Ubuntu 13.10
Posts: 52

Original Poster
Rep: Reputation: 15
Thyank you very much for the info.

wpa_supplicant.conf file does not exist. Is there something I should do to create such a file?

My /etc/network/interfaces file:
auto lo
iface lo inet loopback
 
Old 01-19-2010, 12:36 PM   #52
phillywill
Member
 
Registered: Nov 2009
Location: Philadelphia, PA
Distribution: Ubuntu 13.10
Posts: 52

Original Poster
Rep: Reputation: 15
Should I add the lines you stated above to my /etc/network/interfaces file?
 
Old 01-19-2010, 01:09 PM   #53
phillywill
Member
 
Registered: Nov 2009
Location: Philadelphia, PA
Distribution: Ubuntu 13.10
Posts: 52

Original Poster
Rep: Reputation: 15
wlan1 Scan completed :
Cell 01 - Address: 00:18:3AD:6F:C9
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=100/100 Signal level=100/100
Encryption keyn
ESSID:"Will"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=0000003ee07a0844
Extra: Last beacon: 52ms ago
IE: Unknown: 000457696C6C
IE: Unknown: 010882848B962430486C
IE: Unknown: 030106
IE: Unknown: 2A0102
IE: Unknown: 2F0102
IE: Unknown: 32040C121860
IE: Unknown: DD090010180202F0000000
 
Old 01-19-2010, 01:18 PM   #54
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
I do not understand, in your previous post to pastebin:
wlan1 Scan completed :
Cell 01 - Address: 00:18:3AD:6F:C9
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=87/100 Signal level=87/100
Encryption keyn
ESSID:"Will"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=000000180b8dd916
Extra: Last beacon: 48ms ago

"Encryption keyn ", but now it is "Encryption keyn" - what does it mean, copy/paste mistake?

P.S.

I know, it is ": o" gives nothing.

But anyway, encryption method is still unknown.

Last edited by nimnull22; 01-19-2010 at 01:22 PM.
 
Old 01-19-2010, 01:54 PM   #55
phillywill
Member
 
Registered: Nov 2009
Location: Philadelphia, PA
Distribution: Ubuntu 13.10
Posts: 52

Original Poster
Rep: Reputation: 15
I'm using WEP.
Is the last line in wpa_supplicant.conf:
auth_alg=OPEN
or is it:
auth_alg=SHARED OPEN
(My router settings are "OPEN" for network authentication type

Thanks
 
Old 01-19-2010, 02:43 PM   #56
phillywill
Member
 
Registered: Nov 2009
Location: Philadelphia, PA
Distribution: Ubuntu 13.10
Posts: 52

Original Poster
Rep: Reputation: 15
I went ahead and created wpa_supplicant.conf (I did-auth_alg=OPEN)
I changed my /etc/network/interfaces file to read exactly like you sent above.
I restarted the computer and then went to SYSTEM>PREFERENCES>Network Connections, which I posted in
http://pastebin.com/d4a532969
 
Old 01-19-2010, 02:46 PM   #57
phillywill
Member
 
Registered: Nov 2009
Location: Philadelphia, PA
Distribution: Ubuntu 13.10
Posts: 52

Original Poster
Rep: Reputation: 15
When I click on the connection symbol in the notification area I get:
Wired Network
Auto eth0
Wireless Networks
device not managed
 
Old 01-19-2010, 07:35 PM   #58
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
I don't know, may be you have read this many times before, may be not, but take a look.
It may help a lot.

https://help.ubuntu.com/9.10/internet/C/index.html
 
Old 01-19-2010, 08:25 PM   #59
pomard
LQ Newbie
 
Registered: Jan 2010
Posts: 9

Rep: Reputation: 1
I assume it s still not working?
Ok now you have set the wireless setting trough the interfaces file. You have set auth_alg to OPEN and you typed you wep key in wpa_supplicant.conf
You ve got two lines referencing you wireless connection in your network panel I assume that there is one interfering with the other.

Shutdown the wired connection by typing, as root, "ifdown eth0"

Sutdown the wireless connection by typing, as root, "ifdown wlan1"

Check if the wpa_supplicant daemon is down by typing "ps aux|grep wpa_supplicant"
if you get a result note the pid(s) of the process and type as root "kill -9 the pid of wpa_supplicant"
check again and kill again if needed

in another terminal type as root "iwevent"

start the wlan1 connection by typing as root ifup wlan1.

Let us know if it s ok. And give the result of iwevent
 
Old 01-20-2010, 08:02 AM   #60
phillywill
Member
 
Registered: Nov 2009
Location: Philadelphia, PA
Distribution: Ubuntu 13.10
Posts: 52

Original Poster
Rep: Reputation: 15
You ve got two lines referencing you wireless connection in your network panel I assume that there is one interfering with the other.

Shutdown the wired connection by typing, as root, "ifdown eth0"

Sutdown the wireless connection by typing, as root, "ifdown wlan1"

Here's the result:
william@william-laptop:~$ sudo ifdown eth0
[sudo] password for william:
/etc/network/interfaces:2: too few parameters for iface line
ifdown: couldn't read interfaces file "/etc/network/interfaces"
william@william-laptop:~$ ifdown wlan1
/etc/network/interfaces:2: too few parameters for iface line
ifdown: couldn't read interfaces file "/etc/network/interfaces"
william@william-laptop:~$
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] DSL connection slow on Linux wired connection but fast on Windows wireless Pandarsson Linux - Wireless Networking 9 12-17-2010 05:55 PM
Slackware 13.0 & WICD - Slow wired connection, no wireless connection xTyrant Linux - Laptop and Netbook 2 10-14-2009 11:58 PM
Wireless and Wired connection on Belkin wireless G F5D7230 not working together ernie79 Linux - Hardware 1 02-10-2008 06:50 AM
with APM I have no battery monitor, but with ACPI I lose my wireless connection mantis Linux - Laptop and Netbook 2 04-08-2005 06:11 PM
Wireless vs wired connection on same laptop rps63ifid Fedora 7 02-02-2005 09:38 PM


All times are GMT -5. The time now is 03:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration