LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Linux Wireless for Dummies? (http://www.linuxquestions.org/questions/linux-wireless-networking-41/linux-wireless-for-dummies-508298/)

debuser123 12-07-2006 01:51 PM

Linux Wireless for Dummies?
 
I can't find a single thread just detailing how the heck you set up wireless. At this point, all I know is that I have a broadcomm card (dell 1350) and need the broadcomm driver (which I've compiled from the kernel source as a module)...don't know what to do after that! Please help!

ifconfig doesn't list the device. where does eth0 get created as it seems eth0 isn't really a device but a logical name? (eth0 is plain-old ethernet which I do have working with dhclient, but I have no wlan0 of some sort)

No stickies in this forum (minus the compatibility one).

MoonMind 12-07-2006 02:19 PM

If no wireless device is listed, then you didn't install the driver yet; that's done with modprobe, but first, let's check if the card's really available.

In an X terminal, do
Code:

$ su
Password:
# lspci

If your card is listed, you're on your way; do
Code:

# modprobe [yourdriver]
(If it's not listed, you've got a serious compatibility problem at hand, but I doubt that.)

If this doesn't work immediately (i.e. you get errors): Did you place the driver in the correct directory? If not, do
Code:

# modprobe -l | grep wireless
and copy your driver to the directory the other wireless drivers are in. You'll also have to update /etc/modules after that to make it permanently available upon boot.

Redo the modprobe line for your driver. If it completes without errors, do
Code:

# iwconfig
If iwconfig isn't available (it isn't by default, at least not on my system!), do
Code:

# apt-get install wireless-tools
Then redo the iwconfig call.

If you don't get a list of wireless devices available (to be more precise, your card, if as yet unconfigured), you might have to do a reboot to make the kernel module available. Since you've updated /etc/modules for your kernel, it should be loaded automatically on boot. If this doesn't work, something's wrong with the kernel module.

For anything else: Do
Code:

# man iwconfig
and read. iwconfig is for wireless configuration. It works. Use it ;)

Configure your card, do
Code:

# dhclient [yourdevice]
and you're set.

If you want to do all of that in X, you can use the Network Configuration Tool after modprobe, but using iwconfig is easy enough and gives you complete control over what you're doing (except for WPA, but that'd be a different issue).

debuser123 12-09-2006 12:01 AM

dmesg output when I put the card in the slot (driver is bcm43xx compiled as modules for 2.6.19 kernel)

Code:

pccard: CardBus card inserted into slot 0
PM: Adding info for pci:0000:02:00.0
PCI: Enabling device 0000:02:00.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 17 (level, low) -> IRQ 16
PCI: Setting latency timer of device 0000:02:00.0 to 64
bcm43xx: Chip ID 0x4306, rev 0x3
bcm43xx: Number of cores: 5
bcm43xx: Core 0: ID 0x800, rev 0x4, vendor 0x4243, enabled
bcm43xx: Core 1: ID 0x812, rev 0x5, vendor 0x4243, disabled
bcm43xx: Core 2: ID 0x80d, rev 0x2, vendor 0x4243, enabled
bcm43xx: Core 3: ID 0x807, rev 0x2, vendor 0x4243, disabled
bcm43xx: Core 4: ID 0x804, rev 0x9, vendor 0x4243, enabled
bcm43xx: PHY connected
bcm43xx: Detected PHY: Version: 2, Type 2, Revision 2
bcm43xx: Detected Radio: ID: 2205017f (Manuf: 17f Ver: 2050 Rev: 2)
bcm43xx: Radio turned off
bcm43xx: Radio turned off

But you can see the radio is turned off. The status lights on the card do not illuminate fully either.

Code:

# iwconfig eth1
Warning: Driver for device eth1 has been compiled with version 21
of Wireless Extension, while this program supports up to version 17.
Some things may be broken...

eth1      IEEE 802.11b/g  ESSID:off/any  Nickname:"Broadcom 4306"
          Mode:Managed  Access Point: FF:FF:FF:FF:FF:FF
          RTS thr:off  Fragment thr:off
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

Code:

# iwlist eth1 scan
Warning: Driver for device eth1 has been compiled with version 21
of Wireless Extension, while this program supports up to version 17.
Some things may be broken...

eth1      Interface doesn't support scanning : No such device

What about that warning? I found someone else who had this problem (but they didn't have a resolution...here-look twoards wireless lan).

debuser123 12-09-2006 12:42 AM

Ah ha!

this page got me up and running.

What I was missing:
1. bcm43xx-fwcutter
2. an `ifconfig eth1 up` command. once I did that, the power light illuminated

Now to get it working with my router shouldn't be that hard....

Edit: nope, up and running. See this which details everything I did[/url]

MoonMind 12-09-2006 02:55 PM

If you need ifconfig [device] up really depends on the type of card you use (in many cases, configuration via iwconfig is sufficient) - but I should have mentioned it just in case, thanks for the clarification!

I hope setting it up with your router works as expected.

M.

debuser123 12-10-2006 02:35 AM

I've successfully gotten WEP to work...now I'm having a harder time with WPA.

Code:

# wpa_supplicant -Dwext -ieth1 -c/etc/wpa_supplicant.conf
ioctl[SIOCSIWSCAN{,EXT}]: Operation not supported
Failed to initiate AP scan.
IWEVGENIE overflow
IWEVGENIE overflow

My /etc/wpa_supplicant.conf:
Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

network={
        ssid="myrouter"
        scan_ssid=1
        key_mgmt=WPA-PSK
      psk=211111111003a05c833333333333333333333d4dd8cec46a092b568555555555
}

Note: I don't know what ctrl_interface is, but
1) /var/run/wpa_supplicant: no file or folder exists
2) I had no wheel group before...but I just did a groupadd wheel

MoonMind 12-10-2006 04:15 AM

I haven't got any experience with WPA, so I'd be rather grateful if someone else stepped in!

But without going into too much detail, you might try removing the "scan_ssid" statement from the wpa_supplicant.conf and adjust the values there to your values (I just want to state here that I don't hope you pasted your exact details here... Mask things - and change things if what you pasted is what you want to use ("psk=")! The group "wheel" is insignificant as long as you run wpa_supplicant as root). And a tiny hint: Use a space between option and value when entering commands at the cli - I'm not sure if this may have caused parts of the problem.

That said, I've found various tips on how to set up WPA on the net - I won't reiterate everything here since Google's there. Most seem to involve some changes/additions in /etc/network/interfaces

Concerning your comments:
1) I'm pretty certain that the file the "ctrl_interface" statement is talking about will only be created when wpasupplicant is run - look into /var/run to see the type of files put there...
2) The group "wheel" normally is a privileged group, comparable to "root" (but not quite as powerful) - the statement most probably means that the device (or wpa_supplicant) should only be handled by root, and I'd keep it that way. Which means you won't need the "wheel" group.

M.

debuser123 12-10-2006 05:11 PM

Finally got it to work (using WPA2-PSK with TKIP encryption).

ONe of the main problems was that I was using wpa_supplicant from the debian package (apt-get install wpasupplicant).

I decided to just grab the source(0.4.9) and build it myself. I used the CONFIG options detailed on HangDog42's site. Once I built it myself I got none of these IWEVGENIE errors.

Code:

CONFIG_DRIVER_HOSTAP=y
CONFIG_DRIVER_NDISWRAPPER=y
CONFIG_DRIVER_WEXT=y
CONFIG_DRIVER_WIRED=y
CONFIG_IEEE8021X_EAPOL=y
CONFIG_EAP_MD5=y
CONFIG_EAP_MSCHAPV2=y
CONFIG_EAP_TLS=y
CONFIG_EAP_PEAP=y
CONFIG_EAP_TTLS=y
CONFIG_EAP_GTC=y
CONFIG_EAP_OTP=y
CONFIG_EAP_LEAP=y
CONFIG_PKCS12=y
CONFIG_BACKEND=file
#wasn't originally in his file:
CONFIG_CTRL_IFACE=y

Note that I added the CONFIG_CTRL_IFACE define (this allows you to control wpa_supplicant using the gui [wpa_gui] and client [wpa_cli] through unix sockets) (thanks MoonMind for helping me to realize this).

After that, I took the default wpa_supplicant.conf file provided in the source tree and basically removed all network things that was not the type of security I had (I'm using WPA2-PSK with TKIP encryption-just to reiterate). So my final wpa_supplicant.conf file looked like this:

Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
opensc_engine_path=/usr/lib/opensc/engine_opensc.so
pkcs11_engine_path=/usr/lib/opensc/engine_pkcs11.so
pkcs11_module_path=/usr/lib/pkcs11/opensc-pkcs11.so

network={
        ssid="my_essid"
        proto=RSN WPA
        key_mgmt=WPA-PSK
        pairwise=CCMP TKIP
        group=TKIP CCMP WEP104 WEP40
        #psk="mypassphrase"
        psk=c287a1721c84e7fe5d9bdcf0c251ab5f78ff1988734682a56b89e5178851f341
}

blob-base64-exampleblob={
SGVsbG8gV29ybGQhCg==
}

The network block originally in the template wpa_supplicant.conf provided in the source was:
Code:

# Only WPA-PSK is used. Any valid cipher combination is accepted.
network={
        ssid="example"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=CCMP TKIP
        group=CCMP TKIP WEP104 WEP40
        psk=06b4be19da289f475aa46a33cb793029d4ab3db7a23ee92382eb0106c72ac7bb
        priority=2
}

...so I just changed the essid, added RSN to proto (e.g. WPA2), added the output from `wpa_passphrase my_essid "my_passphrase"` to psk and that was pretty much it. Everything else was the same (except deleting all other network blocks except the aforementioned one). Also note that my real wpa_supplicant.conf file is 19K...it has lots of documentation in there.

after that, the command I use to run wpa_supplicant was:
Code:

#/usr/local/sbin/wpa_supplicant -ieth1 -c/etc/wpa_supplicant.conf -Dwext -B
I am then able to run wpa_gui, and this is what I see:
http://img156.imageshack.us/img156/4246/wpaguiei7.png

Since I use debian, I made a little script called wpasup that executed the above wpa_supplicant command (if $IFACE isn't lo) and threw it in /etc/network/if-pre-up.d/ so that when ifup executes run-parts on that directory it gets automatically ran. Also don't forget to chmod a+x otherwise it won't exec. Also threw a script that just did killall wpa_supplicant in /etc/network/if-down.d/; I don't know if there's more of a graceful way to turn off wpa_supplicant but...

...it works!!!

Now, DHCP shouldn't be that hard...

Edit: all numbers, essids, bssids, psks have been doctored :-P I'm not that much of a dummy! I also want to say that yesterday I went to Starbucks with my laptop to see if I could get my card working under a free un-encrypted access point and was successfully able to. HOWEVER I left my laptop on while driving home and I must say there's a crapload of unencrypted most-likely home-networks out there! I know the computer-savvy probably don't care but it really amazed me; I thought the 'world' was more secure than that!

MoonMind 12-11-2006 03:05 PM

About open networks: When I went to the local mall with a sniffer, I stumbled over four open and two only losely encrypted ones... It's a bit frightening, but on the other hand, they're used to the "just works" philosophy they've been lured to believe in. If a child behaves badly, who do you blame: The kid or the parents?

Please accept my apologies for suspecting unwise behaviour from your side: I just wanted to make sure ;)

debuser123 12-11-2006 03:29 PM

Quote:

Originally Posted by MoonMind
About open networks: When I went to the local mall with a sniffer, I stumbled over four open and two only losely encrypted ones... It's a bit frightening, but on the other hand, they're used to the "just works" philosophy they've been lured to believe in. If a child behaves badly, who do you blame: The kid or the parents?

Question...when you saw loosely encrypted, do you mean:
a) only used WEP
b) the WEP key was easy to guess
c) the WEP key was easy to 'figure out' (:cough: brute :cough: force) ;)
d) some other method that wireless security-related docs detail...like weak IVs and other things that exploit WEP

Quote:

Originally Posted by MoonMind
Please accept my apologies for suspecting unwise behaviour from your side: I just wanted to make sure ;)

No problem, but I'm glad you mention it 'cause it makes me double check what I type.

Whew! Got wireless working over the weekend...now for those final exams @ school - gonna be an entirely different story!

MoonMind 12-12-2006 11:26 AM

Of your list, simply a) ;) I'm not the one to go try cracking just for fun, but it would have been extremely easy; most Linux distributions (live CDs) come equipped with the tools needed, so that's that. d) is also a factor - most of them simply were named "network" "mynetwork" or by some provider's default names. They just bought/rented to modem/router, plugged it in, went away, happy as pie because it "just worked". That's what I meant with "scary" - need a private network to explore and (ab)use? Just go out on the street, switch on your lt, and off you go... The result: more zombies and bot nets or just morons clicking away that fill my mailbox with spam and other abominations. In fact, I think one could go on a walk to do some casual spamming along the way - without those people noticing it...

sanjaygawali 12-15-2006 05:40 AM

can anyone tell me deatails installtion of wireless networking in linux 9.0
 
Hi i am sanjay i have some problem with wireless networking in linux 9.0 give me details of how craete wireless network


All times are GMT -5. The time now is 06:39 AM.