LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 04-30-2006, 06:42 PM   #1
rude_reality
Member
 
Registered: Feb 2004
Location: Gainesville, Fl
Distribution: Debian 6
Posts: 40

Rep: Reputation: 15
Question linksys wireless router & linksys wmp54g wireless card


Ok, sorry if this post is a repeat. I can't find the answer through the threads. The router settings as follows:

essid = linksys
mode = infrastructure
channel = 6
security = disabled
authentication = auto
dhcp Client = enable
default gateway = 192.168.1.1
DNS = 192.168.2.1

I can connect ok through windows ok, but my slackware box I can not do...

can someone help me???

thanks

Last edited by rude_reality; 04-30-2006 at 08:47 PM.
 
Old 05-01-2006, 09:56 PM   #2
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
Tell us more about how you setup the interface. Output of iwconfig.
 
Old 05-04-2006, 01:06 PM   #3
rude_reality
Member
 
Registered: Feb 2004
Location: Gainesville, Fl
Distribution: Debian 6
Posts: 40

Original Poster
Rep: Reputation: 15
right now have the computer set up to connect to my window box. the following is the settings.

wlan0 IEEE 802.11g ESSID:"mitchnet" Nickname:"server"
Mode:Ad-Hoc Frequency:2.462GHz Cell: 96:4A:7D1:FF:04
Bit Rate=54Mb/s Tx-Power:14 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:3525-4769-70 Security mode:restricted
Power Managementff
Link Quality:100/100 Signal level:-57 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
 
Old 05-05-2006, 10:11 AM   #4
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
I would probably try to disable the security temporarily to see if that's a problem. Then you will know more about how to proceed.


Maybe try some other security options or different types of security.


edit:

I just noticed a conflict in your posts as well. In the first post you say it is an infrastructure network yet iwconfig says you have it configured for ad-hoc. Correct this problem first and see what you have.

Last edited by DavidPhillips; 05-05-2006 at 10:15 AM.
 
Old 05-05-2006, 06:59 PM   #5
rude_reality
Member
 
Registered: Feb 2004
Location: Gainesville, Fl
Distribution: Debian 6
Posts: 40

Original Poster
Rep: Reputation: 15
sorry, that was the ad-hoc setting to connect direct to the win box. here is the info you requested... One more thing, how do you make the linux box connect to win box. I always have to make windows connect to the linux box before I can start transfering data back the forth.

requested info:

wlan0 IEEE 802.11g ESSIDff/any
Mode:Managed Frequency:2.437GHz Access Point: 00:00:00:00:00:00
Bit Rate:54Mb/s Tx-Power:14 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption keyff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
 
Old 05-09-2006, 11:01 PM   #6
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
What desktop software are you using?
Most of the time I use kinternet. You can browse for networks and start a connection.

Unless you want to use the command line.

Then I usually input this..

iwconfig wlan0 essid myaccesspoint

iwconfig wlan0 key s:secret


also you could use this if needed

iwconfig wlan0 mode managed

or..

iwconfig wlan0 mode ad-hoc



See man iwconfig for more key options and other info


I move around a lot, however if you want to always connect to the same one you can configure the interface to connect on boot, hotplug, or manually.

Last edited by DavidPhillips; 05-09-2006 at 11:20 PM.
 
Old 05-10-2006, 12:11 AM   #7
rude_reality
Member
 
Registered: Feb 2004
Location: Gainesville, Fl
Distribution: Debian 6
Posts: 40

Original Poster
Rep: Reputation: 15
When I use managed, I can't set the essid name. I don't want to use a key. I just want to keep it simple... I'm also use ndiswrapper

Last edited by rude_reality; 05-12-2006 at 03:00 AM.
 
Old 05-14-2006, 07:29 AM   #8
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
Oops, Double posted..

Last edited by DavidPhillips; 05-14-2006 at 07:32 AM.
 
Old 05-14-2006, 07:30 AM   #9
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
What's the command you are using and the error generated?

Also paste your output like this..

iwconfig wlan0
wlan0 IEEE 802.11g ESSIDff/any Nickname:"linux"
Mode:Ad-Hoc Frequency:2.437 GHz Cell: 00:00:00:00:00:00
Bit Rate=54 Mb/s Tx-Power:25 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption keyff
Power Managementff
Link Quality:100/100 Signal level:-69 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0000 Invalid misc:0000 Missed beacon:0




linux:~ # iwconfig wlan0 mode managed
linux:~ # iwconfig wlan0
wlan0 IEEE 802.11g ESSIDff/any Nickname:"linux"
Mode:Managed Frequency:2.437 GHz Access Point: 00:00:00:00:00:00
Bit Rate=54 Mb/s Tx-Power:25 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption keyff
Power Managementff
Link Quality:100/100 Signal level:-57 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0000 Invalid misc:0000 Missed beacon:0


linux:~ # iwconfig wlan0 essid "Days Inn"
linux:~ # iwconfig wlan0
wlan0 IEEE 802.11g ESSID:"Days Inn" Nickname:"linux"
Mode:Managed Frequency:2.462 GHz Access Point: 00:12:17:7B:41:8B
Bit Rate=54 Mb/s Tx-Power:25 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption keyff
Power Managementff
Link Quality:100/100 Signal level:-67 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0000 Invalid misc:0000 Missed beacon:0


Sorry for the long delay, Got busy over here for a while.

Last edited by DavidPhillips; 05-14-2006 at 07:31 AM.
 
Old 05-16-2006, 08:58 PM   #10
rude_reality
Member
 
Registered: Feb 2004
Location: Gainesville, Fl
Distribution: Debian 6
Posts: 40

Original Poster
Rep: Reputation: 15
thank for replying DavidPhillips and trying to help me with this problem. I'm not getting any error messages. I just can't set the essid when its in managed mode. I can set the essid in Ad-Hoc mode. thinkiing I need an newer version of ndiswrapper or new kernal

Last edited by rude_reality; 05-16-2006 at 09:04 PM.
 
Old 05-16-2006, 11:12 PM   #11
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
Don't give up yet!


Verify your radio and AP to see if the adapter is functioning like this..

Make sure the AP is broadcasting it's essid (this is normally an option in the unit).
Then scan for the unit...


# iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:12:17:7B:41:8B
ESSID:"Days Inn"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-72 dBm Noise level:-256 dBm
Encryption keyff
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Bit Rate:18 Mb/s
Bit Rate:24 Mb/s
Bit Rate:36 Mb/s
Bit Rate:54 Mb/s
Bit Rate:6 Mb/s
Bit Rate:9 Mb/s
Bit Rate:12 Mb/s
Bit Rate:48 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 02 - Address: 00:13:10:1F:98:20
ESSID:"Days Inn"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-84 dBm Noise level:-256 dBm
Encryption keyff
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Bit Rate:18 Mb/s
Bit Rate:24 Mb/s
Bit Rate:36 Mb/s
Bit Rate:54 Mb/s
Bit Rate:6 Mb/s
Bit Rate:9 Mb/s
Bit Rate:12 Mb/s
Bit Rate:48 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 03 - Address: 00:13:10:EC:1C:90
ESSID:"TGC320"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:0/100 Signal level:-87 dBm Noise level:-256 dBm
Encryption keyn
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Bit Rate:18 Mb/s
Bit Rate:24 Mb/s
Bit Rate:36 Mb/s
Bit Rate:54 Mb/s
Bit Rate:6 Mb/s
Bit Rate:9 Mb/s
Bit Rate:12 Mb/s
Bit Rate:48 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 04 - Address: 00:13:46:C4:9E:82
ESSID:"TGC350"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-80 dBm Noise level:-256 dBm
Encryption keyn
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:6 Mb/s
Bit Rate:9 Mb/s
Bit Rate:11 Mb/s
Bit Rate:12 Mb/s
Bit Rate:18 Mb/s
Bit Rate:24 Mb/s
Bit Rate:36 Mb/s
Bit Rate:48 Mb/s
Bit Rate:54 Mb/s
Extra:bcn_int=100
Extra:atim=0




Then try this in order.


iwconfig wlan0 mode Managed

iwconfig wlan0 key off

iwconfig wlan0 essid "yourap"

Other ideas...

The essid can not be set unless the connection is actually made so check the AP configuration.

I have setup MAC filters before and after a long time of not making any changes I forgot to add the MAC of my new card. Then when I checked the client list I realized the adapter was new and had not been added. Once I added the new card it worked like a charm.



Maybe you would need to enter the key off command after the essid in some unusual cases.


The reason why it sets in ad-hoc mode is because the essid will show in iwconfig output immediately in ad-hoc mode and only after association in managed mode.


Are you using the windows xp driver from the ndiswrapper wiki list...

http://ndiswrapper.sourceforge.net/m...index.php/List


If the scan does not show the AP you cannot associate with it.






Last edited by DavidPhillips; 05-16-2006 at 11:55 PM.
 
Old 05-18-2006, 05:23 PM   #12
rude_reality
Member
 
Registered: Feb 2004
Location: Gainesville, Fl
Distribution: Debian 6
Posts: 40

Original Poster
Rep: Reputation: 15
ok, I did want you ask me to do. I still can't set the essid to linksys. I copy the info from iwlist to a file. the following is the information I got:

wlan0 Scan completed :
Cell 01 - Address: 00:14:BFB:64:34
ESSID:"linksys"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.437GHz
Quality:0/100 Signal level:-80 dBm Noise level:-256 dBm
Encryption keyff
Bit Rate:1Mb/s
Bit Rate:2Mb/s
Bit Rate:5.5Mb/s
Bit Rate:11Mb/s
Bit Rate:18Mb/s
Bit Rate:24Mb/s
Bit Rate:36Mb/s
Bit Rate:54Mb/s
Bit Rate:6Mb/s
Bit Rate:9Mb/s
Bit Rate:12Mb/s
Bit Rate:48Mb/s
Extra:bcn_int=100
Extra:atim=0
 
Old 05-22-2006, 05:16 PM   #13
rude_reality
Member
 
Registered: Feb 2004
Location: Gainesville, Fl
Distribution: Debian 6
Posts: 40

Original Poster
Rep: Reputation: 15
I not sure what I did, but I got it working. For some reason I could not set it manually. But I change the wireless.conf file in the rc.d directory and rebooted. it work. thanks for all the help..
 
Old 05-25-2006, 07:01 AM   #14
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
That's Cool

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linksys Wireless G PCI Card (WMP54G) [DRIVERS!!!] Sherpa Linux - Wireless Networking 33 03-29-2006 09:32 AM
Linksys Wireless G PCI card (WMP54G I think) OneSeventeen Linux - Wireless Networking 2 04-09-2005 09:09 AM
Trouble using Linksys WMP54G wireless card with SuSE 9.1 Personal Woessey Linux - Wireless Networking 1 09-21-2004 03:59 PM
Driver needed for linksys wireless card WMP54G Mandrake_Newb Linux - Hardware 2 04-03-2004 05:05 PM
Wireless Card w/ Linksys router Scooter McGee Linux - Newbie 4 11-10-2003 09:43 PM


All times are GMT -5. The time now is 09:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration