LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 11-21-2009, 06:06 AM   #1
darkmaster977
LQ Newbie
 
Registered: Nov 2009
Posts: 4

Rep: Reputation: 0
"iwlist wlan0 scanning" doesn't see my AP.


Hi
Yesterday I installed Slackware (current) on my computer. I can't cope with the configuration of the wireless network connection. As a result of "iwlist wlan0 scanning" I get a list of some wireless networks, except for mine. When I try to connect to my wireless network, my computer is not getting an IP address from a DHCP server. To connect to my wireless network I'm using firmware downloaded from the slackware-current directory on my mirror.
My wireless network card is: Intel Corporation PRO / Wireless 3945ABG
My access point is: Linksys WAP54G
Has anyone had a similar problem??? What is the solution???

Last edited by darkmaster977; 11-21-2009 at 06:41 AM. Reason: adapter=>card
 
Old 11-21-2009, 06:56 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Lets look at a few things. I've got that exact combination of card and router and I know it works.

First off, is your SSID being broadcastby the router? If not, turn on broadcast. Second, make sure that the driver is loaded properly. Have a look in lsmod to make sure iwl3945 is being loaded and have a look in your system log (/var/log/messages, /var/log/syslog and dmesg output) and see if there is any complaining from the card or the driver.

As far as configuring, I've found wicd to be an easy way to deal with wireless in Slackware. You'll find a wicd package in the /extra directory. If you install it, make sure to add your user to the netdev group, otherwise the wicd client doesn't work properly.
 
Old 11-21-2009, 05:44 PM   #3
darkmaster977
LQ Newbie
 
Registered: Nov 2009
Posts: 4

Original Poster
Rep: Reputation: 0
I think I know what the problem is, my network is working on channel 12, when I try to switch the card to that channel, I get an error like "Unable to change...". Tomorrow I will try to re-install Slackware to version 13.0. Maybe this will help.

My AP config:
http://kklodzka.pdg.pl/slack/ap_config.png

My /var/log/messages:
http://kklodzka.pdg.pl/slack/messages00

My /var/log/syslog:
http://kklodzka.pdg.pl/slack/syslog00

My /var/log/dmesg:
http://kklodzka.pdg.pl/slack/dmesg00
 
Old 11-21-2009, 06:59 PM   #4
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Quote:
Originally Posted by darkmaster977 View Post
I think I know what the problem is, my network is working on channel 12, when I try to switch the card to that channel, I get an error like "Unable to change...". Tomorrow I will try to re-install Slackware to version 13.0. Maybe this
Have you tried to change channel in your wireless router?
It will be easy.

Second, your wireless card might not see your SSID, because router doesn't announce it.
To check this, find other devices with wi-fi and scan.

About the channel number, your wireless card connects not to the number, but to SSID of AP, so channel number has nothing in common with connecting process.

Last edited by nimnull22; 11-21-2009 at 07:13 PM.
 
Old 11-22-2009, 04:33 AM   #5
darkmaster977
LQ Newbie
 
Registered: Nov 2009
Posts: 4

Original Poster
Rep: Reputation: 0
It works, but channel 12 is the only free frequency.
 
Old 11-22-2009, 07:04 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Quote:
Originally Posted by darkmaster977 View Post
It works, but channel 12 is the only free frequency.
Well, since we all know that nobody actually exists outside of US borders (where channels stop at 11), it turns out you need to add some extra parameters so that when iwl3945 gets loaded it is capable of recognizing channel 12. Try adding this to your modprobe.conf file and either remove and reload iwl3945 or reboot.

Code:
 options cfg80211 ieee80211_regdom=EU
 
  


Reply

Tags
intel, linksys, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting error while "iwlist scan" on Ubuntu. eaivision Linux - Laptop and Netbook 4 07-01-2009 12:05 PM
net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi" Cayitano Linux - Newbie 5 12-09-2007 07:11 PM
iwlist wlan0 scanning lefter Fedora 1 12-28-2006 08:57 AM
Wireless chip is displayed as "Ath0" instead of "wlan0" with Belkin F5D7000 ceramicsushi Linux - Wireless Networking 4 04-05-2006 11:26 PM
is "iwlist scan" possible with Netgear MA401? dibblethewrecke Linux - Wireless Networking 0 05-17-2005 11:52 PM


All times are GMT -5. The time now is 04:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration