LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 11-30-2003, 01:51 PM   #1
Belize
Member
 
Registered: Jul 2003
Posts: 113

Rep: Reputation: 15
iwconfig ( wireless lan ) questions


Greetings.
Today I installed slackware 9.1 on my laptop. I have pcmcia wireless Lucern Cabletron 802.11 card.
I want to make my wireless lan work ( which connects me to the internet ) and in IRC a guy told me to use iwconfig to set it up.
I used iwconfig eth0 --help and got aware of the options, but they dont work
Only two worked - to change the SSID and the Nickname of the wireless network. The command for the network key ( which I should enter, so my wireless lan work ) is nic. The options if I remember right are {NNNN|off} and I tried iwconfig -eth0 nic *key* or iwconfig -eth0 nic on but they wouldnt work. Can you please help with this - how to enter those iwconfig settings and explain if I have to edit some other settings.
Thanks in advance! I will really appreciate any help. Peace
 
Old 11-30-2003, 02:46 PM   #2
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
The syntax for setting up WEP for your card is:
iwconfig eth0 key 1234567890abcde ... (26 hex digits in all for 128 bit WEP)
I see what you mean about iwconfig -h and the options listed. I've never used those and I'm at a loss to explain the discrepancy, but try man iwconfig. The options there work fine for me.

FYI, to store the values (iwconfig settings are transient), edit /etc/pcmcia/wireless.opts. Use the generic settings at the bottom of the file.
 
Old 11-30-2003, 03:22 PM   #3
Belize
Member
 
Registered: Jul 2003
Posts: 113

Original Poster
Rep: Reputation: 15
hi, I booted and tried iwconfig eth0 key *KEY* and wouldnt work
also ( I am trying examples from man iwconfig ) I tried iwconfig eth0 mode auto which wouldnt work as well.

I copied wireless.opts before editing and there I deleted all those drivers for the other pcmcia wireless cards I dont need. But this configuration file is poorly commented, at least I cant understand it. Should I edit the driver for my Lucern(sp?) Cabletron card, or should I enter the generic options ?

Also, I cant understand this HEX key thing. In wireless.opts, should I edit my key ( the normal word ) or if the only way is to write it in HEX, how can I transform it in HEX ? and in the comments to the key section there is something like "s:key", should I write an s: before the key ???

Peace
 
Old 11-30-2003, 03:54 PM   #4
bbeers
Member
 
Registered: Jul 2002
Location: Florida
Distribution: Centos, Slackware
Posts: 260

Rep: Reputation: 30
Did you post this same question in two forums??

Which chipset is this card? cardctl ident
Which driver is loaded for this card? lsmod

What does iwconfig eth0 return?

Are you trying to associate to an access point or connect via peer-to-peer?
Mode argument for access point is managed, for peer-to-peer is adhoc,
to _be_ the access point is master. (there are even more modes btw)

To convert ascii to hex check the ascii table at ...
<http://asciitable.com>
or you can put the s: prefix in front of the plain text key word, but
some access points don't convert exactly the same way, plus hex
values are harder to guess.


I recommend you delay worrying about the WEP keying until you are sure
you are even connecting wirelessly.
 
Old 11-30-2003, 04:25 PM   #5
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
Don't know what you're using as a key, but for 128 bit WEP you need 26 hexadecimal characters. There are lots of utilities that hash an alphanumeric word or phrase into a hex key, but that leaves you open to dictionary attacks. I use a spreadsheet to generate keys, but there are lots of pseudo-random generators around (with their own issues).

Here is my wireless.opts file for reference (the WEP key is obviously bogus) Removing the comments and unused functions, I could have three lines - ESSID, WEP and mode :
# Generic example (decribe all possible settings)
*,*,*,*)
INFO="Fill with your own settings..."
# ESSID (extended network name) : My Network, any
ESSID="wireless"
# NWID/Domain (cell identifier) : 89AB, 100, off
NWID=""
# Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
MODE="Managed"
# Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
FREQ=""
CHANNEL=""
# Sensitivity (cell size + roaming speed) : 1, 2, 3 ; -70 (dBm)
SENS=""
# Bit rate : auto, 1M, 11M
RATE="auto"
# Encryption key : 4567, sassword
KEY="1234-abcd-5678-bcde-9876-3210-bb"
# RTS threshold : off, 500
RTS=""
# Fragmentation threshold : off, 1000
FRAG=""
# Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
IWCONFIG=""
# iwspy parameters : + 01:23:45:67:89:AB
IWSPY=""
# iwpriv parameters : set_port 2, set_histo 50 60
IWPRIV=""
;;
esac
 
Old 12-01-2003, 04:02 AM   #6
Belize
Member
 
Registered: Jul 2003
Posts: 113

Original Poster
Rep: Reputation: 15
bbeers : yeah I posted this thread also in the slackware forum. Crossposting is bad, I know, but I want to have as much help as I can ( moderators can close the one in slackware )

Im not really sure for the mode, but in winXP it is "Auto", and not "Managed". I just had to enter the SSID and WEP key and voila! - it worked.

I will post the output of cardctl ident, lsmod amd iwconfig later as I am now in the library and not in my room.

And I will have to read again what you guys wrote about the hex key thing to understand it

Thank you very much for helping me
Peace
 
Old 12-01-2003, 02:53 PM   #7
Belize
Member
 
Registered: Jul 2003
Posts: 113

Original Poster
Rep: Reputation: 15
As long as I dont have internet, or a FAT partition where to copy the output of the commands, I am writing them in a notebook and after that copying them here.
Code:
root@Belize:~#cardctl ident
Socket 0:
   product info: "Cabletron", "RoamAbout 802.11 DS", "Version 01.01", ""
   manfid: 0x0156, 0x0002
function: 6 (network)

root@Belize:~#lsmod * HERE I POST ONLY THE ONES THAT HAVE SOMETHING TO DO WITH MY WIRELESS *
Module             Size          Used by
orinoco_cs      4276          0 (unused)
orinoco           33324        0 [orinoco_cs]
hermes           5732          0 [orinoco_cs orinoco]
ds                   6568          1 [orinoco_cs]
yenta_socket 10368        1
pcmcia_core   40032         0 [orinoco_cs cs yenta_socket]

root@Belize:~#iwconfig
lo no wireless extensions

eth0 IEEE 802.11-DS    ESSID:""    Nickname:"HERMES I"
    Mode: Managed   Frequency: 2.422GHz   Access Point:00:00:00:00:00:00
    Bit Rate: 11MB/s    Tx-Power=15dBm    Sensetivity:1/3
    Retry Limit:4 RTS thr: off Fragment thr: off
    Encryption key: off
    Power managment: off
    Link Quality 0/92   Signal Level:134/153    Noise Level:134/153
    Rx invalid nwid:0    Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retreies:0   Invalid misc:0    Missed beacon:0

eth1 no wireless extensions
If you have other questions, please ask.
Thanks for helping!

Last edited by Belize; 12-01-2003 at 03:09 PM.
 
Old 12-01-2003, 04:08 PM   #8
bbeers
Member
 
Registered: Jul 2002
Location: Florida
Distribution: Centos, Slackware
Posts: 260

Rep: Reputation: 30
Ok, looks reasonable so far. No ESSID name and Access Point:00...
means you are not associated to an access point yet.

Which access point are you using? Do you know the ESSID?
Like linksys, or whatever you may have changed it to.
You should be able to issue a command like:
#iwconfig eth0 essid linksys
(the # at the beginning of the line is the prompt when you are root,
you don't type it.)
then check
#iwconfig eth0
your Access Point:xx:xx:xx: should now match the access point's MAC addr.

Then if you _need_ WEP key, verify from the access point which of 4 keys
is active, set same key active on linux, maybe something like this:
#iwconfig eth0 key s:CoDe [1] key s:BIGsecret [3] key [3]

And then finally, try this to get an IP address:
#dhcpcd eth0

or if you prefer just set a static IP with ifconfig eth0 whatever, but then
you have to add a default route and set domain name servers in /etc/resolv.conf

Lot's to do/learn, but it does work. :grin:
 
Old 12-02-2003, 11:32 AM   #9
Belize
Member
 
Registered: Jul 2003
Posts: 113

Original Poster
Rep: Reputation: 15
dude, THIS WORKS !

Thank you ppl so much for helping, now I write this post with Konqueror rox

Now, to make those commands be started automatically when I boot, should I add them to rc.local ?

Any other additional information/help will be great too.

Again thanks for helping !
 
Old 12-02-2003, 11:47 AM   #10
Belize
Member
 
Registered: Jul 2003
Posts: 113

Original Poster
Rep: Reputation: 15
yeah I added to rc.local
Code:
ifconfig eth0 essid *ESSID*
ifconfig eth0 key s:*KEY*
dhcpcd eth0
and it works
 
Old 12-02-2003, 02:28 PM   #11
bbeers
Member
 
Registered: Jul 2002
Location: Florida
Distribution: Centos, Slackware
Posts: 260

Rep: Reputation: 30
congrats,

You should be able to set those iwconfig params in the /etc/pcmcia/wireless.opts file
and the dhcpcd in the /etc/pcmcia/network.opts file and have it work automatically
when you boot or remove/replace the pcmcia card.

But it's okay to put it in rc.local if you're going to leave the card in all the time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to configure wireless NIC with iwconfig essdeeay Linux - Wireless Networking 1 12-10-2004 04:56 PM
Debian: How do I set wireless (iwconfig) options at boot? muzicman82 Linux - Wireless Networking 1 06-06-2004 11:57 AM
iwconfig ( wireless lan ) questions Belize Slackware 2 11-30-2003 03:28 PM
Wireless: RedHat 9 + 3CRSHPW796 (ADM8211) = iwconfig not working Guru3 Linux - Wireless Networking 1 11-28-2003 01:20 PM
Wireless problem (iwconfig) WhoDang Slackware 2 04-19-2003 02:15 AM


All times are GMT -5. The time now is 06:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration