LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 09-13-2006, 06:16 AM   #1
irena56
LQ Newbie
 
Registered: Oct 2004
Posts: 24

Rep: Reputation: 15
Exclamation iwconfig does nor set essid


Hi there,

I installed my wireless network card (Netgear) on FC4 with 16k kernel (I had to upgrade to this kernel as FC4 originally came with 4k kernel) using ndiswrapper v1.1.
I also installed wireless-tool v.28 as this version was recommended for FC4.
When I type
iwlist wlan0 scan
I get correct information about my wireless card (essid, mac address, etc.)
When I type
iwconfig wlan0
the essid is not set and the mac address is all zeros.
After typing 'iwconfig wlan0 essid essid-name' iwconfig still shows no essid or mac address set for my wireless card.

Has anyone have any suggestions what is wrong and how to fix it?
Different wireless HowTo indicate that I can not proceed if 'iwconfig wlan0' shows no essid set.

Thanks,
irena56
 
Old 09-14-2006, 03:11 PM   #2
zetabill
Member
 
Registered: Oct 2005
Location: Rhode Island, USA
Distribution: Slackware, Xubuntu
Posts: 348

Rep: Reputation: 30
Do you get any error messages?
 
Old 09-15-2006, 09:38 AM   #3
MasterKin8T
Member
 
Registered: Jul 2003
Location: Maryland
Distribution: Slackware 9.1
Posts: 56

Rep: Reputation: 15
Stupid question, but have you set the card to mode Managed?
 
Old 09-15-2006, 10:34 AM   #4
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,450

Rep: Reputation: Disabled
You may need to "ifconfig wlan0 up" before setting the essid?

Brian
 
Old 09-18-2006, 08:20 AM   #5
irena56
LQ Newbie
 
Registered: Oct 2004
Posts: 24

Original Poster
Rep: Reputation: 15
I don't get any error messages and I have set the mode to managed.
It seems that 'iwconfig wlan0 essid essid-name' does not do anything. After executing this command 'iwlist wlan0 scan' outputs correct information, but 'iwconfig wlan0' does not.
Perhaps there is something wrong with the wireless-tool v.28. I don't really know what other wireless-tool I can use with FC4.

I will try "ifconfig wlan0 up" before setting the essid.

cheers,
Irena
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot set ESSID with iwconfig leapingfrog Linux - Wireless Networking 37 09-15-2008 03:54 AM
Cant change ESSID with iwconfig svenbox Linux - Hardware 1 04-27-2005 05:54 AM
iwconfig - can't set essid simon_w Linux - Wireless Networking 5 04-13-2005 09:23 PM
iwconfig shows essid, unable to connect rjcrews Linux - Wireless Networking 8 12-21-2004 04:59 PM
essid not being set with iwconfig jonathan_t Linux - Wireless Networking 17 10-19-2004 06:14 AM


All times are GMT -5. The time now is 11:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration