Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.


  Search this Thread
Old 10-08-2004, 07:05 AM   #1
LQ Newbie
Registered: Nov 2003
Posts: 4

Rep: Reputation: 0
ipw2200 - Unable to load ucode, unable to load firmware

I'm trying to run ipw2200 on Fujitsu-Siemens Amilo Pro V2000D. It has Intel PRO/Wireless 2200BG. The driver compiles, but when I try do load the module, I get following messages in dmesg:

ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 0.11
ipw2200: Copyright(c) 2003-2004 Intel Corporation
ACPI: PCI interrupt 0000:02:06.0[A] -> GSI 10 (level, low) -> IRQ 10
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: Unable to load ucode
ipw2200: Unable to load firmware: 0xFFFFFFEA
ipw2200: failed to register network device
ipw2200: probe of 0000:02:06.0 failed with error -5

I use Slackware 10.0 kernel, I have hotplug, and I placed the firmware in /usr/lib/hotplug/firmware directory as well as in /etc/firmware. Googling doesn't provide any information about those error messages.

Any ideas?

Old 10-10-2004, 08:46 AM   #2
Registered: Feb 2004
Distribution: Slackware 14.1
Posts: 442

Rep: Reputation: 32
Just a thought, I am wrestling with something similar at the moment, did you enable the firmware hotplugging option when compiling the kernel?


Old 10-10-2004, 09:28 AM   #3
LQ Newbie
Registered: Nov 2003
Posts: 4

Original Poster
Rep: Reputation: 0
I finally solved this problem. It turned out that the problem was that ipw2200 wouldn't load if ndiswrapper was loaded and removed before. If you load ndiswrapper module, you have to reboot. "rmmod ndiswrapper" is not enough.

Now I got this card to work, and I'm wrestling (yeah, that's a good word) with DWL-120+ with damned ACX100 chipset. Seems like I have to fix the ACX100 driver myself, I wish I knew where to begin.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash won't load in Konqueror - "Unable to load Netscape plugin" rollo Linux - Software 2 09-10-2005 01:28 PM
unable to load mouse Cam.Thompson Slackware - Installation 6 08-17-2005 11:39 PM
Unable to load KDE NicoLinux Linux - Newbie 3 01-27-2005 07:45 AM
IPW200 unable to load firmware eggoz Linux - Wireless Networking 7 10-05-2004 09:46 PM
Unable to load X dragonlook Linux - Software 5 07-27-2004 07:49 PM

All times are GMT -5. The time now is 03:57 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration