LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 07-18-2007, 12:20 AM   #1
narz
Member
 
Registered: May 2007
Location: US
Distribution: slackware
Posts: 184

Rep: Reputation: 35
IP Unavailable, wireless help please


i have just installed slackware 12 and compiled the latest madwifi drivers for my atheros chipset. everything seems to be in order, as i can scan for the local area wireless networks just fine, but i cannot obtain an ip address.
i have set up my wireless network info in the wireless networks config section in kde, and when i go into kwifimanager my network comes up and says im connected with good signal strength but it says ip unavailable.
i have done an ifdown on my ethernet port(eth0) and an ifup on my wireless(ath0) and i have tried dhcpcd ath0, it just stalls for about 30 seconds and nothing happens. and dhclient ath0 gives me this message:

wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/ath0/00:15:af:09:3c:94
Sending on LPF/ath0/00:15:af:09:3c:94
Can't bind to dhcp address: Address already in use
Please make sure there is no other dhcp server
running and that there's no entry for dhcp or
bootp in /etc/inetd.conf. Also make sure you
are not running HP JetAdmin software, which
includes a bootp server.

i have googled my problem for the past hour and only find people saying the same things that arent helping me. i hope someone else has had this problem and knows how to handle it or someone might know whats wrong. i have used wireless with no problems on debian and ubuntu.

thanks.
 
Old 07-18-2007, 12:36 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
In my experience, the KDE GUI tools don't work as expected. Maybe they are great tools, and I'm not able to use them properly.

In Slackware your network is setup in /etc/rc.d/rc.inet1.conf and /etc/resolv.conf -- and if you want to set it up automatically, rather than edit thess files, you can open a terminal/konsole and as root run the command "netconfig" which will do it automatically for you.

If you use "netconfig" and still have problems, post back and we'll go from there.
 
Old 07-18-2007, 02:47 AM   #3
narz
Member
 
Registered: May 2007
Location: US
Distribution: slackware
Posts: 184

Original Poster
Rep: Reputation: 35
oh thanks for reply, sorry i took a nap there for a little while. lol.
ok so i ran netconfig, it didnt really offer me any options other than choosing my host name, domain name and whether i wanted to connect my ethernet port with static ip or dhcp. but no help for wireless.
thanks anyways.
 
Old 07-18-2007, 03:20 AM   #4
narz
Member
 
Registered: May 2007
Location: US
Distribution: slackware
Posts: 184

Original Poster
Rep: Reputation: 35
ok so i tried to edit the /etc/rc.d/rc.inet1.conf file.
i found this:
# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

so i tried this:

IFNAME[ath0]
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

but on boot it just says command IFNAME[ath0] not found.
???

still working at it.
 
Old 07-18-2007, 03:28 AM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
To answer your above post ^ before proceeding to my diatribe :}

If you want to try editing /etc/rc.d/rc.inet1.conf it should look like this:
Code:
# Config information for ath0:
IFNAME[0]="ath0"
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
#DHCP_HOSTNAME[1]=""
If that doesn't work ...

First, is your wireless adapater recognized? What is the output of:
Code:
/sbin/lspci | grep -i ethernet
Second, is the module for your wireless adapter loaded? What is the output of:
Code:
lsmod | grep -i ath
Third, as asked from your system, are you running the HP JetAdmin software? What is the output of:
Code:
ps aux | grep -i hp
Fourth, what does your network setup look like? What is the output of:
Code:
cat /etc/rc.d/rc.inet1.conf
and
Code:
cat /etc/resolv.conf
Last, what is in your system log? What is the output of:
Code:
dmesg | grep -i wifi
 
Old 07-18-2007, 03:59 AM   #6
narz
Member
 
Registered: May 2007
Location: US
Distribution: slackware
Posts: 184

Original Poster
Rep: Reputation: 35
Quote:
Originally Posted by Bruce Hill
To answer your above post ^ before proceeding to my diatribe :}

If you want to try editing /etc/rc.d/rc.inet1.conf it should look like this:
Code:
# Config information for ath0:
IFNAME[0]="ath0"
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
#DHCP_HOSTNAME[1]=""
haha...yes i figured this one out shortly after posting that, after about a minute on reboot it seemed to assign a mac address to ath0 but didnt work.

If that doesn't work ...

First, is your wireless adapater recognized? What is the output of:
Code:
/sbin/lspci | grep -i ethernet
03:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g Wireless PCI Express Adapter (rev 01)
05:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)


Second, is the module for your wireless adapter loaded? What is the output of:
Code:
lsmod | grep -i ath
ath_rate_sample 16000 1
ath_pci 91680 0
wlan 194372 4 wlan_scan_sta,ath_rate_sample,ath_pci
ath_hal 193616 3 ath_rate_sample,ath_pci

Third, as asked from your system, are you running the HP JetAdmin software? What is the output of:
Code:
ps aux | grep -i hp
root 249 0.0 0.0 0 0 ? S< 03:43 0:00 [khpsbpkt]
me 3265 0.0 0.0 2004 648 pts/1 S+ 03:51 0:00 grep -i hp

Fourth, what does your network setup look like? What is the output of:
Code:
cat /etc/rc.d/rc.inet1.conf
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout. Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0. Uncomment the lines you need and fill
## in your info. (You may not need all of these for your wireless network)
#IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
#USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=BARRIER05
#WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=7B1ABEEB5D197741923ED26727569C365E31212096A0EAFAD563B268BAD01CAF TxRate=0"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0" # Use a different interface name nstead of
# the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89" # Overrule the card's hardware MAC address
#MTU[4]="" # The default MTU is 1500, but you might need
# 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes" # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes" # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes" # If you don't want the DHCP server to change
# your default gateway
#DHCP_IPADDR[4]="" # Request a specific IP address from the DHCP
# server
#WLAN_ESSID[4]=DARKSTAR # Here, you can override _any_ parameter
# defined in rc.wireless.conf, by prepending
# 'WLAN_' to the parameter's name. Useful for
# those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=thekey TxRate=0"
# Some drivers require a private ioctl to be
# set through the iwpriv command. If more than
# one is required, you can place them in the
# IWPRIV parameter (space-separated, see the
# example).

and
Code:
cat /etc/resolv.conf
# Generated by dhcpcd for interface eth0
search hsd1.il.comcast.net.
nameserver 68.87.72.130
nameserver 68.87.77.130


Last, what is in your system log? What is the output of:
Code:
dmesg | grep -i wifi
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
wifi0: mac 10.0 phy 6.1 radio 10.2
wifi0: Use hw queue 1 for WME_AC_BE traffic
wifi0: Use hw queue 0 for WME_AC_BK traffic
wifi0: Use hw queue 2 for WME_AC_VI traffic
wifi0: Use hw queue 3 for WME_AC_VO traffic
wifi0: Use hw queue 8 for CAB traffic
wifi0: Use hw queue 9 for beacons
wifi0: Atheros 5424/2424: mem=0xdfef0000, irq=21

and for good measure here is my ifconfig:

ath0 Link encap:Ethernet HWaddr 00:15:AF:09:3C:94
inet6 addr: fe80::215:afff:fe09:3c94/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth0 Link encap:Ethernet HWaddr 00:18:F3:6A:2D:F9
inet addr:192.168.1.103 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::218:f3ff:fe6a:2df9/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:695 errors:0 dropped:0 overruns:0 frame:0
TX packets:733 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:473892 (462.7 KiB) TX bytes:117968 (115.2 KiB)
Interrupt:20 Base address:0xe800

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wifi0 Link encap:UNSPEC HWaddr 00-15-AF-09-3C-94-61-74-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8421 errors:0 dropped:0 overruns:0 frame:11762
TX packets:3193 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:1326500 (1.2 MiB) TX bytes:146878 (143.4 KiB)
Interrupt:21

and iwconfig:
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"" Nickname:"host"
Mode:Managed Frequency:2.427 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:17 dBm Sensitivity=0/3
Retryff RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=0/94 Signal level=-94 dBm Noise level=-94 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


EDIT: i have since found this guide http://madwifi.org/wiki/UserDocs/Distro/Slackware buried in the docs at madwifi.org. its still no help as i followed it step by step and still come back to square one, so i re-edited my files back to the defaults as you see them there. if you can think of any other options i have, please let me know.
otherwise i am considering this a lost cause for the time being.

Last edited by narz; 07-18-2007 at 06:00 AM.
 
Old 07-18-2007, 06:06 AM   #7
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
This is what I see wrong:
Code:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""
You have no interface for ath0, and eth0 is running.

This is how I would suggest you set it up:
Code:
# Config information for eth0:
IFNAME[0]="eth0"
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for ath0:
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]=""

# Default gateway IP address:
GATEWAY=""
Your output of "/sbin/lspci | grep -i ethernet" indicates you only have two ethernet interfaces, so that is all you need in that file.

You can change the file as above, save it, then restart but issue these commands:
Code:
/etc/rc.d/rc.inet1 eth0_down
which should stop your wired interface. Then issue:
Code:
/etc/rc.d/rc.inet1 ath0_restart
which should start your wireless interface.

There are ways to write scripts, etc., so that you can start the one you want at boot. But the easiest thing for now might be to just comment out (put # in front of the line) the one you don't want to use. For instance:
Code:
# Config information for eth0:
IFNAME[0]="eth0"
IPADDR[0]=""
NETMASK[0]=""
#USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for ath0:
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]=""
should start the wireless interface when you boot. If you want the wired, comment ath0 and uncomment (remove the # from in front of the line) eth0.
 
Old 07-18-2007, 06:15 AM   #8
narz
Member
 
Registered: May 2007
Location: US
Distribution: slackware
Posts: 184

Original Poster
Rep: Reputation: 35
thanks for reply.
but what you suggest is exactly what i did after i read that guide from madwifi. i think this is just slackware's way of telling me to go back to debian. lol.
 
Old 07-18-2007, 06:17 AM   #9
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Go back, but you still have incorrect information in /etc/rc.d/rc.inet1.conf ...

Garbage in, garbage out.
 
Old 07-18-2007, 06:26 AM   #10
narz
Member
 
Registered: May 2007
Location: US
Distribution: slackware
Posts: 184

Original Poster
Rep: Reputation: 35
Quote:
Originally Posted by Bruce Hill
Go back, but you still have incorrect information in /etc/rc.d/rc.inet1.conf ...

Garbage in, garbage out.
lol...whats the incorrect information? everything is commented out, how can it be garbage? i already told you i edited the file as you described after i found that guide. the file you are looking at was before i had done anything to it.
 
Old 07-18-2007, 06:38 AM   #11
narz
Member
 
Registered: May 2007
Location: US
Distribution: slackware
Posts: 184

Original Poster
Rep: Reputation: 35
this is exactly how my /etc/rc.d/rc.inet1.conf file looks right now

# Config information for eth0:
IFNAME[0]="eth0"
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for ath0:
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]=""

but im leaving the changes i made to it commented out because when i restart my card or reboot my computer dhcpcd request for ath0 takes like a minute and still doesn't get my card to work.
 
Old 07-18-2007, 09:22 AM   #12
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
This info from your one of your earlier posts is part of the problem:
Code:
ath0 IEEE 802.11g ESSID:"" Nickname:"host"
Mode:Managed Frequency:2.427 GHz Access Point: Not-Associated
Until you fix that, you won't be able to get an IP address.

Disable any security on the router - WEP, WPA, MAC address filtering, etc. Make sure the SSID is broadcast. Use iwconfig to set the SSID on your card - iwconfig ath0 essid your_ssid

Look at the output of iwconfig ath0 again to make sure it's associated. If so, try dhcpcd ath0. If not, try bringing the interface up - ifconfig ath0 up.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitor mode option unavailable with my Orinoco gold wireless card dharden26 Linux - Wireless Networking 2 04-20-2007 09:43 AM
local ip unavailable? herbietheferret Linux - Networking 9 02-26-2007 04:43 PM
apt "wireless-tools is unavailable" cheech66 Linux - Newbie 0 05-29-2004 08:37 AM
/etc/mtab unavailable zdenkod Linux - Software 4 03-29-2004 12:44 AM
Service unavailable tintin Linux - Newbie 2 11-25-2002 06:45 AM


All times are GMT -5. The time now is 03:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration