LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 03-15-2008, 11:14 AM   #1
lazylogic
Member
 
Registered: Aug 2006
Posts: 145

Rep: Reputation: 16
Intel PRO/Wireless 3945ABG Network Connection Problem


Just installed Debian Lenny (with KDE) on a Thinkpad R61.

Did the following:
Quote:
aptitude install firmware-ipw3945 ipw3945d && sudo m-a a-i ipw3945
aptitude install wpa_supplicant
and all the dependencies.

Output of lspci | grep 3945
Quote:
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
Output of ipw3945d
Quote:
ERROR: Could not find Intel PRO/Wireless 3945ABG Network Connection
I've been googling and struggling for the pass few hour and still unable to connect wireless connection. Confirmed that the hardware is okay as it works in xp.


Any help is really REALLY appreciate :-)
 
Old 03-15-2008, 12:21 PM   #2
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
What's the output of ifconfig and iwconfig? Check lsmod to see if the module is being loaded.
 
Old 03-15-2008, 12:36 PM   #3
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Also post output of the command ' /sbin/lspci -v '

Brian
 
Old 03-15-2008, 09:52 PM   #4
lazylogic
Member
 
Registered: Aug 2006
Posts: 145

Original Poster
Rep: Reputation: 16
Output of lspci -v
Quote:
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
Subsystem: Intel Corporation Unknown device 1010
Flags: bus master, fast devsel, latency 0, IRQ 22
Memory at df3ff000 (32-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>
Kernel driver in use: ipw3945
Kernel modules: ipw3945

Ouput of ifconfig (same output for iwconfig)
Quote:
eth1 unassociated ESSIDff/any
Mode:Managed Frequency=nan kHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:16 dBm
Retry limit:15 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:587 Missed beacon:0
 
Old 03-16-2008, 12:36 PM   #5
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
What are you trying to connect to? You need to configure the security settings to match the router you are trying to connect to.

There should be a file /etc/network/interfaces - you will want to configure it to apply the correct configuration settings when the interface is brought up. Post the contents of the file - there should be a stanza for eth1 - if not you'll need to add one using a text editor.

http://www.linuxmigration.com/quickref/debian/gen.html
 
Old 03-16-2008, 04:39 PM   #6
Ricio
Member
 
Registered: Sep 2003
Location: Colombia
Distribution: Debian
Posts: 220

Rep: Reputation: 30
try downloading the new iwlwifi driver, cuz the ipw driver will be left behind... and for the connection try getting knetworkmanager or networkmanager for gnome..

I think aptitude install iwlwifi* will do the trick so would aptitude install knetworkmanager --> for kde
 
Old 03-16-2008, 06:37 PM   #7
lazylogic
Member
 
Registered: Aug 2006
Posts: 145

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by pentode View Post
What are you trying to connect to? You need to configure the security settings to match the router you are trying to connect to.

There should be a file /etc/network/interfaces - you will want to configure it to apply the correct configuration settings when the interface is brought up. Post the contents of the file - there should be a stanza for eth1 - if not you'll need to add one using a text editor.

http://www.linuxmigration.com/quickref/debian/gen.html
Added the interface into /etc/network/interfaces,
ifconfig reports the interface but connection is still not there :-(
 
Old 03-16-2008, 06:38 PM   #8
lazylogic
Member
 
Registered: Aug 2006
Posts: 145

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Ricio View Post
try downloading the new iwlwifi driver, cuz the ipw driver will be left behind... and for the connection try getting knetworkmanager or networkmanager for gnome..

I think aptitude install iwlwifi* will do the trick so would aptitude install knetworkmanager --> for kde
Installed both with aptitude as suggested,
knetworkmanger reports no wireless enabled :-(
 
Old 03-17-2008, 08:26 AM   #9
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
Installed both with aptitude as suggested,
knetworkmanger reports no wireless enabled :-(
The iwlwifi drivers require a kernel patch and recompile if you're running a 2.6.23 or older kernel. Have a look at the install instructions on the Intel Wifi site.
 
Old 03-17-2008, 09:35 AM   #10
Ricio
Member
 
Registered: Sep 2003
Location: Colombia
Distribution: Debian
Posts: 220

Rep: Reputation: 30
if youre running lenny, you probably have the 2.6.23 kernel.

Remember to edit your /etc/network/interfaces add iwlwifi to it.

do --> sudo apt-get install firmware-iwlwifi, restart dbus and network daemon and try again knetworkmanager.
 
Old 03-17-2008, 10:30 AM   #11
lazylogic
Member
 
Registered: Aug 2006
Posts: 145

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Hangdog42 View Post
The iwlwifi drivers require a kernel patch and recompile if you're running a 2.6.23 or older kernel. Have a look at the install instructions on the Intel Wifi site.
Thanks all for the info..

will try them out when I am back with my box, which may take more than 24 hours :-(

will report back asap :-)
 
Old 03-21-2008, 08:01 PM   #12
lazylogic
Member
 
Registered: Aug 2006
Posts: 145

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Ricio View Post
if youre running lenny, you probably have the 2.6.23 kernel.

Remember to edit your /etc/network/interfaces add iwlwifi to it.

do --> sudo apt-get install firmware-iwlwifi, restart dbus and network daemon and try again knetworkmanager.

I am running lenny, and apt-get only list kernel of 2.6.22

How can I add 2.6.23 or even 2.6.24?

Really desparate and is willing to try new kernels in unstable.
 
Old 03-22-2008, 08:22 AM   #13
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Can I ask why you're desperate? I'm running iwl3945 on a 2.6.23 kernel without trouble. If you follow the instructions on the site I linked to, patching and recompiling the kernel modules isn't that hard. If you want a slightly different wording, I wrote up what I did to get it working here.
 
Old 03-22-2008, 11:05 AM   #14
Ricio
Member
 
Registered: Sep 2003
Location: Colombia
Distribution: Debian
Posts: 220

Rep: Reputation: 30
do the following

apt-get update
apt-get upgrade
apt-get dist-upgrade
 
Old 03-23-2008, 05:17 AM   #15
lazylogic
Member
 
Registered: Aug 2006
Posts: 145

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Hangdog42 View Post
Can I ask why you're desperate? I'm running iwl3945 on a 2.6.23 kernel without trouble. If you follow the instructions on the site I linked to, patching and recompiling the kernel modules isn't that hard. If you want a slightly different wording, I wrote up what I did to get it working here.
Frankly, I've done that process (mentioned in your link) many many times and it still doesn't work..... until now !!

YES !!!

I've finally lost my cool and start pressing the keyboard like a maniac and switching the wireless kill switch on and off...... and I get the wireless connection.

I slowly replayed my chaotic pressing of keys and finally found that toggling the wireless kill switch actually enables a connection.

Somehow (which is not logical) I need to toggle the kill switch while doing a dhclient eth1 command.

Anyway, THANKS for the patience and the help !!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PRO/Wireless 3945ABG network connection Louis_Carole Linux - Hardware 1 12-30-2007 12:54 PM
could not find intel pro/wireless 3945abg network connection verbose Linux - Hardware 22 10-03-2006 12:59 AM
Problem - Intel Intel(R) PRO/Wireless 3945ABG suresheva31 Fedora 2 09-18-2006 08:45 PM
intel pro 3945abg wireless card driver problem garfield1228 Linux - Hardware 0 04-20-2006 09:15 AM
intel pro 3945abg wireless card driver problem garfield1228 Linux - Laptop and Netbook 0 04-16-2006 09:26 AM


All times are GMT -5. The time now is 03:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration