LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Intel PRO/Wireless 2200BG (http://www.linuxquestions.org/questions/linux-wireless-networking-41/intel-pro-wireless-2200bg-200709/)

wfischer 07-03-2004 12:37 PM

Intel PRO/Wireless 2200BG
 
Hello,

Can anyone tell me if the driver located at http://ipw2100.sourceforge.net/#downloads

can be used for Intel PRO/Wireless 2200BG?

The 2100 vs. 2200 is what concerns me. Thank you. Best,

wfischer

XavierP 07-03-2004 12:52 PM

http://ipw2200.sourceforge.net/#downloads - might be more to your liking

wfischer 07-03-2004 01:11 PM

Thanks XavierP!!!

kpmanoj 10-25-2006 09:20 AM

Intel® PRO/Wireless 2200 enterprise linux 4
 
Hai ,

Any one can know how to install wirless connectivity in hp laptop, my linux is enterprsie linux 4 kernel 2.6.9-5.EL. i am try ieee80211-1.2.15 got error like . In time of makeing

Warning: could not find versions for .tmp_versions/ieee80211.mod
make[1]: Leaving directory `/usr/src/kernels/2.6.9-5.EL-i686'

in the time of make install, i got this error

Warning: could not find versions for .tmp_versions/ieee80211.mod
make[1]: Leaving directory `/usr/src/kernels/2.6.9-5.EL-i686'
install -d /lib/modules/2.6.9-5.EL/net/ieee80211/
install -m 644 -c ieee80211.ko ieee80211_crypt.ko ieee80211_crypt_wep.ko ieee80211_crypt_ccmp.ko ieee80211_crypt_tkip.ko /lib/modules/2.6.9-5.EL/net/ieee80211/
install -d `echo /lib/modules/2.6.9-5.EL/include | grep "/net\$" || echo /lib/modules/2.6.9-5.EL/include/net`
install -m 644 -c net/ieee80211.h net/ieee80211_crypt.h net/ieee80211_radiotap.h `echo /lib/modules/2.6.9-5.EL/include | grep "/net\$" || echo /lib/modules/2.6.9-5.EL/include/net`
cp Modules.symvers /lib/modules/2.6.9-5.EL/net/ieee80211/
cp: cannot stat `Modules.symvers': No such file or directory
make: [install] Error 1 (ignored)
mkdir -p /lib/modules/2.6.9-5.EL/net/ieee80211//.tmp_versions
cd .tmp_versions && install -m 644 -c ieee80211.mod ieee80211_crypt.mod ieee80211_crypt_wep.mod ieee80211_crypt_ccmp.mod ieee80211_crypt_tkip.mod /lib/modules/2.6.9-5.EL/net/ieee80211//.tmp_versions
/sbin/depmod -a 2.6.9-5.EL



In the package ipw2200-1.1.0 making time I got the error



mkdir -p /root/hp/wirless/ipw2200-1.1.0/tmp/.tmp_versions
cp /lib/modules/2.6.9-5.EL/net/ieee80211/.tmp_versions/*.mod /root/hp/wirless/ipw2200-1.1.0/tmp/.tmp_versions
make -C /lib/modules/2.6.9-5.EL/build M=/root/hp/wirless/ipw2200-1.1.0 MODVERDIR=/root/hp/wirless/ipw2200-1.1.0/tmp/.tmp_versions modules
make[1]: Entering directory `/usr/src/kernels/2.6.9-5.EL-i686'
CC [M] /root/hp/wirless/ipw2200-1.1.0/ipw2200.o
/root/hp/wirless/ipw2200-1.1.0/ipw2200.c: In function `ipw_rx_queue_alloc':
/root/hp/wirless/ipw2200-1.1.0/ipw2200.c:5050: warning: implicit declaration of function `kzalloc'
/root/hp/wirless/ipw2200-1.1.0/ipw2200.c:5050: warning: assignment makes pointer from integer without a cast
/root/hp/wirless/ipw2200-1.1.0/ipw2200.c: In function `ipw_get_wireless_stats':
/root/hp/wirless/ipw2200-1.1.0/ipw2200.c:10147: error: `IW_QUAL_NOISE_INVALID' undeclared (first use in this function)
/root/hp/wirless/ipw2200-1.1.0/ipw2200.c:10147: error: (Each undeclared identifier is reported only once
/root/hp/wirless/ipw2200-1.1.0/ipw2200.c:10147: error: for each function it appears in.)
/root/hp/wirless/ipw2200-1.1.0/ipw2200.c:10148: error: `IW_QUAL_QUAL_INVALID' undeclared (first use in this function)
/root/hp/wirless/ipw2200-1.1.0/ipw2200.c:10148: error: `IW_QUAL_LEVEL_INVALID' undeclared (first use in this function)
/root/hp/wirless/ipw2200-1.1.0/ipw2200.c:10158: error: `IW_QUAL_QUAL_UPDATED' undeclared (first use in this function)
/root/hp/wirless/ipw2200-1.1.0/ipw2200.c:10158: error: `IW_QUAL_LEVEL_UPDATED' undeclared (first use in this function)
/root/hp/wirless/ipw2200-1.1.0/ipw2200.c:10159: error: `IW_QUAL_NOISE_UPDATED' undeclared (first use in this function)
make[2]: *** [/root/hp/wirless/ipw2200-1.1.0/ipw2200.o] Error 1
make[1]: *** [_module_/root/hp/wirless/ipw2200-1.1.0] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.9-5.EL-i686'
make: *** [modules] Error 2


please give me necesary actions


All times are GMT -5. The time now is 07:51 AM.