LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-27-2005, 04:05 PM   #1
SuSE starter
LQ Newbie
 
Registered: Mar 2005
Posts: 17

Rep: Reputation: 0
Installing the D-Link AirPlus G DWL-G122 Wireless USB Adapter on SuSE 9.2


Installing the D-Link AirPlus G DWL-G122 Wireless USB Adapter on SuSE 9.2


The installation of this device requires the use of ndiswrapper because there are no Linux drivers available for it at present.
The 0.10 version of ndiswrapper on the SuSE CD however, does not recognise the hardware once I installed the package from the CD and added the windows driver to it, so a newer version has to be used in this case.
Before adding a newer version however, there is a file that has to be removed in order to prevent any conflicts between the kernel and the new version of ndiswrapper that you will use.
This is the ndiswrapper.ko file located in the /lib/modules/(your kernel version)/extra directory and it is present there by default whether you selected to install the 0.10 version from the SuSE CD or not, so it has to be deleted from this location before compiling a newer version of ndiswrapper.

Any of the ndiswrapper versions above 0.11 will recognise the hardware, so make sure you’re using one of those otherwise the wireless USB adapter will not work.

In order to use a newer version of ndiswrapper you also have to ensure that the kernel sources are installed from the SuSE CD, and in order to successfully compile the ndiswrapper source you will also require the following C compiler packages from the CD :

gcc package
binutils package
glib-devel package

You can check with YaST to see whether these packages have been installed already for you. Make sure that all these packages are installed before using the ndiswrapper source, otherwise you will receive several errors if you attempt to compile ndiswrapper without them.

To compile ndiswrapper you firstly have to extract the files from the tar.gz file that you can download from the ndiswrapper.sourceforge.net website and this should produce an ndiswrapper folder which is necessary for the compilation of the program.
The next thing to do is to open a Terminal window and sign in as root or superuser and then to enter the directory where the ndiswrapper folder is using the
cd /…/ndiswrapper-(your version) command

Once there, you can type make in the Terminal window and wait till the make operation is completed. Check to see whether you received any error message during the make operation and then type make install to complete the compilation process.

This completes the compilation of ndiswrapper and you shouldn’t receive any errors if the kernel sources and the C compiler packages have been installed in advance.

Once ndiswrapper has been compiled it can now use the Windows driver of the wireless USB adapter and allow it to operate under Linux as well.

To achieve this you firstly need to copy the Windows drivers from the installation CD of the wireless USB adapter to a folder of your choice on your hard disk.
The files that are required from the installation CD are the following :

NetRTUSB.inf
NetRTUSB.cat
rt25u98.sys
rt2500usb.sys

These files are located in the Drivers\WinXP2K\ folder of the D-Link AirPlus G DWL-G122 Wireless USB adapter installation CD.

Once you have copied these files you can then instruct ndiswrapper to use them and this is done once more by using the Terminal window signing in as root and then typing

ndiswrapper -i /(path to the folder where you copied the files from the D-Link CD)/NetRTUSB.inf

This command adds the Windows driver to the ndiswrapper module so that it can be used when the ndiswrapper module is working.

To check whether the driver has been added successfully type ndiswrapper -l and the output should tell you that netrtusb is there and that the driver and hardware are present.

The next step is to enable the kernel to use the ndiswrapper module and this is done by typing modprobe ndiswrapper

Once you type that you should notice that the green Lnk light of the wireless USB adapter will turn on after a few seconds and this indicates that the kernel is using the ndiswrapper module properly.

To complete the process you can then type ndiswrapper -m to create an alias for the ndiswrapper module in the modules.conf file

The next step is to configure the wlan0 settings for the device so that the wireless USB adapter can communicate with your access point.

The configuration of the wireless USB adapter is done using YaST and selecting Network Devices from the main menu list on the left and then choosing the Network Cards icon.
This will open the Manual network card configuration menu and you will notice that nothing is configured if you haven’t configured any other network card on your Linux system before.

To configure the wireless USB adapter first press the Configure button and in the menu that appears make the following selections:

For Device Type choose Wireless from the drop-down options

For Configuration Name choose 0 (zero)

For Hardware Configuration type static-0 if it's not already written in for you.

In the Module Name field type ndiswrapper and the Options field should be left blank.

The PCMCIA and USB tick boxes should NOT be ticked.

Once you have entered these values then press Next at the bottom of the menu.

The next menu is the Network address setup and here you can configure your static I.P. and the Subnet Mask.

By pressing the Host name and name server button you can enter the values for your DNS server in the Host name and name server configuration window. You can leave the Host Name and Domain Name as they are but under Name Server 1 you should enter your DNS server address and under Domain Search 1 you should write local.
When you have completed the DNS server configuration you can press OK to return to the previous menu for the Network address setup.

Select the Routing button if you're using a router and you can configure your Default Gateway by entering your router I.P. in the menu that opens and make sure to enable I.P. forwarding as well. Press OK once you have completed the Router configuration to return back to the Network address setup menu.

You can use the Advanced button to make further changes regarding the hardware details, additional addresses and DHCP client options if you need to.

Once you are finished, press Next to continue to the Wireless Network Card Configuration menu and here you can enter the ESSID of the access point and you can also select the operating mode and the authentication mode and the type of encryption you're using if you have enabled encryption for the wireless network. In the Expert Settings you can enter values for the Channel, Bit Rate and enable Power Management if you wish.

When you have completed the Wireless Network Card configuration you can press Next and then Finish in order for the changes to be registered and allow the network service to be activated so that the wireless USB adapter can communicate successfully with your access point.

Finally, in order to ensure that network service is activated during booting you can select System from the YaST main menu list and then choose the /etc/sysconfig Editor. From the menu tree on the left of the window, expand the System menu and then the Kernel menu so that you can see the MODULES_LOADED_ON_BOOT option. You can enter the value ndiswrapper in the field provided and then press Finish and this will enable the activation of the wireless network service every time Linux starts.

The overall procedure to enable the wireless USB adapter to communicate with your access point using SuSE 9.2 is quite lengthy and it doesn't compare at all to the instant installation of this device on Windows. However, until a native Linux driver is written for this device, there's no other alternative to make it work with Linux and I hope the steps that I have outlined here will provide sufficient help for other SuSE 9.2 users who have the same wireless USB adapter.
 
Old 05-29-2005, 11:03 AM   #2
kylnj
Member
 
Registered: May 2005
Posts: 37

Rep: Reputation: 15
hi

i have a dwl-630 card and i dont think dlink has drive for it.
do you have any idea of any work around?
thanks
 
Old 05-30-2005, 06:50 AM   #3
SuSE starter
LQ Newbie
 
Registered: Mar 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Hi kylnj,

The DWL-630 is a PCMCIA card so I believe that when you insert it in its slot, it will be identified successfully and you will not need the ndiswrapper program.

If your Linux version identifies it correctly then you can configure it using the network devices option from the YaST menu and then select network card. From the Manual network card configuration menu that will appear, select Wireless for the Device Type, then 0 for Configuration Name and finally static-0 for Hardware Configuration. Then press the Select from list button and see whether the DWL-630 model is listed there. If it's listed you can carry on with the next steps to complete the configuration and enter the relevant I.P. values etc.

Another way is to use the iwconfig command from the Terminal window. If your card has been identified automatically, you will notice that there will be a wlan0 section to the iwconfig output when you type iwconfig in the Terminal. You can then set the necessary settings for your card according to the iwconfig manual which you can see when you type man iwconfig.

You'll need ndiswrapper however, if you don't see wlan0 present when you type iwconfig or if your card isn't listed in the YaST menu.


I have outlined what you have to do to install ndiswrapper, assuming it is SuSE 9.2 that you're using, so once you follow those steps, you will be able to configure the card using YaST or iwconfig.
The drivers you should use once you have compiled ndiswrapper are the ones you have on your Windows installation CD in the Drivers directory. The files you need to copy from that folder are the .inf .cat and .sys
 
Old 05-31-2005, 03:50 AM   #4
kylnj
Member
 
Registered: May 2005
Posts: 37

Rep: Reputation: 15
hi suse starter,

thanks for ur reply.

i try to run on a dell inspiron 1100/fedora 3/2.6.11-1.27_FC3. from the pull down menu of system setting/ network, i dont see my pcmcia dwl-630g!!

i try iwconfig, it seems it try to find a extending device on lo, eth0, sit0. so i dont think the 630 was detected. i did check d-link web site and 630 dont have a driver for linux??

am i right that iwconfig is for a wireless extending of a enet interface?

thanks
 
Old 05-31-2005, 06:45 AM   #5
kylnj
Member
 
Registered: May 2005
Posts: 37

Rep: Reputation: 15
hi s starter,

i did load the ndiswrapper, with warning about '4k stack' kernel.... but i proceed

then follow the link of 'list' to see what was support and i do find my dwl-g630. showing i should download asus driver dwl138g. but i also see someone post a link saying that drive would work for him. he try ndiswrapper -i tnet1130 instead. but while i do 'ndiswrapper -l', it show installed but invalid driver!!!

so, how do i find out what XP drive i need from the cd came with hware?

thanks
 
Old 06-01-2005, 04:43 AM   #6
kylnj
Member
 
Registered: May 2005
Posts: 37

Rep: Reputation: 15
hi s starter

why iam getting error msg:

[root@kyt /home/tom/Desktop/ndiswrapper-1.1]# ndiswrapper -l
Installed ndis drivers:
mrv8ka51.sys invalid driver!

and the pcmcia card led is not on for sure.

thanks
 
Old 06-02-2005, 05:20 AM   #7
SuSE starter
LQ Newbie
 
Registered: Mar 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Hi kylnj,

From what you have written you are going to need the ndiswrapper in order to be able to use your PCMCIA card.

The Windows driver you select from your installation CD should be the .inf file instead of the .sys that you picked.

Firstly remove the .sys driver with the ndiswrapper -e mdv8ka51 command and then install the corresponding .inf file with the ndiswrapper -i command and then try ndiswrapper -l to see what the output will tell you.

I'm surprised that you have to use ndiswrapper for the PCMCIA card but anyhow, once you use the .inf instead of the .sys you shouldn't any error as far as the driver selection.

I have to also point out to you that if it's SuSE 9.2 you're using, then in order for ndsiwrapper to operate properly, you have to make sure that the ndiswrapper.ko file in the /lib/modules/(your kernel version)-default/extra directory is removed. If it's still there, you'll find that there will be a conflict between ndiswrapper versions once enter the modprobe ndiswrapper command after you add the driver you want ndiswrapper to use.

If the mdv8ka51.inf is not the correct driver and you see that the driver is not present when you type ndiswrapper -l, then you should check the list on the ndiswrapper WiKi site at

http://ndiswrapper.sourceforge.net/p...4c738af84aefd4

and find which Windows driver for your PCMCIA card is recommended for use with Linux.
 
Old 06-02-2005, 05:35 AM   #8
kylnj
Member
 
Registered: May 2005
Posts: 37

Rep: Reputation: 15
hi s starter

thanks for taking time to reply.

now i'm try to figure out what 2 do next after:

[root@kyt ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

wlan0 IEEE 802.11b ESSIDff/any
Mode:Managed Channel:0 Access Point: 00:00:00:00:00:00
Bit Rate:54 Mb/s Sensitivity=-200 dBm
RTS thr:2346 B Fragment thr:2346 B
Encryption keyff
Power Managementff
Link Quality:100/100 Signal level:-50 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


if you would pls drop me line and i will try in the mean time.

thanks again

tom
 
Old 06-02-2005, 05:37 AM   #9
kylnj
Member
 
Registered: May 2005
Posts: 37

Rep: Reputation: 15
[root@kyt ~]# ndiswrapper -l
Installed ndis drivers:
mrv8ka51 driver present, hardware present


it does find the card and the led is on now!!
 
Old 06-02-2005, 06:08 AM   #10
kylnj
Member
 
Registered: May 2005
Posts: 37

Rep: Reputation: 15
also, i can make the card to scan and does show the hub name.
how do i set it for dhcp and put into config file so it will get address itself while boot

thanks

[root@kyt ~]# iwlist wlan0 scanning
wlan0 Scan completed :
Cell 01 - Address: 00:0E:A6:7F:03:95
ESSID:"tonyhomegateway"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.412 GHz (Channel 1)
Quality:0/100 Signal level:-52 dBm Noise level:-256 dBm
Encryption keyff
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Bit Rate:18 Mb/s
Bit Rate:24 Mb/s
Bit Rate:36 Mb/s
Bit Rate:54 Mb/s
Bit Rate:6 Mb/s
Bit Rate:9 Mb/s
Bit Rate:12 Mb/s
Bit Rate:48 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 02 - Address: 00:11:24:5B:C3:23
ESSID:"Apple Network "
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.412 GHz (Channel 1)
Quality:0/100 Signal level:-95 dBm Noise level:-256 dBm
Encryption keyn
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:6 Mb/s
Bit Rate:9 Mb/s
Bit Rate:11 Mb/s
Bit Rate:12 Mb/s
Bit Rate:18 Mb/s
Bit Rate:24 Mb/s
Bit Rate:36 Mb/s
Bit Rate:48 Mb/s
Bit Rate:54 Mb/s
Extra:bcn_int=100
Extra:atim=0
 
Old 06-02-2005, 06:51 AM   #11
kylnj
Member
 
Registered: May 2005
Posts: 37

Rep: Reputation: 15
hi s starter,

sorry to post so many issue, hope you dont mind.

when i reboot the led on the card is on and i can scan the hub, and then i try to put out a fine ifcfg-wlan0 and reboot again.

it fail to get ip address and seems hanged for few minute(the card activity led is blinking) but boot didnt proceed.

any comment? thanks much





[tom@kyt /etc/sysconfig/network-scripts]$ cat if*wlan*
DEVICE=wlan0
BOOTPROTO=dhcp
onfiltered=yes
MII_NOT_SUPPORTED=yes
NEEDHOSTNAME=yes
TYPE=Wireless
ESSID="tonyhomegateway"
[tom@kyt /etc/sysconfig/network-scripts]$
 
Old 06-03-2005, 05:43 AM   #12
SuSE starter
LQ Newbie
 
Registered: Mar 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Hi again Tom,

You have succeeded with the ndiswrapper and you have added the correct driver to it and now you receive the relevant wlan0 output when you type iwconfig, so you're on the right track.

What remains, is to configure the wlan0 network properly so that your PCMCIA card can communicate with your access point.

There are two ways to do this but I recommend using YaST because you say that you want to set it up to use DHCP.

Once you start YaST you'll see the Network Devices selection on the left column and when you click there, you'll see the Network Card option.

Select Network Cards and the Manual network card configuration menu will appear and you will notice that nothing is configured if you haven’t configured any other network card on your Linux system before.

To configure the wireless PCMCIA adapter, press the Configure button and in the menu that appears make the following selections:

For Device Type choose Wireless from the drop-down options

For Configuration Name choose 0 (zero)

For Hardware Configuration type static-0 if it's not already written in for you.

In the Module Name field type ndiswrapper and the Options field should be left blank.

The PCMCIA and USB tick boxes should NOT be ticked.

Once you have entered these values then press Next at the bottom of the menu.

The next menu is the Network address setup and here you can configure your static I.P. and the Subnet Mask.

By pressing the Host name and name server button you can enter the values for your DNS server in the Host name and name server configuration window. You can leave the Host Name and Domain Name as they are but under Name Server 1 you should enter your DNS server address and under Domain Search 1 you should write local.
When you have completed the DNS server configuration you can press OK to return to the previous menu for the Network address setup.

Select the Routing button if you're using a router and you can configure your Default Gateway by entering your router I.P. in the menu that opens and make sure to enable I.P. forwarding as well. Press OK once you have completed the Router configuration to return back to the Network address setup menu.

To configure your DHCP client, use the Advanced button to make the necessary changes and press OK when you have entered the appropiate values in the DHCP client menu.
The Advanced button also gives you a selection of other menus but you do not need to make any changes in the Hardware details or Additional addresses sections.

Once you are finished, press Next to continue to the Wireless Network Card Configuration menu and here you can enter the ESSID of the access point and you can also select the operating mode and the authentication mode and the type of encryption you're using if you have enabled encryption for the wireless network. In the Expert Settings you can enter values for the Channel, Bit Rate and enable Power Management if you wish.

When you have completed the Wireless Network Card configuration, press Next and then Finish in order for the changes to be registered and allow the network service to be activated so that the wireless PCMCIA adapter can communicate successfully with your access point.

If all goes well, you should have established a connection between the PCMCIA adapter and your access point and when you open your browser in Linux you will be able to browse without any problems.

You can also read the iwconfig manual by typing man iwconfig in the Terminal window and then customise the wlan0 settings further using the commands that are explained there for you.
I do recommend you enter the access point code in this way with the iwconfig wlan0 ap command follwed by the code.
To view your access point number you can type ifconfig in the Terminal window and the wlan0 output will show you the access point number in the form of xx:xx:xx:xx:xx:xx

Finally, to start the wlan0 service during the boot process you can use YaST once more and select System from the list on the left and then choose /etc/sysconfig Editor. From the menu tree on the left of the window, expand the System menu and then the Kernel menu so that you can see the MODULES_LOADED_ON_BOOT option. Enter the value ndiswrapper in the field provided and then press Finish and this will enable the activation of the wireless network service every time Linux starts.

I hope that after following these steps you will have your PCMCIA card setup properly and everything will work without any problems.
 
Old 06-03-2005, 10:17 AM   #13
kylnj
Member
 
Registered: May 2005
Posts: 37

Rep: Reputation: 15
hi s starter,

thanks for ur reply. i am running fedora 3/ 2.6.11-1.27_FC3.
after setting up few files under /etc/sysconfig/networking/.. &./networking-scrip. but it always hang the system while reboot.

so i rename these files and manually try 'iwconfig wlan0 xxxx' to see what cause the problem. it turn out that
'iwconfig essid xxxxxxx' command is the problem. after using the command, iwconfig showing the access point's MAC accress(it always show support 802.11b, so i try rate=11M, but in vain--still showing 54M).

all the key stroke/mouse will keep on working for about 30 sec and then hang and had to recycle the power.

any comments? will try to removed ssid requirement from access point to see if i can get it working.
also will try to get YaST.

thanks
 
Old 07-06-2005, 09:50 AM   #14
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Rep: Reputation: 30
Hi there

I'm trying hard to get the D-Link DWL-G122 working on my Mandrake 10.1 set-up (I know its not Suse, but please bear with me...)

I've done everything correct I think... but when I install the netRTUSB.inf using ndiswrapper I get the following message:

Installing netrtusb
cp: cannot stat 'netRTUSB.inf' : No such file or directory

However, if I then type ndiswrapper -l I get the message

Installed ndis drivers:
netrusb invalid driver!



Any ideas what I am doing wrong??? I did cd into the correct folder and put the necessary files there too

Last edited by Adrian Baker; 07-06-2005 at 09:54 AM.
 
Old 07-06-2005, 10:17 AM   #15
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Rep: Reputation: 30
Found it....

I typed netRTUSB rather than NetRTUSB


!
 
  


Reply

Tags
dlink, ndiswrapper


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DWL-122 D-link USB adapter with SUSE 9.3 bitsnedker Linux - Newbie 2 04-29-2005 08:33 AM
Is it possible to install the D-Link DWL-G122 wireless USB adapter on SuSE 8.2 ? SuSE starter Linux - Hardware 2 03-05-2005 11:20 AM
D-Link DWL-G122 (USB) not working with ndiswrapper Anders1 Linux - Wireless Networking 8 02-27-2005 10:57 AM
Mandrake 9.1 Internet: D-Link AirPlus DWL-G520 wireless PCI Adapter khurrum Mandriva 47 12-06-2004 10:43 PM
D-Link Airplus Pci Adapter and Suse 9.0 joshsterm Linux - Wireless Networking 1 02-14-2004 03:12 AM


All times are GMT -5. The time now is 09:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration