LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 12-02-2004, 12:59 PM   #1
Groovelab
LQ Newbie
 
Registered: Dec 2004
Distribution: Kubuntu 5.04
Posts: 20

Rep: Reputation: 0
Idiots Guide to using the MN-720, MN-730 and MN-700 microsoft base station: Suse 9.x


Note: I have not only the Microsoft MN-730 Wireless G Card on an Athlon Desktop machine, but I also have the matching MN-700 "Base Station"/router.

Note 2: Microsoft networking cards use the broadcom chipset. So THEY WILL work in linux and work very well with strong signal.

OVERVIEW:
I) Get microsoft drivers for your non linux supported wireless card, mn720-ankh.inf, mn720-50.sys (for both the mn 720/730)
II) Install Suse, duh Then place drivers in a folder somewhere, remember it.
III) Goto Rpmfind.net, get the latest suse build Ndiswrapper.RPM and associated libraries
IV) Install Ndiswrapper with YAST, get any more libaries if needed to complete install
V) Run Ndiswrapper, ModProbe, and create ifcfg-wlan0 file to complete.

Step 1: NDISWRAPPER "Wraps itself around" any windows driver to operate a device for which no linux driver exists. Either installed on your windows partition (if you still have one) or can be downloaded from Microsoft.com or Google search you need to place the following files for MN-720/730 into a directory on your linux partition. Both use the same driver files:

MN720-ankh.inf (this is what ndiswrapper loads and then uses the .sys file)
MN720-50.sys

*** Since Windows doesn't recognize linux partitions, in Suse/KDE open the K-Menu by the clicking the little green round lizard button on the menu-bar. Use "Find Files", Named: = "mn720*.*" Look in: = "file:/". This will point to the root directory of your hard disk(s), and whatever you find just copy files mentioned above to a new directory wherever you like in linux.

Step 2: Collect the following information: SSID/ESSID (they are the same thing, it is a GIVEN name YOU made when installing your wireless base station, for the MN-700 base station Microsoft lovingly calls this the "WIRELESS NETWORK NAME" in its broadband utility.)

Step 3: Turn OFF your encryption, WPA, WEP, etc. on your base-station/router We will turn it on later once you're computer connects to your base station sucuesfully. Right now it is one less variable to troubleshoot. Use your windows setup utility if need be, or just use the reset button with a small pen or whatnot, to reset it to the default (Security OFF and Channel 6).

Step 4: Goto RPMFIND.net or Google search for "ndiswrapper rpm Suse". Then get the newest ndiswrapper (non development version) rpm. Get the Suse version if at all possible for Suse version 9.x. Its pretty available on the net. The i586 version will work for pentium 1 generation chips and beyond. Click the "Little Blue House" (that links to your user's home directory) on the menu-bar where most browser downloads are placed. You should see it there, but if it somehow wound up on your desktop, move it there.

Step5: Now click on your newly downloaded NdisWrapper RPM file. As long as its NOT on the desktop but in a regular file folder, the window will show you a button to automatically Install with YAST. Do this. Suse depending on your version, personal (like me), or pro like others may or may not comes with the needed "dependcies" which are files libraries used to compile the bastard Most likely is you are using the personal version you will need to also get the Suse RPMs for GCC, GLIBC, MAKE. They are all on RPMFIND.net, and if there is anything I missed, YAST will tell you, goto RPMFIND.net and get it too, install them in whatever order it likes, since one depends on another, then on another, etc.

Step 6: Once YAST has finished installing Ndiswrapper. Open a Konsole in super user mode, or just open a Konsole/Terminal and type in "su root", then enter your password from when you installed Suse. This puts you in root mode, otherwise known as super user. The following steps are done in the konsole mode as root.

Step 7: type in "ndiswrapper -i /path/to/mn720-ankh.inf" This tell ndiswrapper where the .inf and the associated .sys is.

Step 8: type in "ndiswrapper -l" This will display your installed "wrapped" microsoft drivers.

Step 9: type "modprobe ndiswrapper" This is uses the modprobe command to load a driver into linux, which points to ndiswrapper as a driver, which inturn is controlling your windows driver for your device.

Step 10: type in "iwconfig wlan0 essid [SSID name goes here]" This is the iwconfig command, which displays or sets settings for your wireless extensions. wlan0 is the default if you only have one wireless card.

Step 11: If you didnt listen to me before and left your base station's security on (WEP), then type in "iwconfig wlan0 key restricted [enter key here]"

Step 12: type in "ndiswrapper -m" which will write an alias to to the modprobe config file.

*** Normally this would finish us off, but more than likely eth0, NOT wlan0 will dominate upon reboot.***
Type in "route" at the konsole as root and it will show you whether your system behaved well, alot of times it won't. Two solutions are proposed, one creates a simple text file, one uses YAST. I used both to cover my butt

TEXT FILE:
A.) K-Menu, System, File Manager, File Manager - Super User Mode. Must be in super user.
B.) Browse "directories-folders" to /etc/sysconfig/network
C.) In that folder, look for a text file named "ifcfg-wlan0"

D.) If it exists, use Kwrite or whatever Editor from the "File" menu in the folder window, add the following lines.
DHCLIENT_MODIFY_RESOLV_CONF='yes'
DHCLIENT_SET_DEFAULT_ROUTE='yes'

*** These are very important and not only seem to fix the "route" issue, but works for linuxant and ndiswrapper (I know because a linuxant driverloader user gal told me so).

E.) If it doesn't exist, make one. It will look like the following:
BOOTPROTO='dhcp'
MTU=''
REMOTE_IPADDR=''
STARTMODE='onboot'
WIRELESS_AP=''
WIRELESS_BITRATE='auto'
WIRELESS_CHANNEL=''
WIRELESS_ESSID='pennstater'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_POWER='yes'
_nm_name='static-0'
DHCLIENT_MODIFY_RESOLV_CONF='yes'

F.) Save your file, as "ifcfg-wlan0" in the directory mentioned above. Linux will look for this as a mandatory network device upon bootup.

YAST Method:
A.) Open YAST, Network Devices, Network Card.

B.) Choose Configure button.
C.) Device Type = Wireless
Configuration Name = 0
Hardware Config. Name = static-0
Module Name = Ndiswrapper

D.) Click Wireless Settings Button
E.)Operating Mode = Managed or Auto
Network Name (ESSID) = [enter your chosen name, must match router-basestation]
Encryption Key = [Didn't I tell you to turn it off at the base station, until later????]

E.) Once done with that, use the NEXT button.
F.) Use ADVANCED, DHCP Client Options.
G.) Check the broadcast response box.

************** YAY!!!! Wholly crap you're done and you DIDN'T pay Linuxant.com 20 bucks to do the same thing and its permanent on bootup.

I hope this helps other newbies, I was a linux NooB about 3 days ago, not anymore Everything in linux is generall plug any play unless you're a nutz-fsck doin IT stuff, in which case you're not a NooB and you're not reading this

Last edited by Groovelab; 01-06-2005 at 01:28 AM.
 
Old 12-10-2004, 03:36 AM   #2
wifispy
LQ Newbie
 
Registered: Dec 2004
Location: San Diego
Distribution: Fedora
Posts: 3

Rep: Reputation: 0
thanks your instructions got the my Microsoft card working in Fedora Core 2
 
Old 12-10-2004, 05:46 AM   #3
snecklifter
Member
 
Registered: Mar 2004
Location: UK/West Yorkshire/Huddersfield
Distribution: Fedora 7
Posts: 982

Rep: Reputation: 30
Groovelab - you may wish to add these instuctions along with the new cards to this site's HCL?
 
Old 12-10-2004, 12:19 PM   #4
Groovelab
LQ Newbie
 
Registered: Dec 2004
Distribution: Kubuntu 5.04
Posts: 20

Original Poster
Rep: Reputation: 0
I could do that.

I guess I could add it to the new card list.

Who do I need to contact to do that?

Sincerely, one stressed out engineering major during finals
 
Old 12-10-2004, 12:26 PM   #5
Groovelab
LQ Newbie
 
Registered: Dec 2004
Distribution: Kubuntu 5.04
Posts: 20

Original Poster
Rep: Reputation: 0
Update to tutorial.

*If using these cards in Mandrake 10.1 , use the GUI, (K-menu, system, config, configure computer) config tool, its more straightforward and clearer, and a cleaner /etc/sysconfig/network-scripts/"ifcfg-wlan0" text file that it creates"

*Back at the driver names, Driverguide.com and google will help you locate drivers for the microsoft series cards. The "mn720-ankh.inf" IS sometimes named differently. I have been sucessful in configuring 2 different sets of drivers to work the MN-730 and ndiswrapper.

Sincerely, John
 
Old 12-11-2004, 03:36 PM   #6
snecklifter
Member
 
Registered: Mar 2004
Location: UK/West Yorkshire/Huddersfield
Distribution: Fedora 7
Posts: 982

Rep: Reputation: 30
If you're okay with it I'll submit it on your behalf. The call has been put out for more HCL additions so this will help the cause. Dont worry dude, I'm sitting my finals this year too. It'll all be over soon and then its strawberry ice-cream, sunshine and the ocean of your life ahead of you.
 
Old 12-12-2004, 01:55 AM   #7
Groovelab
LQ Newbie
 
Registered: Dec 2004
Distribution: Kubuntu 5.04
Posts: 20

Original Poster
Rep: Reputation: 0
Go for it.

Hey bud, go for it

If it helps get people over to linux and the experience I've had building not only a powerful station for my academic needs here at Penn State, the fact that an Operating System includes music creation software like Rosegarden is fantastic.

Its about time operating system caught up with the diversity of people's creativity. And its free in so many forms thanks to people of a similar phiosophy, it certainly has matured since the last time I took a crack at it back in 97'.

Sincrely, John
 
Old 12-12-2004, 03:21 PM   #8
snecklifter
Member
 
Registered: Mar 2004
Location: UK/West Yorkshire/Huddersfield
Distribution: Fedora 7
Posts: 982

Rep: Reputation: 30
Cheers John.

I submitted the MN-720 along with your guide. It should be up as soon as the mods approve the entry.

Regards
Chris
 
Old 01-05-2005, 03:38 PM   #9
troublefunk
LQ Newbie
 
Registered: Jan 2005
Location: Alexandria, VA
Distribution: Suse 9.1
Posts: 4

Rep: Reputation: 0
Groove, I really appreciate your instructions. They helped me out alot. My setup is still not working yet, but I'm getting there. At this point, my mn-720 is powered and communicating with the base station. It picks up an IP address by DHCP and I can ping the station. But that's it. I can't ping or reach anything else. The error I get is the the host is unreachable. No name resolution either so I'm wondering what's going on now. Any ideas?
 
Old 01-06-2005, 01:24 AM   #10
Groovelab
LQ Newbie
 
Registered: Dec 2004
Distribution: Kubuntu 5.04
Posts: 20

Original Poster
Rep: Reputation: 0
Well after review my old tutorial, I noticed it's overly verbose. Of course I switched distros like 10 times and have a much easier more general process now.

I also double pasted the ifcfg-wlan0 file contents, obviously all the crap thats repeated twice above, was me being stoned and hitting paste twice or whatnot.

Anyway... make sure your security is off. If possible connect your computer via ethernet to the hub and or directly to your DSL/Cable modem. Then make sure the eth0 works and you can get internet and its not something else crazy.

The MAIN reason wlan0 will show and seem to connect but you wont have internet is because SOME distrobutions will seem to "route" to eth0 as default.

In your distro's network config tool, goto eth0 and turn off "start at bootup" or whatever is similar. Also, one can run the "route" command to check whats up. Make sure wlan0 is started at bootup once you got the hardware recognized, and then also use the option to ask for "request response from hub/router" concerning wlan0 again in the config tool. Each distro calls it something slightly different.

Hope that helps ya out, if not I'll be here.

________________________________________________
TUTORIAL UPDATE: More general for multiple distros.

1.) Get your driver files from your windows partition or use www.driverguide.com just copy everything mn720 or mn*.*

2.) Burn them to a removable media, like a cd-r or even a floppy disk.

3.) Install linux, open a terminal window as "su root" and then enter your password.

4.) Copy files from your removable media to /home/mn720 or some arbitrary directory.

5.) Run ndiswrapper in the "root" terminal window.
5a.) ndiswrapper -i /home/mn720/mn720.inf (this will install the mn720-50.sys or whatnot into the wrapper)
5b.) ndiswrapper -l (will list and verify your hardware is detected)
5c) ndiswrapper -m (adds ndiswrapper alias to modprobe.conf)

6.) Cross your fingers, run "modprobe ndiswrapper" command in your terminal window. (The modprobe command installs hardware or devices, then points to the ndiswrapper which now has your windows API based drivers in use).

7.) Manually create a ifcfg-wlan0 file in /etc/sysconfig/network or similarly named directory or use a handy KDE or Gnome network config program that will edit or create the file for you specific to YOUR distrobution.

***Make sure you use the settings double copied above, or you simply have to enter the correct SSID and make sure wlan0 points to "ndiswrapper" in the config utility. Since that is where your driver resides

Restart your network or reboot. And there ya go. I've got it working in like 7 different distros with slightly different fudging, but same process.

Whomever submitted the original tutorial, based on my early work I hope will make this an addendum.

JOHN
 
Old 03-07-2006, 07:31 PM   #11
Thorlord
LQ Newbie
 
Registered: Mar 2006
Location: Oregon
Distribution: SuSE 10.0
Posts: 7

Rep: Reputation: 0
how do we get the wireless encription back on?
you said to turn it off and it would be explained later on how to turn it back on.

well help on getting it back on would be very much appriciaited.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DISCUSSION: Guide to NdisWrapper for MN-720 MN-730 Microsoft Wireless Cards in Groovelab LinuxAnswers Discussion 4 10-27-2005 08:56 AM
Microsoft MN-720 wireless card to work on SUSE Linux 9.1 Professional maxtothemax1004 Linux - Wireless Networking 1 09-16-2005 12:08 PM
Idiots guide to debian mcgworld Debian 3 02-19-2005 12:51 PM
How I got the Microsoft MN-720 (802.11g) card working in Suse 9.0 -=Sabin=- Linux - Wireless Networking 25 03-20-2004 09:48 PM
Is there a complete guide for Postfix for idiots? ziggie216 Linux - Software 1 11-12-2003 06:12 AM


All times are GMT -5. The time now is 03:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration