Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.


  Search this Thread
Old 12-13-2010, 09:42 PM   #1
Registered: Apr 2005
Location: Durban
Posts: 391

Rep: Reputation: 30
ibdriver and the 2.6.35-23-generic-pae kernel

I need to get my iBurst Kyocera USB pppoe dongle working.

Unfortunately the 2.6.31 kernel removed deprecated network API calls which broke th ibdriver.

However, I found a patch here:

Although this fixes a lot of the issues, I still get the following errors when I try to 'make' the ibdriver:
make -C /lib/modules/2.6.35-23-generic-pae/build SUBDIRS=/home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28 modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.35-23-generic-pae'
CC [M] /home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28/ib-net.o
/home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28/ib-net.c: In function ‘ib_net_setup’:
/home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28/ib-net.c:516: warning: statement with no effect
CC [M] /home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28/ib-pcmcia.o
/home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28/ib-pcmcia.c:105: error: field ‘node’ has incomplete type
/home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28/ib-pcmcia.c: In function ‘ib_pcmcia_config’:
/home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28/ib-pcmcia.c:601: error: implicit declaration of function ‘pcmcia_get_first_tuple’
/home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28/ib-pcmcia.c:604: error: implicit declaration of function ‘pcmcia_get_tuple_data’
/home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28/ib-pcmcia.c:672: error: implicit declaration of function ‘pcmcia_get_next_tuple’
/home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28/ib-pcmcia.c:685: warning: assignment makes integer from pointer without a cast
/home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28/ib-pcmcia.c:686: warning: passing argument 1 of ‘pcmcia_request_window’ from incompatible pointer type
include/pcmcia/ds.h:203: note: expected ‘struct pcmcia_device *’ but argument is of type ‘struct pcmcia_device **’
make[2]: *** [/home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28/ib-pcmcia.o] Error 1
make[1]: *** [_module_/home/dave/Downloads/hardware/drivers/ibdriver-1.3.4-linux-2.6.28] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-23-generic-pae'
make: *** [default] Error 2
Can anyone give me assistance on how to resolve these?

Alternatively, the pppoe package in Ubuntu 10.10 describes itself as drivers for pppoe devices, but I am unable to see how to get it to see my modem.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Build driver failed in PAE platform with linux kernel steven215 Programming 3 01-19-2014 06:11 PM
KERNEL PANIC: Cannot execute a PAE-enabled kernel on a PAE-less CPU! ovais370 Linux - Laptop and Netbook 7 10-13-2007 06:49 PM
PAE Kernel stumpedguy_frustrate Fedora 5 07-22-2007 10:46 PM
New update Kernel-bigsmp-Kernel with PAE Support raylhm SUSE / openSUSE 2 07-15-2007 04:42 PM
How do I open ports on my generic conexant PRI PAE CE84 router scarymary Linux - Newbie 1 04-29-2005 01:14 PM

All times are GMT -5. The time now is 01:28 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration