LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 11-19-2008, 02:21 AM   #16
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 288Reputation: 288Reputation: 288

ifconfig shows that wlan0 is running, and you are transeferring (Tx) and recieving (Rx) packets.
sudo iwlist wlan0 scanning shows 2 networks detected. One has a essid Lan, and the other one's essid is MACCABI-TLV. Both show "Encryption key on", so it appears they are both password protected.

I assume you know which essid belongs to your router, and what you WEP key is. Since your wireless works in Windows, just open up internet explorer in Windows and type 192.168.0.1 (or whatever your router's address is) into the address bar of internet explorer to access your router's configuration if you need to check it.

Linux is case sensitive. So if the "cell 01" which has an essid of "Lan" is your router, to connect to it run:
Code:
sudo iwconfig wlan0 essid Lan
sudo iwconfig wlan0 key YOUR_WEP_HEX_KEY_HERE
sudo dhclient wlan0
You will substitute your router's WEP key for YOUR_WEP_HEX_KEY_HERE in the example above. Run those commands and post the output here. (You can edit out your WEP key abd replace it with XXXs when you post back).
If that still does not work, then go into your router's configuration and turn off encryption to see if you can connect without encryption.

Your wireless is working. "sudo iwlist wlan0 scanning" is detecting the 2 networks. You just need to associate your wireless card with one of them, give the encryption key, and get an IP address. That is what the commands in the code box above are for.

Last edited by tommcd; 11-19-2008 at 02:31 AM.
 
Old 11-19-2008, 08:01 AM   #17
someone Awesome
Member
 
Registered: Nov 2008
Posts: 70

Original Poster
Rep: Reputation: 17
ok iwrote "lan" instead of "Lan"
i guess that did the trick
 
Old 11-19-2008, 10:29 AM   #18
someone Awesome
Member
 
Registered: Nov 2008
Posts: 70

Original Poster
Rep: Reputation: 17
still the same message even if i write

sudo iwconfig wlan0 essid sgljl;sgkjl;sfkj
sudo iwconfig wlan0 key sjsshshkdghkdhgk
sudo dhclient wlan0

and if write the real one
 
Old 11-20-2008, 04:42 AM   #19
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 288Reputation: 288Reputation: 288
Quote:
Originally Posted by someone Awesome View Post
still the same message even if i write

sudo iwconfig wlan0 essid sgljl;sgkjl;sfkj
sudo iwconfig wlan0 key sjsshshkdghkdhgk
sudo dhclient wlan0

and if write the real one
Can you post the output of those 3 commands please?
Code:
sudo iwconfig wlan0 essid Lan
sudo iwconfig wlan0 key your_WEP_key
sudo dhclient wlan0
iwlist identified your router as "Lan" not "lan" so you should probably run it with an upper case L. But try it both ways if it doesn't work.
 
Old 11-20-2008, 09:10 AM   #20
someone Awesome
Member
 
Registered: Nov 2008
Posts: 70

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by someone Awesome View Post
ido9@ido9-desktop:~$ sudo ifconfig
[sudo] password for ido9:
Sorry, try again.
[sudo] password for ido9:
eth0 Link encap:Ethernet HWaddr 00:0f:ea:51:e7:3b
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:21

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1 bytes:121000 (118.1 KB)

wlan0 Link encap:Ethernet HWaddr 00:13:d4:f4:bb:dc
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:2420 errors:0 dropped:0 overruns:0 frame:0
TX packets:2420 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:121000 (118.1 KB) TX
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wmaster0 Link encap:UNSPEC HWaddr 00-13-D4-F4-BB-DC-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

ido9@ido9-desktop:~$ sudo iwlist wlan0 scanning
wlan0 Scan completed :
Cell 01 - Address: 00:0F:CB:B5:32:3C
ESSID:"Lan"
Mode:Master
Channel:7
Frequency:2.442 GHz (Channel 7)
Quality=50/100 Signal level=-58 dBm
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=000000000bde2dcd
Cell 02 - Address: 00:1B:9E:1D:55:E8
ESSID:"MACCABI-TLV"
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=47/100 Signal level=-78 dBm
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:tsf=0000003fc8f36ac6

ido9@ido9-desktop:~$ sudo iwlist wlan0 scanning
wlan0 Scan completed :
Cell 01 - Address: 00:0F:CB:B5:32:3C
ESSID:"Lan"
Mode:Master
Channel:7
Frequency:2.442 GHz (Channel 7)
Quality=50/100 Signal level=-56 dBm
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=000000000da1a5b5
Cell 02 - Address: 00:1B:9E:1D:55:E8
ESSID:"MACCABI-TLV"
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=46/100 Signal level=-79 dBm
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:tsf=0000003fca834972

ido9@ido9-desktop:~$ sudo iwconfig wlan0 essid
Error for wireless request "Set ESSID" (8B1A) :
too few arguments.
ido9@ido9-desktop:~$ sudo iwconfig wlan0 essid
Error for wireless request "Set ESSID" (8B1A) :
too few arguments.
ido9@ido9-desktop:~$ sudo iwconfig wlan0 essid lAN
ido9@ido9-desktop:~$ sudo iwconfig wlan0 key $$$
ido9@ido9-desktop:~$ sudo dhclient wlan0
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:13:d4:f4:bb:dc
Sending on LPF/wlan0/00:13:d4:f4:bb:dc
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
No DHCPOFFERS received.
No working leases in persistent database - sleeping.


the one without the password doesn't appear here
i tryed my network see the above log /\/\/\/\

i wasnt clear that is what i got (whats bold) when i typed lan or Lan or modmsfjhndjkdfnjadkhnadfjkadghjkadafjkdfhjkdfhdfkjhdfkjhadfjk
ok?
 
Old 11-21-2008, 03:55 AM   #21
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 288Reputation: 288Reputation: 288
Everything looks good until it tries to get an IP address using dhclient. Perhaps try turning off encryption on the router and try those commands again. Try running dhclient a few times. Sometimes it may not connect on the first try.
 
Old 11-21-2008, 06:10 AM   #22
someone Awesome
Member
 
Registered: Nov 2008
Posts: 70

Original Poster
Rep: Reputation: 17
well a few days ago the enencrypted network came back and it didnt do anything (stil got the above answer)
ad i tryed it planty of times maybe its wubi's fault and i should download reguler linux
 
Old 11-22-2008, 01:00 AM   #23
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 288Reputation: 288Reputation: 288
Quote:
Originally Posted by someone Awesome View Post
well a few days ago the enencrypted network came back and it didnt do anything (stil got the above answer)
Does this mean you tried it without encryption? I think you should try it without encryption just to see if it will connect. Your wireless is working. It is reliably detecting the 2 networks (as verified by "iwlist wlan0 scanning"). If you remove encryption, all you need to do is associate the wireless card with your router:
Code:
sudo iwconfig wlan0 essid Lan
sudo iwconfig wlan0 essid lan
Try it both ways if "Lan" doesn't work. If you do connect without encryption, then we can work on getting encryption working.
Quote:
Originally Posted by someone Awesome View Post
ad i tryed it planty of times maybe its wubi's fault and i should download reguler linux
This could be possible. I have never used Wubi, and I know very little about it. There may be some complicating factor using wireless with Ubuntu through Wubi that I am not aware of.
By the way, how does Wubi work anyway? When you boot your computer, do you get to choose to boot Windows or Ubuntu? Or do you you boot Windows normally, then load Ubuntu inside Windows, like launching any other program in Windows?

If you decide to partition your hard drive and install Ubuntu to it's own partition (the usual way of installing linux) here is a good site to get you started:
http://www.psychocats.net/ubuntu/
And see this tutorial:
http://www.howtoforge.com/the-perfec...op-ubuntu-8.10
Or if you wat to stick with Ubuntu 8.04 LTS:
http://www.howtoforge.com/the-perfec...ts-hardy-heron
Remember to defrag Windows first, before partitioning and installing Ubuntu.
I would go with Ubuntu 8.10 since it is newer, and it just may have better support for your wireless. The Ralink wireless drivers work well in both versions, though 8.10 will have newer versions of those drivers.
Sorry we can't seem to get your wireless going. It's frustrating, because you are 90% of the way there. Your wireless drivers are loaded, and iwlist detcts your router. All you need to do is associate your wireless card with the router, provide the encryption key (like I have explained) and you are good to go.
Since you are using a desktop, can't you just hook up an ethernet cable from your router to the computer and use the wired connection?

Last edited by tommcd; 11-22-2008 at 01:13 AM.
 
  


Reply

Tags
internet


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
setting up wlan card asus wl-138g 802.11g ronald_dodd Linux - Wireless Networking 1 12-17-2012 11:19 AM
Asus 802.11g network driver ciritus Linux - Software 3 09-26-2008 06:30 AM
Help me problems with wireless card ASUS IEEE 802.11g model WL-107g xuxanodedo Linux - Wireless Networking 1 01-10-2008 04:32 PM
CNet Wireless-G USB Dongle 54 Mbps 802.11g, WPA/AES/WPA2 compatible to SuSe 10.1? ungua Linux - Hardware 2 06-14-2007 06:31 AM
Need 802.11g (54 Mbps) Wireless card for SuSE 9.1 MasterPatricko Linux - Wireless Networking 0 09-04-2004 05:16 AM


All times are GMT -5. The time now is 02:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration